Showing results for 
Search instead for 
Did you mean: 

JVM crashes on startup. (Error 8 allocating x Bytes)

Former Member
0 Kudos


I recently installed Netweaver 2004s SR2 Developer Workplace in my Windows XP development machine (Core 2 Duo 2,33Ghz and 2GB of RAM).

The problem is that I haven't been able to start the J2EE engine. I checked the "Developer Trace" (on SAP MMC) and apparently it was an issue with some misplaced dlls (see notes: 943602, 940893, 736462, 856393, 129813 and 664269) which could be corrected by setting some environment variables in order to tell jlaunch to preload the conflicting dlls.

However, after a more detailed analysis of the logs I found that there was another error. Here is the relevant excerpt from std_server0.out:

stdout/stderr redirect
node name   : server0
pid         : 2716
system name : DW0
system nr.  : 00
started at  : Tue Apr 10 15:33:32 2007

Error 8 allocating 0x70000000 Bytes at 0x0

Then there is the address space layout for jlaunch and then the final part of the message:

Address                   : 0.005 sec
Elapsed Time              : 0.010 sec
Virtual total             :        0 K
Virtual free              :  2073304 K
Virtual commit            :    17780 K
Virtual reserve           :     5940 K

[Thr 3904] MtxInit: -2 0 0
Error occurred during initialization of VM
Could not reserve enough space for object heap

Does anybody know what does that Error 8 mean and how can I solve it? Thanks in advance for any help.

Accepted Solutions (1)

Accepted Solutions (1)

0 Kudos

Hi Salvador,

Please upgrade your jdk and jre.

I have also installed the same package recently.

The version of jdk, ,jce and jre is 1.4.2_13.

If you have this or higher, then there problem can be somewhere else.

Check out the SAP notes.



Former Member
0 Kudos

Hi Prashil, thank you very much for your suggestion. However, I'm almost certain that I'm trying to run the engine with jdk 1.4.2_13. I'll try uninstalling all other versions of the jdk (as I have 1.5 and 1.6 also installed) and I'll let you know how it went.

Also, do you know what does that Error 8 mean or where could I find such information?



0 Kudos

Hi Salvador,

No i don't have much idea regarding the error. But the SAP notes that were suggested (943602, 940893, 736462, 856393, 129813 and 664269) is all related to JDK and JRE version.

Thats why i am pretty sure that your the issue is with java versioning only.

I would suggest uninstall all JDK and JRE on the system and configure only for JDK 1.4.2_13.

Please also take care that the JAVA_HOME and classpath is properly configured.

Award points if you feel the solution is helpful!!!!



Former Member
0 Kudos

Well, I uninstalled all other jdk and jre in my machine but still no luck.

JAVA_HOME and PATH are also correctly set (although there is another env. variable called "Path", could this one conflict with PATH?).

I also tried adding environment variables for preloading dlls but when the memory reservation fails, the preloading doesn't take place.At this point I'm pretty sure it's a memory allocation issue but I just don't know how to solve it, is there any way to limit the maximum memory allocation for an application? Is there a setting I can change in windows?

Sorry for not rewarding points yet, but I don't feel the answers were helpful.



0 Kudos

Hi Salvador,

You can try to increase the virtual memory. Its in context menu of the "My computer--> Advanced" tab in the Setting for the Performance Advance table change the virtual memory allocation.

Hope this helps!!!

Former Member
0 Kudos

Well, that's one of the first things I tried, it is set to the maximum (4G) so I can't increase it anymore.

Now, just to make sure, am I supposed to have 2 instances of jlaunch running after trying to lauch the j2ee engine?

And could you tell me what I should see in the std_server0.out ? (or what do you have in it)

The part that intrigues me the most is this one:


Virtual free : 2020660 K

Virtual commit : 27316 K

<b>Virtual reserve : 48988 K</b>


So, does that mean that it reserved only 48988K of virtual memory? Even though there are almost 2G of free virtual memory ?

0 Kudos

No i have only 1 instance of jlanch.

I am posting what i have in my std_server0.out


stdout/stderr redirect


node name : server0

pid : 2728

system name : HNW

system nr. : 00

started at : Tue Apr 10 17:00:32 2007

Reserved 1610612736 (0x60000000) bytes before loading DLLs.

[Thr 3688] MtxInit: -2 0 0

CompilerOracle: exclude com/sapportals/portal/pb/layout/taglib/ContainerTag addIviewResources

CompilerOracle: exclude com/sap/engine/services/keystore/impl/security/CodeBasedSecurityConnector getApplicationDomain

CompilerOracle: exclude com/sap/engine/services/rmi_p4/P4StubSkeletonGenerator generateStub

CompilerOracle: exclude com/sapportals/portal/prt/util/StringUtils escapeToJS

CompilerOracle: exclude com/sapportals/portal/prt/core/broker/PortalServiceItem startServices

CompilerOracle: exclude com/sap/engine/services/webservices/server/deploy/WSConfigurationHandler downloadFile

CompilerOracle: exclude com/sapportals/portal/prt/jndisupport/util/AbstractHierarchicalContext lookup

CompilerOracle: exclude com/sapportals/portal/navigation/cache/CacheNavigationNode getAttributeValue

CompilerOracle: exclude com/sapportals/portal/navigation/TopLevelNavigationiView PrintNode

CompilerOracle: exclude com/sapportals/wcm/service/ice/wcm/ICEPropertiesCoder encode

CompilerOracle: exclude com/sap/lcr/pers/delta/importing/ObjectLoader loadObjects

CompilerOracle: exclude com/sap/engine/services/webservices/jaxrpc/encoding/InstanceBuilder readElement

CompilerOracle: exclude com/sap/engine/services/webservices/jaxrpc/encoding/InstanceBuilder readSequence

CompilerOracle: exclude com/sap/engine/services/webservices/jaxrpc/encoding/TypeMappingImpl initializeRelations

CompilerOracle: exclude com/sap/engine/services/webservices/jaxrpc/encoding/GeneratedComplexType _loadInto

SAP J2EE Engine Version 7.00 PatchLevel is starting...

Error occurred while preloading classes of security providers from jre/lib/ext folder: The filename, directory name, or volume label syntax is incorrect

Loading: LogManager ... 4024 ms.

Loading: PoolManager ... 47 ms.

Loading: ApplicationThreadManager ... 297 ms.

Loading: ThreadManager ... 47 ms.

Loading: IpVerificationManager ... 47 ms.

Loading: ClassLoaderManager ... 204 ms.

Loading: ClusterManager ... 1424 ms.

Loading: LockingManager ... 595 ms.

Loading: ConfigurationManager ... 13355 ms.

Loading: LicensingManager ... 79 ms.

Loading: CacheManager ... 438 ms.

Loading: ServiceManager ...

Loading services.:

Service DQE started. (16 ms).

Service runtimeinfo started. (141 ms).

Service memory started. (157 ms).

Service timeout started. (47 ms).

Service cross started. (266 ms).

Service file started. (391 ms).

Service cafeuodi~mnuacc started. (0 ms).

Service trex.service started. (47 ms).

Service p4 started. (689 ms).

Service classpath_resolver started. (109 ms).

Service cafeucc~api started. (2630 ms).

Service userstore started. (47 ms).

Service jmx_notification started. (501 ms).

Service log_configurator started. (9378 ms).

Service locking started. (0 ms).

Service naming started. (1049 ms).

Service ts started. (110 ms).

Service javamail started. (376 ms).

Service failover started. (47 ms).

Service licensing started. (16 ms).

Service http started. (1534 ms).

Service appclient started. (141 ms).

Service jmsconnector started. (78 ms).

Service iiop started. (1096 ms).

Service connector started. (313 ms).

Service webservices started. (1284 ms).

Service deploy started. (25332 ms).

Service configuration started. (47 ms).

Service MigrationService started. (31 ms).

Service bimmrdeployer started. (16 ms).

Service dbpool started. (2928 ms).

Service cafeugpmailcf started. (63 ms).

Service started. (2176 ms).

Service security started. (2129 ms).

Service applocking started. (94 ms).

Service classload started. (266 ms).

Service jmx started. (783 ms).

Service ejb started. (892 ms).

Service shell started. (2599 ms).

Service tceCATTPingservice started. (16 ms).

Service prtbridge started. (486 ms).

Service servlet_jsp started. (4086 ms).

Service keystore started. (4416 ms).

Service telnet started. (1456 ms).

Service dsr started. (3992 ms).

Service ssl started. (16 ms).

Service basicadmin started. (4195 ms).

Service adminadapter started. (141 ms).

Service com.adobe~LicenseService started. (2302 ms).

Service tc.monitoring.logviewer started. (5323 ms).

Service apptracing started. (5918 ms).

Service tcsecsecurestorage~service started. (4400 ms).

Service cafummetadata~imp started. (9112 ms).

Service com.adobe~DocumentServicesConfiguration started. (1440 ms).

Service tcsecwssec~service started. (141 ms).

Service monitor started. (1895 ms).

Service CUL started. (10490 ms).

Service started. (7515 ms).

Service webdynpro started. (9895 ms).

Service started. (861 ms).

Service com.adobe~DataManagerService started. (11304 ms).

Service cafruntimeconnectivity~impl started. (42852 ms).

Service developmentserver started. (9582 ms).

Service cafumrelgroups~imp started. (4258 ms).

Service rfcengine started. (12682 ms).

Service com.adobe~DocumentServicesLicenseSupportService started. (970 ms).

Service com.adobe~TrustManagerService started. (156 ms).

Service sld started. (5762 ms).

Service tcsecdestinations~service started. (6090 ms).

Service com.adobe~DocumentServicesBinaries2 started. (1597 ms).

Service pmi started. (31 ms).

Service jms_provider started. (14654 ms).

Service com.adobe~DocumentServicesDestProtoService started. (345 ms).

Service tcsecvsi~service started. (924 ms).

Service cafeugp~model started. (15 ms).

Service tceujwfuiwizsvc started. (0 ms).

Service com.adobe~PDFManipulation started. (20588 ms).

Service cafeuer~service started. (8313 ms).

Service com.adobe~FontManagerService started. (27555 ms).

Service com.adobe~XMLFormService started. (11758 ms).

ServiceManager started for 104726 ms.

Framework started for 125815 ms.

SAP J2EE Engine Version 7.00 PatchLevel is running!

PatchLevel September 11, 2006 16:35 GMT


Hope this helps!!!!



Former Member
0 Kudos

I managed to get rid of the memory allocation error by entering a lower value for the environment variable jlaunch/ReserveSize (It doesn't work for 0x60000000 but it does for 0x40000000).

Unfortunately there were still dlls fragmenting my address space, so I tried to restore my computer to a previous state and now I can't boot Windows.

I'll have to try an installation repair and if that doesn't work I'll have to reinstall the whole system.

Answers (1)

Answers (1)

Former Member
0 Kudos

So, to summarize:

Error 8 allocating x Bytes at 0x0000 

means that jlaunch is trying to reserve too much memory. Try creating environment variable jlaunch/ReserveSize and setting it's value to something lower. Once the memory allocation is reported as sucessful in std_server0.out you can start tackling the memory fragmentation (preloading dlls with jlaunch/PreloadDLLs environment variable)

0 Kudos

Thanks for the solution!!!!!

That will help if anybody stuck with same kind of solution

Best Regards,