cancel
Showing results for 
Search instead for 
Did you mean: 

JR Crystal Reports, Getting QE Error : Unable to find parameter ''{0}''

Former Member
0 Kudos

I am getting the Error

QE Error unable to locate the parameter ''''

Kindly help me in resolving this.

I am using Tomcat 6.0 Application server and Crystal Reports 11.

I am getting the reports in the PDF format(export) by setting the resultset fot stored procedures.

When there are more than one stored procedures defined in report this error is coming otherwise not.

Regards.

Kazim Raza.

Accepted Solutions (1)

Accepted Solutions (1)

ted_ueda
Employee
Employee
0 Kudos

I don't believe that version of Tomcat is on the supported list for the version of the Java Reporting Component (JRC) you're using.

However, I'd like to know, from your comments concerning 'resultsets' whether you're "pushing" or "pulling" data.

"Pushing" means you're using Java code to connect to your data set, retrieve the ResultSet instance, then pushing it into the report.

"Pulling" means you're creating a Crystal Report, configuring the data source where Crystal should get data, and allowing the JRC to connect to the data source directly.

If you're "pushing" data over a parametrized stored procedure, the stored proc parameters will be removed from the report.

Sincerely,

Ted Ueda

Former Member
0 Kudos

I am Pushing the Data and getting the ResultSet from my Java JDBC Datasource and passing it to the Crystal reports in setDataSource() method, but when I do this using a single SP in my report it is working fine but its not for the case of multiple SP's

Kindly Let me know how to resolve this issue,

Thanks.

ted_ueda
Employee
Employee
0 Kudos

I'd recommend upgrading to CR4E JRC - the newest version:

[https://boc.sdn.sap.com/node/19020|https://boc.sdn.sap.com/node/19020]

Checked with a small report here - appears to work with injecting two ResultSets to two different tables in the report.

Sincerely,

Ted Ueda

Answers (0)