cancel
Showing results for 
Search instead for 
Did you mean: 

JMS receiver error

Werner_Magerl
Participant
0 Kudos

Hello,

I have maintained a JMS receiver adapter to an existing MQ system (IBM WebSphere 6.0)

After deploying the modules to PI (7.11) the adapter goes green but allways says "Sucessfully disconnected from destination".

When sending a message through this adapter I get the error message:

"Message processing failed. Cause: com.sap.engine.interfaces.messaging.api.exception.MessagingException: No transition found from state: STARTING, on event: process_commence for DFA: JMSReceiver_ATLAS_MQ:4b9d8e8dfe883ebeb7ab5af79e59cdf6"

I can not find out where the problem can be....I played arrounf with the several options for QM Manasger, channels.....

I do not use any "Advanced Adapter options"

Anybody who can help me????

best regards

Werner

View Entire Topic
venkatanarayana_vagu
Active Participant
0 Kudos

Hello warner,

First please again cross verify you JMS deployment in PI server.

1138877 PI 7.1 : How to Deploy External Drivers JDBC/JMS Adapters

/people/peng.shen2/blog/2010/06/08/how-to-deploy-pi-7071-jdbc-drivers (blog)

If the deployment is OK please check these JMS FAQ and other notes,

856346 J2EE JMS Adapter: Frequently Asked Questions (FAQ)

990629 J2SE JMS Adapter: Missing mandatory element <sap:queueId>

1493689 JMS Adapter not working in J2SE Adapter Engine.

1305390 JMS Adapter: On Demand Connection (New Feature)

Werner_Magerl
Participant
0 Kudos

I still have checked all the notes and blogs....

But nothing helps, I still have the same problem.

The problem can be, that I am not a MQ specialist, but I have access to the MQ and I can see the settings.

Do I have to use adapter specific atributes???

I only use QManager, Chanell, queue....

ANd there is somehting other really strange.

I have create several components for different scenarios.

When I create an Adapter in one component, I get the error I listed before.

But in some components I get the error:

"Channel Has Internal Error" in the RWB overview and in the node

"Adapter had not provided any status infomration about this channel"

I tried with Creating new channel, copy channel between the components....

but allways the same...in some components I get this error

in other components I get the message "Successfully discponnected from destination"

Werner

Edited by: Werner Magerl on Sep 28, 2010 1:59 PM

Former Member
0 Kudos

I am getting similar issue. Can you tell me how did you solve this ?

Nitin

Former Member
0 Kudos

Hi,

Please check JMS adapter protocol and configuration.

Also try this blog

Regards,

Dipali

Werner_Magerl
Participant
0 Kudos

Hello Nitin,

there are three important things I found out....

1) check and recheck the libraries you deploy on the PI system...this is very important to have the correct version

2) you define a MQ channel in the configuration....this must be a specific server channel....check for OSS note for JMS adapter (I do not remember at the moment)

3) I had to define a user MQ Server, because PI adapter is using specific PI user to logon, but this user did not exists.....

Main reason is 1) and 2).....and then it worked and all other error message are really clear.....

best regards

Werner