cancel
Showing results forΒ 
Search instead forΒ 
Did you mean:Β 

Java Version /SAP JVM compatibility with SAP JAVA based applications.

0 Kudos

Hi Friends,

Please provide your valuable inputs on below question(s). Thanks in advance πŸ™‚

Q1 - is there any relation of java of IBM OS i.e AIX with SAP Product?

our AIX (OS team) planning to upgrade java version and asking us to check compatibility of latest JAVA version with sap ?

i am thinking that from SAP NW 7.1 on wards SAP has it's own JVM so there is no dependency with AIX java(OS) with SAP applications.? please correct me if am wrong

Q2 - Where can we find out SAM JVM compatibility with respective SAP product(like NW 7.31etc..) ?

Accepted Solutions (1)

Accepted Solutions (1)

0 Kudos

Hi Masthanamma Mandadi,

Please see my answers on your queastions:

Q1 - is there any relation of java of IBM OS i.e AIX with SAP Product?

You think right, that SAP NW AS Java products are using our own SAP JVM that is not the same java as used by OS. However, there is dependency between OS and AS Java as well, that can be checked in Product Availability matrix.

Q2 - Where can we find out SAP JVM compatibility with respective SAP product(like NW 7.31etc..) ?

You can check the same at Product Availability Matrix. or there are some KBAs that are describing these. Here is a complete table with information regarding SAP NW AS Java , SAP JVM and SAP Kernel:

I hope this will be helpful for you.

BR,

Csaba

0 Kudos

Hi Csaba,

Thanks a lot for your prompt reply πŸ™‚

So there will not be any effect to SAP JAVA application servers due to JAVA upgrade at AIX Level (OS Level) right?

i believe for SAP ABAP Applications there there is no concept of SAP JVM ? right correct me if am wrong

once Thank you so much for your information.

Regards, Masthanamma

Answers (2)

Answers (2)

0 Kudos

Hi Masthanamma,

You're very welcome. You can upvote it if you think it will be useful for later visitors of this question as well.

Regarding your latest question:

No, updating Java at OS level should not have any affect on AS Java and SAP JVM.

SAP AS ABAP should not use SAP JVM, however it could be surely stated by AS ABAP expert, but in my opinion there is no reason for ABAP to use SAP JVM.

BR,

Csaba

0 Kudos

Thanks a lot for your prompt reply πŸ™‚

So there will not be any effect to SAP JAVA application servers due to JAVA upgrade at AIX Level (OS Level) right?

i believe for SAP ABAP Applications there there is no concept of SAP JVM ? right correct me if am wrong

once Thank you so much for your information.

Regards, Masthanamma