cancel
Showing results for 
Search instead for 
Did you mean: 

java.lang.RuntimeException: Could not DER encode the public key

0 Kudos
173

We're facing this error while running our Business Objects from AWS, any help here please?

java.lang.RuntimeException: Could not DER encode the public key. (No OID for this transformation.) at com.crystaldecisions.enterprise.ocaframework.ServiceMgr.<init>(ServiceMgr.java:620) at com.crystaldecisions.enterprise.ocaframework.ServiceMgrFactory.getServiceMgr(ServiceMgrFactory.java:64) at com.crystaldecisions.sdk.occa.security.internal.SecurityMgr.<init>(SecurityMgr.java:120) at com.crystaldecisions.sdk.occa.security.internal.SecurityFactory.makeSecurityMgr(SecurityFactory.java:155)

0 Kudos

Was there a solution to this problem? I'm getting the same error now.

sveabecker
Community Advocate
Community Advocate
0 Kudos

Welcome and Thank you for visiting SAP Community to get answers to your questions. Please add more details to your question, e.g. you can also add a screenshot. With that, you can reach a broader range of experts to get your question answered. I also recommend to do this tutorial https://developers.sap.com/tutorials/community-qa.html

The more details you provide, the more likely it is that members will be able to assist you.

Finally, if you're hoping to connect with readers, please consider adding a picture to your profile. Here's how you do it: https://www.youtube.com/watch?v=F5JdUbyjfMA&list=PLpQebylHrdh5s3gwy-h6RtymfDpoz3vDS. By personalizing your profile with a photo of you, you encourage readers to respond.

If you have solved the issue in the meanwhile, please let the community know, too, so that other can also profit from your solution.

Thank you.

Regards, Svea

SAP Community moderator

Accepted Solutions (0)

Answers (1)

Answers (1)

denis_konovalov
Active Contributor

your question doesn't have any useful information to even attempt to answer it.

1. What product version ?
2. What is the architecture ?
3. What exact workflow produces the error ?
4. what have you done so far to troubleshoot ?