Showing results for 
Search instead for 
Did you mean: 

J2EE Visual Administrator Login Failuer

Former Member
0 Kudos

There were a few discrepancies between the word for word SAP installation and configuration guides and our actual SAP installation. I have been following the process of going back and fixing these gaps.

Yesterday, I adapted J2EE Server Memory Configuration (see below)and after that the XI J2EE Visual Administrator locked me out. My logins are unsuccessful:

1. In the left frame choose Server → Services →

Configuration Adapter

2. Choose cluster_data → Propertysheet…

3. Choose Show the detail of the selected node

4. The parameter ID...MaxHeapSize for server0 must

be set according to your platform:

• On IBM iSeries: Set the value to 3072.

• Other platforms: Set the value to 1024

5. For the parameter ID...JavaParameters for server0

add the following settings at the beginning of the

existing properties settings:

Never use this -XX parameter for IBM or

Compaq JDKs.

-XX:MaxPermSize=128M <existing settings>…

I cannot view the J2EE homepage on the server. Nor am I able to see any of my SAP XI J2EE components. I have checked the SAP Management console and restarted the J2EE Server. I have also checked my port numbers. The J2EE Server restarts and I can also get into the Configuration tool.

What should I do to fix the problem?


Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos

Thanks to all for the help. We solved the problem doing the steps described by Evan in this Topic:


Former Member
0 Kudos

Hi all

If you need any more help, let me know. We are running with XI, Portal, CRM, BW, standard was640 install and of course, trusty R/3...So we have come across many issues. Just be patient, I'm an abaper, but manage the outsourced basis team !


Answers (4)

Answers (4)

Former Member
0 Kudos

Hi Any one Please help me!!

I tried all the ways to login to Visual Administrator.

I also used emergency user ID but it too falied.

I then tried to add another usr to direct dispatcher method and gave the port 8101 instead of 50004.It logged upto 76% and gave "could not open connection host"

if connected through look up connection "msgserver/text/logon returned empty list of parameters"


user authentication failed.I tried all ways but failed.Please help me in this pretext by giving a solution other than reinstallation of Netweaver.

I am Using NetWeaver`04 SP 9

Thanking you in advance.

Former Member
0 Kudos

Hi Sejoon,

Even i am facing the same poblem as Fabian.My J2ee is not up and hence i am not able to login to visual admin.When i ran the jcmon.exe as u told, i Got the following in the port list.



























What should i do to start my j2ee engine???????.Any pointers are welcome.



Former Member
0 Kudos

Hi, Rashimi and Fabian.

Regarding J2EE engine trouble with startup, please refer to the section VM problems of the following pdf. for sap web as java.pdf

Or search with the phrase "JVM troubleshooting" in the search box on the SDN top page.

Also check the Note 723909.

Hope this helps.

Former Member
0 Kudos

Hi, Fabian.

First of all, are you sure that your J2EE server process is running?

This kind of problem is usually due to the fact that J2EE server couldn't start up.

Please run the jcmon utility program in the \usr\sap\QDX\SYS\exe\runU directory and check whether your server0 process is running.

In my case when i execute the jcmon like the following,

D:\usr\sap\QDX\SYS\exe\runU>jcmon.exe pf=D:\usr\sap\QDX\SYS\profile\QDX_DVEBMGS00_ides2

And this shows the following results.

|Idx|Name                |PID     |State               |Error|Restart|
|  0|dispatcher          |    4048|Running             |    0|yes    |
|  1|server0             |    2616|Running             |    0|yes    |
|  2|SDM                 |    3984|Running             |    0|yes    |


And if your J2EE server couldn't start up, you should tune the JVM settings by using the Configuration tool(Configuration Tool can be run regardless of J2EE engine).

Good luck.

Former Member
0 Kudos

I get a message saying that jcmon.exe is not a valid win32 application when I try to run that command.

Former Member
0 Kudos

I also just looked at my J2EE Visual Administrator log and found this

"Error while starting service zzz: Unused RFC Adapter on cluster node with ID 8430550: Could not start service on cluster ID 8430550;"

0 Kudos

Log into SAP system. go to smicm transaction.

From the menu, di a soft shutdown and restart of j2ee server. this also should bring up the visual admin tool.

oss note 709140 refers to a config tool.

using this you can reset the values. try this.

-- Bhaskar

Former Member
0 Kudos

I have tried this already - SMICM.

Here is the weird part. The J2EE Engine is up and running in the SAP Management Console.

In the SMICM it shows the following:

ABAP Server operational = TRUE

J2EE Server configured = FALSE

J2EE HTTP port =

J2EE HTTPS port =

J2EE Server operational = FALSE

Default root access handler = ABAP

URL Prefix Table loaded = TRUE

Message was edited by: Fabian Mansfeld

Former Member
0 Kudos

Add profile parameter icm/HTTP/j2ee_0 = PREFIX=/,HOST=localhost,CONN=0-500,PORT=5<sysnumber>00



Former Member
0 Kudos

To which profile and what is this parameter called?

Former Member
0 Kudos

profile on ABAP Stack.

/usr/sap/<SYSID>/SYS/profile/<SYSID>_DVEBMGS<sysnumber>_<hostname> file.

Goto RZ10

Click on the drop down button for Profile.

If you do not have any profile in that. Import the profile.

<b>RZ10 --> Utilities --> Import Profiles --> Of active server</b>

Then do the drop down on <b>Profile</b> again. This time pick the one with <b><sysid>_DVEBMGS<system number>_<hostname></b> which is an instance profile. Then choose <b>extended maintenance</b> radio button

Choose <b>Change</b>.

In the next screen if you see ur parameter change it, otherwise, you can add one. Do not forget to save the changes.

Former Member
0 Kudos

Ok. But I still don't know what to call this profile parameter. The name or title of it.

Former Member
0 Kudos