Showing results for 
Search instead for 
Did you mean: 

ITS Admin Instance: What's the initial login and password?

Former Member
0 Kudos


I've installed ITS 6.20

(Version: 6200.1019.53044.0 Buildno: 768746 Package: system.sar

Version: 6200.1019.53044.0 Buildno: 768746 Package: its_adm.sar)

on a win2003 server machine with apache 1.3.

I've installed two instances:

First, the admin instance listening on port 81

and the normal instance listening on port 82

The normal instance works fine and I succesful can connect to sap with service webgui

The admin instance is also running and I get a login screen after starting service admin with the IE browser.


During the installation I was prompted for a admin password and I entered an easy one: admin

What ever I tried, no login pass combination worked.

I tried:

itsadmin / admin

itsadmin / init

itsadmin / itsadmin

itsadm / admin

itsadm / init

itsadm/ itsadm


Could it be that the admin user still is not created?

Do I have to configure something before I can access the admin service?

How could I reset username and password?

Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos

Hello Knud,

as stated in the note, there should be a key named (Admin/Users/itsadmin) in the ItsRegistryADM.xml:

<key name="Admin">

..<key name="Users">

...<key name="itsadmin">

....<value name="password" type="text">des26(dfab78...e28b)</value>




After clearing:

....<value name="password" type="text"></value>

and restarting the ADM Agate instance, the pw should be resetted.

If not then:

  • Not a dual host (wgate and agates separated) installation, is it?

  • There must some error during installation, please check the install logs on any occurance related to admin/ADM.

  • Also check the traces (ITS/6.20/ADM/traces) of the ADM instance on errors.

  • Some file access restrictions on ItsRegistryADM.xml ?



Former Member
0 Kudos

That was the clue!

I just edited the ItsRegistryADM.xml and inserted the missing lines with your example structure.

Then I was able to login without password and was prompted to give a new password.

All is working fine now.

To fillup the information...

it is a single host installation

During the installation I always had to follow the same procedure:

Unzipping the setup dir, unpacking the sapcar files.

Starting sapinst and choose the desired service

Waiting for the same error message (missing calling parameter username ...)

Exiting the setup and deleting the setup dir, recreate the setup dir (unzip ...)

Start sapinst again and choose refresh.

The installation terminated successful.

That's all.

Both sap services were working at once, but not the ADM.

Nevertheless, the problem is solved so I'm happy now

Answers (2)

Answers (2)

Former Member
0 Kudos

thanks for the hint, but I neither don't find an registry entry nor an xml entry in c:\program files\sap\its\6.20\config\itsregistryadm.xml

Looks like no user exists?

Former Member
0 Kudos

If you can't find the "itsadmin" user defined in the ItsRegistryADM.xml file, I don't think I'd bother trying to put it back in. That would suggest to me that other items in the install might have been borked. I would run the SAPInst process to delete the ADM instance, and then re-install it.

Former Member
0 Kudos


and during the installation process you will be asked what the itsadmin password should be.

Then you know.

It also looks like you are installing Patch 19. You could download Patch 20 and go with that.

Former Member
0 Kudos

I know, I was asked for the password and I surely can remember the entered password.

I'm going to deinstall and install the adm instance again, but I doubt that this will solve my problem.

I've already downloaded two patches and I will try to install these patches too, but first I want to see a successfull login.

Active Contributor
0 Kudos

The URL in your initial posting (http://sapits:82/scripts/wgate/admin/!) points to the normal instance and not to admin instance (http://sapits:81/scripts/wgate/admin/!)) Do you get the ITS admin login screen with the text Administration Login and without client and language fields?

Former Member
0 Kudos

Sorry, there was a mistyping in my initial post.

I certainly use the right url for the admin instance

I get the right admin logon screen, without client and language field.

After a heap of tries, the login is blocked for 30 minutes. So I have to restart the service to enable further tries.

Active Contributor
0 Kudos

Please check OSS note 702372.

Best regards,