Showing results for 
Search instead for 
Did you mean: 

Issue with Idoc segment extension File -> PI -> IDOC Scenario

Former Member
0 Kudos

Hi All,

I have a unique problem. On an existing IDOC segment the requirement is to add new fields and change the mapping in PI to pass the information through to the new fields.

I have created new fields in a custom segment by cancelling the Release and set release again after adding the new fields.

Changed the user exit to use the new fields and to populate relevant information on the document.

As Its a inbound IDOC I did a small test using WE19 and it worked perfectly as expected.

then I login to PI and in the design I imported the metadata of the IDOC again and Updated the existing metadata.

Changed my mapping to populate the new fields which I have added.

then I did test the mapping and it worked as expected.

Again when I tried with the file I can see all the fields are populated correctly in SXMB_MONI but in the backend system I am unable to see the new fields that I have created on the IDOC in WE02.

Then I did full cache refresh but still I am seeing the same problem.

Can anyone throw some light to this issue please.

Many Thanks,


Accepted Solutions (1)

Accepted Solutions (1)

Active Contributor
0 Kudos

Hi Pradeep,

Try to reimport the metadata with the transaction IDX2


Answers (0)