cancel
Showing results for 
Search instead for 
Did you mean: 

Issue with branding SAM 2205 with MDK 6.3.1

0 Kudos
459

Hi All,

I am trying to build SAM 2205 metadata with MDK 6.3.1 and MDK plugin 2210.0.1 but i get below error when running create client command.

Could you please help.

Installing pods...

Analyzing dependencies

[!] CocoaPods could not find compatible versions for pod "ArcGIS-Runtime-SDK-iOS":

In Podfile:

ArcGIS-Runtime-SDK-iOS (= 100.15.0)

None of your spec sources contain a spec satisfying the dependency: `ArcGIS-Runtime-SDK-iOS (= 100.15.0)`.

You have either:

* out-of-date source repos which you can update with `pod repo update` or with `pod install --repo-update`.

* mistyped the name or version.

* not added the source repo that hosts the Podspec to your Podfile.

'pod install' command failed.

For more information on resolving CocoaPod issues in NativeScript read.

Error: Failed to run ns build ios

Accepted Solutions (1)

Accepted Solutions (1)

0 Kudos

Running below commands , solved the issue.

Run sudo arch -x86_64 gem install ffi

Run arch -x86_64 pod repo update

Run arch -x86_64 pod install error should be gone

But the xcode build fails because of below error-

error build: Multiple commands produce '/Users/i059173/Library/Developer/Xcode/DerivedData/SvcAssetMgr-gmnixozewtbhxnbbipmqenvrulmw/Build/Products/Debug-iphonesimulator/SvcAssetMgr.app/Frameworks/ArcGIS.framework'

Any inputs please?

Answers (0)