cancel
Showing results for 
Search instead for 
Did you mean: 

Issue when paging or export to pdf, Java SDK 12.0

0 Kudos
501

Hi,

we create the reports with Crystal Reports 2013 or higher. To show the reports in our Web-Application, we use Crystal Reports for Eclipse (Java SDK).

Version-Information

Eclipse-Version Neon.3 Release (4.6.3), Build id: 20170315-1500

Java JDK 1.8.0_60

Tomcat 8.0.26

Crystal Reports for Eclipse SP27 (CR4EMIP27_0_80004572)

Crystal Reports Java SDK (12.0)

Because there is no Flash available any more, we moved to the newer service packs of Crystal Reports for eclipse, newest, what I found SP 27 (27_0_80004572).

Since that time we have almost every day customer calls, because one of the reports doesn't work. That problem never appeared with the older version with Flash, so I think it's a bug in the newer version. The reports, where that happens are all invoice-types and other reports, which have a lot of subreports included. For example one of the incoive-types is a composit of 17 subreports. Not all of the subreports have always data and depending on the settings for printout, not always every of the subreport is printed, unless there are data or not.

In some cases, when one of these reports are printed (not always), report creation failes.

Its depending on the data and where the page change happens.

(1) Selection of prompt inputs always works

(2) Creation of report and showing first page in viewer works

(3) Paging thru the report pages works only till there is a composit, where page changes and Viewer can't calculate und create the next page. In that case, the page stays where it is, the in progress window is shown and you can hear the system is working hard and it's running in an endless loop.

I think regardless, if paging or exporting to pdf the same program routines are used, because, when trying to export to pdf the same error appears.

This happens in the servlets of the Crystal Reports for Eclipse Framework, so I don't have any chance to fix the problem and I need your urgent help.

Nearly every day one of our employess works the half or hole day only, to get a printout for the reports, where customers can't print. The fix is, to find the place, where printout hangs, change the hight of rows on some of the subreports, so page changes on another place and to try againg, if the printout can be done. But that is only the fix, for the special case, may be in another case, you have to change something else, because you have always different number of rows, datas, etc..

Note: we and also our customers have license to use crystal reports.

c4u_mkoch
Explorer

We have the same problem - our fix was to go back to SP24.

We could reproduce this issue with SP25, SP26 and SP27.

We're suffering from the same endless loop - we found this after setting the loglevel very high.

It seems that the endless loop depends on the data because sometimes the report works and sometimes not (depending on the parameter it shows more or less data).

I've also tried to modify the layout - after that my testdata was displayed without endless loop but therefore the endless loop occurs with another set of parameters.

With SP24 there are no issues - so it seems that this bug was introduced in SP25.

Accepted Solutions (0)

Answers (2)

Answers (2)

c4u_mkoch
Explorer
0 Kudos

SP28 was released 2021-12-23 (after log4shell).
I've did some local tests and it seems that the bug is maybe fixed.

I could at least create some PDFs for records that created an endless loop with SP26.

I'll have to do some more tests but at least for now it looks promising.

But attention: it seems that SAP switched with SP27 from log4j 1x to 2x!

[edit]

I did another test with SP26 before SP28 to check if I still get an endless loop.

[/edit]

0 Kudos

Hi Markus,

sorry for the delay. We can't go back to older version, because we use this in web environment. and unfortunately SP24 isn't flash free, so I don't have this option.

When one of our customers has this problem, we are manipulating the report. And as you wrote, if you make changes, it is not sure, if the whole report can be printed out, so it's sometimes a litte boring.

Thanks a lot for your answer and time. If you hear something more about a fix, I would be greatfull, if you can write this here.