cancel
Showing results for 
Search instead for 
Did you mean: 

ISA control number is not getting generated

Former Member
0 Kudos

Hi

Some times we are facing problem while sending X12 to partners.

ISA I12 (transmission control number) is not getting created at runtime, so message is failing in PI.

It seems some problem with Seeburger classes.

But is working fine in development.

Please provide some clues.

Thanks in advance.

Subba Rao

Accepted Solutions (0)

Answers (3)

Answers (3)

Former Member
0 Kudos

Hi Daniel

Sorry for the late reply.

Problem is solved by refreshing cache.

Thanks

Subba Rao

Former Member
0 Kudos

Hi Subba Rao,

did you check that you have enough database connections available on your production system?

If this only happens on your prod system, the db poolsize could be too low. so when a lot of messages are processed at the same time and each message needs to generate a control number (which can be done through external counters within the seeburger workbench), at some point there are no more db connections available and the message failes. after a few retries it works, because some connections were closed and are now available again to process the rest of the messages.

This is only a guess, but might be worth checking. Also, if you can get the error message of a failed message, this might help to identify the problem.

regards,

Daniel

Former Member
0 Kudos

Hey,

Please ensure your code to fetch the 'counter' is correct. If you dont' mind please copy & paste it here ( I think you would be using the standard one anyway?)

Former Member
0 Kudos

Hi

Thank for your response, Normally it is working fine.

This error is occurring sometimes and is getting reprocessed after some restarts.

It is strange.

Subba Rao