Showing results for 
Search instead for 
Did you mean: 

Is it possible to import a Fixed Text file that does not have a header?

Former Member
0 Kudos

I'm trying to import a Fixed Text file through Import Manager, but the text file I am receiving does not have a header on it (the first row is valid data). When I try importing this, Import Manager uses the first row of data as the headings. Is there any way to turn this off and tell Import Manager there is no header data in the file?


Accepted Solutions (0)

Answers (3)

Answers (3)

Former Member
0 Kudos

Hi Ryan ,ur requirement can be met only when u import the file as ODBC .for this follow the below steps.

1)Go to control panel,in ur settings,select administrative tools

2) In that select DATA SOURCE(ODBC ).

3)Go to SYSTEM DSN tab select tab .

4)Select ur file type MICROSOFT TEST DRIVER (.txt,.csv)

5)Double click on "Import DSN" and in the blank give the name of DATA SOURCE NAME any name u want to give.

6)Uncheck the use current directory box and select the directory ur file is it will automatically show ur source file select it and click ok.

7) Now when u import ur file as ODBC give the name of ur DATA source name which u have given and it will show ur file in the source preview itself .

In this way u can import ur file as ODBC.

Hope this may help u.



Former Member
0 Kudos

Hi Ryan,

Your requirement can be met by using ODBC connection.

If you try to import a txt file with the first heading as a data line using ODBC driver connection then in Import manager in your source side you will find fields created as FIELD1,FIELD2 etc you can then map these fields from your source with your rep fields,so these fields becomes your heading and the data lines will appear below them.

So your req can be met.

Hope it helped



Former Member
0 Kudos


It is only possible if you import the the file using a ODBC connection from the Import manager TYPE ODBC.