cancel
Showing results for 
Search instead for 
Did you mean: 

Internet Mail Gateway on Unix for R/3 4.6c

Former Member
0 Kudos
195

hi,

we are in the process of configuring the Internet Mail Gateway on R/3 4.6c on Unix platform.

I have created the RFC Destinations in SM59 and also checked the Test Connection and its working fine. I then did the Unix configuration and went on to the check whether the configuration was successful in SO01 by sending a sample text message to my company's mail address. but i did not recieve any mails on my Microsoft Outlook, instead the count under the errors column increased by one.

on checking the status for the sent message in SO01, its saying "No Delivery to .@xxx.com(for reason, see long text)... but there's no long text either...

Can anyone please let me know the reasons for it and it would also be really helpful if someone can let me know whether i have missed any configuration settings.

Also, can someone send the list of parameters that are to be entered for the Unix configuration under mlsomadm mailgw.ini, so that i can verify whether i have entered the parameters correctly....

Kindly revert back at the earliest...

Thanks & Regards

Manicks

Accepted Solutions (0)

Answers (9)

Answers (9)

Former Member
0 Kudos

Hi Manicks,

Please read this link <a href="http://help.sap.com/saphelp_46c/helpdata/en/6c/69c4e3418d11d1896e0000e8322d00/frameset.htm">sap internet mail gateway</a>.

I think you are using documentation from a newer release to setup a 4.6c mail gateway

Kind regards,

Alexander

Former Member
0 Kudos

hi Alexander,

Could you also provide some clarity on the following doubts...

Firstly, there's no SMTP node in the transaction SCOT under INT... and

Secondly, the transaction SICF does not exist in R/3 4.6c for me to activate the services for SMTP....

wat impact do tehse two factors have in sending across the mail through Internet Mail Gateway...

Thanks & Regards

Manicks

Former Member
0 Kudos

hi Alexander,

thought posting the trace in itself was a seperate activity in SCOT.. thats why asked you how it should be done...

well!! here is the trace...

SO_OBJECT_SEND G Recipient in queue flagged

SO_OBJECT_SEND G Structure: SOSCO

SO_OBJECT_SEND G Status written for this recipient

SO_OBJECT_SEND G Structure: SOST

SO_OBJECT_SEND G Queue updated

SO_OBJECT_SEND G Status updated

SO_OBJECT_ID_FOR_SEND_GET G Structure: SOSC

SO_OBJECT_ID_FOR_SEND_GET G Object ID returned

SX_OBJECTS_SEND G Document type: M. Send attribute class: 0. No. of recipients: 1

SX_OBJECTS_SEND G Call of SX_PERFORM_RFCSEND with ROUTE M MANICK

SO_CONVERTED_VERSIONS_GET G Versions returned

SX_PERFORM_RFCSEND G Nicht unterstützte Formate: ALI OBJ OTF SCR URL

SX_OUTGOING_VERSION_BUILD G Read contents of document RAW31000000000038

SO_OBJECT_DATA_FOR_SEND_GET G Object transferred

SO_OBJECT_PREPARE_FOR_SEND G Object prepared for transmission

SX_SEND_DATA G Structure: SXRECINFI1

SX_SEND_DATA G Structure: SXEXTRECI1

SX_SEND_DATA G Structure: SXPCKLSTI1

SX_SEND_DATA G Structure: SXDOCCHGI1

SX_PERFORM_RFCSEND G After call of function SX_OBJECT_RECEIVE Returncode: 0

SX_PERFORM_RFCSEND G Structure: SXEXTRECI1

SX_PERFORM_RFCSEND G Message transferred by node to communication system

SO_OBJECT_STATUS_UPDATE(synchr G Message obj. does not exist - no event necessary

SO_OBJECT_STATUS_UPDATE(synchr G Status set (synchronous)

Former Member
0 Kudos

hi Alexander...

Thanks for the response...

Can you also explain on how to post the trace file????

Thanks

Manicks

Former Member
0 Kudos

Hi Manicks,

Just cut and paste the file into a post

Alexander

Former Member
0 Kudos

Hi Manicks,

Please run mlsomadm again and set the trace to 1.

Then send another mail and post the tracefile.

Kind regards,

Alexander

Former Member
0 Kudos

Also,

On the R/3 side, in the transaction SCOT, the SMTP node is not there.... The SMTP node is there only on the BW side...

Is this SMTP node a must?? if so, how do we need to set this up???

Thanks & Regards

Manicks

Former Member
0 Kudos

Also, in the transaction SCOT, under System Status, all teh requests are under the column "In Transit" for a long time...

its not moving to the completed column...

can anyone please revert back on this quickly...

Thanks & Regards

Manicks

Former Member
0 Kudos

hi,

Thanks... that answer was useful.... when i give start send process and check the status in SOST, its saying "Message transferred by node to Communication System" and the status light is in grey...

can anyone let me know wat this communication system is thats being referred to....

Can u please throw more light on this.... we need to get this fixed as early as possible...

Thanks & Regards

Manicks

Former Member
0 Kudos