cancel
Showing results for 
Search instead for 
Did you mean: 

INTERNAL.CLIENT_RECEIVE_FAILED error in Proxy -> PI -> SOAP Scenario

former_member628395
Active Participant
23,015

Hi All,

I am implementing the synchronous ABAP proxy -> PI -> SOAP(.NET Webservice) scenario in PI 7.4. I have imported the WSDL as external definition and crated the service interfaces and the other relevant objects. After that I tried to test the same in sproxy, but I get an error, given below.

INTERNAL.CLIENT_RECEIVE_FAILED Error while receiving by HTTP (error code:

Configuration error on Adapter-Framework(AFW)-Server, error text:

#com.sap.aii.af.service.cpa.CPAObjectNotFoundException: Couldn't retrieve

inbound binding for the given P/S/A values:

Please check configuration for SOAP/XI sender agreement

    Exception of class CX_AI_SYSTEM_FAULT

I tried all the possible solutions mentioned in the relevant SCN post. Also I replicated the scenario as per, the document

http://www.sdn.sap.com/irj/scn/go/portal/prtroot/docs/library/uuid/80104882-c7a8-2f10-c3a3-81f182917...

Has anyone faced the same problem anytime. Request your valuable guidance in the same.

Thanks,

Sagar.

View Entire Topic
iaki_vila
Active Contributor

Hi Sagar,

The problem could be originated by some reason, you should share more information about the exception.

Check these notes:

  1748814 - PI SOAP adapter messages fail with error : Status Code = 500 [null "null"]

1952439 - BubbleException in SOAP receiver channel during sending data to backend Integration Engine...

Check the workarounds pointed out in the notes, i know your version is 7.4 but the 7.31 version is similar.

Regards.

former_member628395
Active Participant
0 Kudos

Hi,

Thanks once again.

I have already checked the same, but no luck. I tried changing the Message Protocol to HTTP 1.1 in both the channels. After that I got the error(but the communication channel log does not have any errors. All the operations complete successfully) :


PARSER.UNEXPECTED_VALUE XML tag
Main/@versionMajor has incorrect value 000;
expected value is 003


On changing the message protocol to XI3.0, the communication channel log shows the below error


Info : SOAP: Request message entering the adapter processing with user J2EE_GUEST

Info : XISOAP: XI message received for processing

Error : Error during parsing the received XMB message.

Error : SOAP: Call failed: com.sap.aii.af.sdk.xi.srt.BubbleException: HTTP Response Received. Status                     Code = 500 [null "null"]


Regards,


Sagar


iaki_vila
Active Contributor
0 Kudos

Hi Sagar,

I had the same problem than you with ABAP proxies and PI, finally Basis team had to patch the ECC system and the PI, but all depends about your ECC and PI releases and SPs.

Check with your basis team this note 1349125 - Error in communication between ABAP Proxy Application & AAE

This note can be helpful because you are under PI 7.4, check with your basis team if your SP is affected or not:  2106429 - Response message contains invalid SOAP headers in BE mode

Regards.

former_member628395
Active Participant
0 Kudos

Hi  Iñaki,


Thanks yet again.


I had already check the notes but did not help much. The issue is resolved now. I created the whole scenario again and used the Message Protocol as XI3.0 in the sender communication channel and SOAP 1.1 in the receiver.


Thanks once again for you valuable inputs.


Regards,


Sagar

iaki_vila
Active Contributor
0 Kudos

Hi Sagar,

Thanks to you to share with us the final solution without application any note, definitely a the best option.

Regards.