cancel
Showing results for 
Search instead for 
Did you mean: 

Interesting Problem with R3trans -d

Former Member
0 Kudos
215

Guys!

I am facing a strange and a interesting problem with R3trans -d

I hav DB and CI installed in two different boxes.

From CI, if i do a R3trans -d, I get RC=12. BUT if I start SAP it runs fine without any issues.

Log files shows that its not able to connect with OPS$ user, Log below.

basically it fails in the step conn /@PRE

if i go to command prompt of CI and try that, as expected it fails even there too...

but i am able to connect with system, sys, etc from CI and run all select queries.

Now, If i go to DB Server...and there if i run 'conn /@PRE' it works!

Why is it not workin from CI?

All env variables are set.

R3trans Log:

4 ETW000 [dev trc ,00000] Logon as OPS$-user to get SAPDAT's password 44 0.181828

4 ETW000 [dev trc ,00000] Connecting as /@PRE on connection 0 (nls_hdl 0) ... (dbsl 640 310306)

4 ETW000 46 0.181874

4 ETW000 [dev trc ,00000] Nls CharacterSet NationalCharSet C EnvHp ErrHp ErrHpBatch

4 ETW000 47 0.181921

4 ETW000 [dev trc ,00000] 0 UTF8 1 00000000002D4000 00000000002F0A38 00000000002F03E8

4 ETW000 127 0.182048

4 ETW000 [dev trc ,00000] Allocating service context handle for con_hdl=0 11146 0.193194

4 ETW000 [dev trc ,00000] Allocating server context handle 33 0.193227

4 ETW000 [dev trc ,00000] Attaching to DB Server PRE (con_hdl=0,svchp=00000000002F02B8,svrhp=00000000002F2788)

4 ETW000 65 0.193292

4 ETW000 [dev trc ,00000] Assigning server context 00000000002F2788 to service context 00000000002F02B8

4 ETW000 98809 0.292101

4 ETW000 [dev trc ,00000] Allocating user session handle 51 0.292152

4 ETW000 [dev trc ,00000] Starting user session (con_hdl=0,svchp=00000000002F02B8,srvhp=00000000002F2788,usrhp=00000000002FC488)

4 ETW000 52 0.292204

4 ETW000 [dboci.c ,00000] *** ERROR => OCI-call 'OCISessionBegin' failed: rc = 1017

4 ETW000 17264 0.309468

4 ETW000 [dev trc ,00000] Wed Jul 11 06:39:37 2007 7434 0.316902

4 ETW000 [dbsloci. ,00000] *** ERROR => CONNECT failed with sql error '1017'

Accepted Solutions (0)

Answers (2)

Answers (2)

Former Member
0 Kudos

Hi Bidwan,

This would be problem with your oracle database.

This is because, there is no enough processes in your oracle database.

Try this..

Logon to client 000.. go to SPAM. Utilities --> Check tranport tool.

You will get an error in tp connect to database.

The solution is you have to increase the processes parameter in init<SID>.ora file to a higher value and restart your database.

I have encountered number of times.

Thanks and Regards,

Sailesh K

Former Member
0 Kudos

Guys!

Any other clues/options please?

Cheers!

Bidwan

Former Member
0 Kudos

Sailesh,

I tried what you have suggested and its working fine..so thats not the problem in my case...

Others: Please throw some light incase you have any ideas...

Cheers,

Bidwan

Former Member
0 Kudos

Hello Bidwan ,

1 ) What is a result of TNSPING ?

2 ) If both Systems are on NT , did the registry are having all relavent parameters ?

HKEY_LOCAL_MACHINE\SOFTWARE\ORACLE\HOME

Regards ,

Santosh

Former Member
0 Kudos

Thanks Santosh..Had checked that...both are fine...

Any other clues please?

Former Member
0 Kudos

Hello Bidwan ,

Can you cross check the environment variable & system variable ?

system environment and the user environment :

Please check that variables such as ORACLE_HOME or "PATH=<oracle_home>\bin..." must not be set in the SYSTEM environment. Instead, they must be set locally in each case in the environment of the database users.

Registry under the following path are used:

HKEY_LOCAL_MACHINE -> Software -> SAP -> <sid> -> Environment

Hope this will help !

Regards ,

Santosh Karadkar

Message was edited by:

Santosh Karadkar

Former Member
0 Kudos

Even this is fine..

The problem basically is that its not able to login as a OPS$ user from CI..But the OPS$ user has been set up correctly ..with SAPDBA rights...and thats why conn /@<SID> is working properly in DB Server....and SAP is running fine...Not sure why problem is comin from CI..:-(