cancel
Showing results for 
Search instead for 
Did you mean: 

Integration Builder: Unable to launch the application.

former_member204746
Active Contributor
0 Kudos
3,723

Hi,

I'm on PI 7.11. we just implemented SPS 06.

We're on DB 9.7 FP3 and AIX 5.3

I am trying to start the integration builder. Sometimes it works, sometimes it fails.

when it fails, I get a popup with this info:

Unable to launch the application.

Name: Integration Directory

Publisher: SAP AG

From http://my_server_name:53000

When clicking on the DETAILS button, under the Exception tab, I find:

java.lang.NoClassDefFoundError: com/sap/aii/ib/gui/misc/ApplicationBase

at java.lang.ClassLoader.defineClass1(Native Method)

at java.lang.ClassLoader.defineClassCond(Unknown Source)

at java.lang.ClassLoader.defineClass(Unknown Source)

at java.security.SecureClassLoader.defineClass(Unknown Source)

at java.net.URLClassLoader.defineClass(Unknown Source)

at java.net.URLClassLoader.access$000(Unknown Source)

at java.net.URLClassLoader$1.run(Unknown Source)

at java.security.AccessController.doPrivileged(Native Method)

at java.net.URLClassLoader.findClass(Unknown Source)

at com.sun.jnlp.JNLPClassLoader.findClass(Unknown Source)

at java.lang.ClassLoader.loadClass(Unknown Source)

at java.lang.ClassLoader.loadClass(Unknown Source)

at com.sun.javaws.Launcher.doLaunchApp(Unknown Source)

at com.sun.javaws.Launcher.run(Unknown Source)

at java.lang.Thread.run(Unknown Source)

Caused by: java.lang.ClassNotFoundException: com.sap.aii.ib.gui.misc.ApplicationBase

at java.net.URLClassLoader$1.run(Unknown Source)

at java.security.AccessController.doPrivileged(Native Method)

at java.net.URLClassLoader.findClass(Unknown Source)

at com.sun.jnlp.JNLPClassLoader.findClass(Unknown Source)

at java.lang.ClassLoader.loadClass(Unknown Source)

at java.lang.ClassLoader.loadClass(Unknown Source)

... 15 more

Like I said earlier, If I try over and over again, I eventually get it to start normally!

For additional info, I'm using:

java version "1.6.0_20"

Java(TM) SE Runtime Environment (build 1.6.0_20-b02)

Java HotSpot(TM) 64-Bit Server VM (build 16.3-b01, mixed mode)

Note that this issue also happens on other workstation. The only thing that changes is installation of SPS06.

Thanks.

Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos

Hi ,

Follow the below steps:

1.Open your C:\ folder

Search for Windows---->Prefetch foleder in that you will have many files select all and delete it.

2.Next go to your Control pannel->there u can find Java(TM)->double click on that

-


>click General tab-->there u can find a View button click that button----->there u can find the a list IR and ID files select and delete all .

hope this will help u.

Regard's

Preethi.

former_member204746
Active Contributor
0 Kudos

Hi chichilin,

I did not find the "administration" link from /rep link.

Hi preethi_malu,

I tried your procedure and it did not work... and as I stated, after 3 tries, it worked... but failed after try #4.

I found something very interesting:

When I try repeatedly to download the integration builder file directory.jnlp, I get multiple versions downloaded with names such as directory-12.jnlp and directory-13.jnlp.

These files are not the same file size! They do not have the same contents! how could that be.

That makes be believe that problem is on the server it self and NOT on the workstation.

The working one has this text in it:

<jar href="directory/jta.jar" download="lazy" part="part-154"/>

<jar href="directory/ejb20.jar" download="lazy" part="part-153"/>

<jar href="directory/sap.comtcsapxmltoolkit~sapxmltoolkit.jar" download="lazy" part="part-71"/>

<jar href="directory/sap.comtcexception~impl.jar" download="lazy" part="part-111"/>

<jar href="directory/sap.comtcloggingjavaimpl.jar" download="lazy" part="part-120"/>

<jar href="directory/sap.comtcblguidgeneratorimpl.jar" download="lazy" part="part-112"/>

<jar href="directory/jperflib.jar" download="lazy" part="part-51"/>

<jar href="directory/sap.comtcblniimpl.jar" download="lazy" part="part-116"/><!-- required for CSN-connection -->

<jar href="directory/sap.comtcjeclientlibimpl.jar" download="lazy" part="part-52"/>

<jar href="directory/sap.comtcbljarmjarm.jar" download="lazy" part="part-122"/><!-- Tensegrity Libs -->

the one that is failing:

<jar href="directory/jta.jar"/>

<jar href="directory/ejb20.jar"/>

<jar href="directory/sap.comtcsapxmltoolkit~sapxmltoolkit.jar"/>

<jar href="directory/sap.comtcexception~impl.jar"/>

<jar href="directory/sap.comtcloggingjavaimpl.jar"/>

<jar href="directory/sap.comtcblguidgeneratorimpl.jar"/>

<jar href="directory/jperflib.jar"/>

<jar href="directory/sap.comtcblniimpl.jar"/><!-- required for CSN-connection -->

<jar href="directory/sap.comtcjeclientlibimpl.jar"/>

<jar href="directory/sap.comtcbljarmjarm.jar"/><!-- Tensegrity Libs -->

Also, when I double-click on the directory-12.jnlp file, it ALWAYS work!

when I double-click on the directory-10.jnlp file, it always FAIL!

Edited by: Eric Brunelle on Oct 4, 2011 8:59 AM

naveen_chichili
Active Contributor
0 Kudos

Hi Eric,

Go to TCODE:SXMB_MONI --> you will get a popup window which has IR,ID,SLD and RWB

in the right hand side you will have an option called administration ..just login to that page with your user credentials and if you see at left pane you will find an option for repository -->Javau2122 Web Start Administration and also Directory --> Javau2122 Web Start Administration for re-initialization and reinitialization force signing.

just click on these two then try after 5 min.

Regards,

Naveen.

Edited by: chichilin on Oct 4, 2011 7:14 PM

former_member204746
Active Contributor
0 Kudos

Hi chichilin and Kumar,

When I go into transaction, I get into a transaction that looks like SPRO:

see screenshot at http://img249.imageshack.us/img249/3797/84435049.jpg

0 Kudos

Hi,

Step1: I am also faced the same probleam now it solved, i did in "http://<server_ip>:50000/dir/start/index.jsp -> Administration Tab->java web start(both Repository/Directory Tab) -> click "remove lock" button.

Step2: Window->start->Run enter the commend "javaws -viewer" and In java cache viewer delete the application history.

After u can open the IR/ID.

Regards,

Kumar

former_member204746
Active Contributor
0 Kudos

I finally found the "Administration" tab everyone is talking about. So, I tried it, logged in.

when I try to click on the REMOVE LOCK button, I get an error on both Repository/and Directory Tabs

Unable to remove lock

I am stuck again!

naveen_chichili
Active Contributor
0 Kudos

Hi Eric,

Click on reinitialization and reinitialization force signing as i said above .

Regards,

Naveen

former_member204746
Active Contributor
0 Kudos

Do you mean option "Restore Archives and Generate New Signature" from the Java Web Start Administration option?

naveen_chichili
Active Contributor
0 Kudos

Hi Eric,

1. Login to your XI/PI server

2. Go to Exchange Infrastructure Tools main web screen. You will see

Tools list and other options.

http://SERVER:PORT/rep/start/index.jsp

3. On the Upper right part of your screen you will see Tools

Administration Client Installation and Guidelines Documentation.

Click Administration

4. Login with user.

5. On the Exhange Infrastructure Administration , make sure you are in

the Correct tab. (Repository Directory Runtime). The tab will

determine the administration configuration that your will perform

5.1 When this problem occur with Integration Repository > make sure you

are in Integration REPOSITORY TAB. Proceed with step 6. Skip step 5.2.

5.2 When this problem occur with Integration Directory > make sure you

are in Integration DIRECTORY TAB. Proceed with step 6.

6. Click on Java web start administration.

7. Click on Re-initialization and force-signing. This will

re-authenticate all new JAR files deployed. This will also let the new

JAR files adapt to the current certificate deployed.

This function will cause the above re-collection and additionally a

re-signing of ALL resources with a dummy certificate. The original SAP

signatures of the jarfiles will be lost. To get back the original SAP signatures

the application has to be deployed again.

8. A Java(TM) Web start Application reset text will appear.

9. Wait for 5 to 15 minutes for re-initialization to complete

10. Start your "Integration Repository' or "Integration Directory"

again. It should work now.

This will solve the issue

With regards

Naveen

former_member204746
Active Contributor
0 Kudos

thanks for the very detailed post.

in option 7:

7. Click on Re-initialization and force-signing. This will

re-authenticate all new JAR files deployed. This will also let the new

JAR files adapt to the current certificate deployed.

I do not see such option I see the following text (button are in BOLD)

Status

Initialization Status Display

List of Resources Display

JNLP File Display Start Application

Re-Initialization

Restore Archives Choose this function to restore the Java Web Start archives at the client. All JAR files will be collected and placed in a global directory (sys.global.dir). Any JAR files that do not already have a signature will be assigned a new key. The system will also apply a lock to avoid simultaneous processing

Restore Archives and Generate New Signature Choose this function to restore the Java Web Start archives at the client and to assign a new key to all archives. The original SAP signatures for the JAR files will be deleted. We recommend that you only use this function in test systems. To restore the original SAP signatures, you must deploy the application again

Remove Lock Use this function only if a previous attempt to restore archives terminated with errors and consequently a reconfiguration lock has not been deleted. Before use, ensure that no collection process is running (as is the case if you have restarted the J2EE server, for example) otherwise errors can occur

naveen_chichili
Active Contributor
0 Kudos

Hi Eric,

You would be able to see Re-initialization and force-signing option just below Re-initialization just click on that and try to open IR and ID after few min's.

Regards,

Naveen

former_member204746
Active Contributor
0 Kudos

I do not see that option.

look at http://img51.imageshack.us/img51/6674/screenshotqhj.jpg for a screenshot

prasanthi_chavala
Active Contributor
0 Kudos

Hi,

Re-Initialization & force-signing in PI 7.0 = Restore archives & generate new signature in PI 7.1 onwards..

So go with second option and check if you are able to access the ID.

Thanks,

Prasanthi.

0 Kudos

Hi,

After click "Restore archive and generate new signature"

Go to Start->Run> enter "prefetch" and delete content of the folder.

u can open the ESR/ID.

former_member204746
Active Contributor
0 Kudos

I tried that... unfortunately, it did not work.

I still get an intermittent behavior. and as I stated earlier, the file size of the JNLP file varies everytime!

Former Member
0 Kudos

The only thing I've found that works when I get the "Unable to launch" error is

1. Go to Windows Control Panel and open the Java control panel.

2. Press the View button to see the Temporary Internet files.

3. Select the one that's giving the error and click the big red X (Remove Selected Items).

After that the application should download again and start ok. It's a pain, but it seems to work.

former_member204746
Active Contributor
0 Kudos

Thanks Murray,

I tried this and it only works temporarily and randomnly.

Former Member
0 Kudos

Not the solution.

I was facing the same problem sometime back. What i used to do was, open command prompt and type javaws -Xclearcache and hit enter. Then start ID again. I think it does the same as clearing java temp files manually.

For the past few weeks im not facing that problem!

Now i am wondering if it is related to SP06 upgrade. We too had SP06 upgrade a few months back.

- Jose.

Former Member
0 Kudos

I've just gotten into the habit of doing this every time I want to start up the ESB or IB. Every now and then I take a look to see if anyone has a proper fix (that's why I was looking at this thread), but so far I haven't seen one.

former_member204746
Active Contributor
0 Kudos

Hi Jose,

I tried your trick and it failed right after my first ry after it downloaded a ton of stuff.

Former Member
0 Kudos

Pls chk if this [link|http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6642654] makes sense!

I am not able to see a fix/solution there.

Sorry. i think it dosent make sense if your java version is "1.6.0_20"

- Jose.

Edited by: Jose on Oct 12, 2011 12:59 AM

Former Member
0 Kudos

Hi Eric,

All that you need to do is:

1 - Restore Archives and Generate New Signature (You know already where to find it - tcode SXMB_IFR / ADMINISTRATION / REPOSITORY tab / JAVA WEB START ADMINISTRATION )

then wait for a while (about 10 min - it will be processing in background)

2 - and then restart the J2EE server

Perhaps, just restarting the J2EE server it solves your problem already. But just in case, i did the step 1 before restarting it.

Pretty sure it will work (restarting the J2EE server).

Regards,

Danilo Rossatto

former_member204746
Active Contributor
0 Kudos

It finally works!

1. Restore archives & generate new signature

2. restart J2EE instance.

it now works everytime!

Former Member
0 Kudos

That information is provided in the the TBIT51 Course and the BIT 400 Courses.

former_member204746
Active Contributor
0 Kudos

on which pages is this published?

Answers (3)

Answers (3)

0 Kudos

Hi,

sxmb_ifr-> click on Administrator, In both Repository and Directory Tab click "java Web Start" and click the "Remove Lock" button.

After Remove lock u can open the "ID/IR".

Regards,

Kumar

GabrielSagaya
Active Contributor
0 Kudos

Did you check the file in the path C:WINNTsystem32driversetc or C:WINDOWSsystem32driversetc. This file contains the mappings of IP addresses to host names with FQDN

Also please check this blog

former_member204746
Active Contributor
0 Kudos

Hi,

i checked hosts file. All looks fine.

Please remember that my problem is intermittent! It works sometimes... it fails sometimes.

naveen_chichili
Active Contributor
0 Kudos

Hi Eric,

Try opening http://<host>:<port>/rep -> Administration. In Repository and Directory tabs, go to Java Web Start and click the button Re-initialization and force-signing.

Regards,

Naveen

Former Member
0 Kudos

Just few cents...

Are you in a Local Network under a Proxy Server?

It seem like an old issue with Java RE ... when it can't load the application, caused by Proxy Settings in Java ControlPanel or Certificate authentication...

former_member204746
Active Contributor
0 Kudos

Thanks spantaleoni for you answer.

I am not under a Proxy.

I searched SAP notes and found a few notes about Certificate authentication. I am not sure if this is the case here as the error message does not seem to be related... but I may be wrong.

Former Member
0 Kudos

Hi Mr Brunelle,

I'm referring to Java RE Protected Certificate (like SAP AG or similar), but I may be wrong.

I've no problem with SP6 in PI 7.11 system, but this error seem to be related to JRE on local Machine.

ps. if you have pleasure, please add me on gtalk