cancel
Showing results for 
Search instead for 
Did you mean: 

Integrated ITS and SSO (Logon Tickets)

former_member1173626
Participant
0 Kudos
69

hello all,

i've installed a WAS 7.00 box and now i've been requested to activate the integrated ITS.

i've already configured the server to accept logon tickets from another box running the portal.

the question is that is there something special to config the integrated ITS to accept the certificate? or is because the WAS box is already configured, there is nothing more to do for the ITS except activate it?

thx much.

mike

Accepted Solutions (1)

Accepted Solutions (1)

athavanraja
Active Contributor
0 Kudos

to activate SSO for ITS (integrated) from portal you need to do the following.

1. icm/host_name_full profile parameter should be set to the Fully Qualified Domain name of your WAS (ABAP) server.

(washost.domain.com)

2. itsp/enable should be set to 1 to activate integrated ITS

3. profile parameters login/accept_sso2_ticket &

login/create_sso2_ticket should be set to 1.

4. portal certificate (verify.der) should be loaded into ABAP engine - transactin STRUSTSSO2

5. in the definition of system in portal (the definition of the backend to be connected) set the WAShost/path/protocol and ITS host/path/protocol

This all what is required.

Regards

Raja

former_member1173626
Participant
0 Kudos

hi raja,

many thanks for those precise steps. i will try it out and get back to you.

thanks again,

mike

former_member1173626
Participant
0 Kudos

hi raja,

i was away on a conference and i am back.

1- icm/host_host_name iss fqdn

2- itsp/enable is 1

3- i set accept_sso2_ticket to 1, but not for create_sso2_ticket. I was told we dont want that box to create tickets, only accept them.

is setting the create_sso2_ticket to 1 mandatory?

4- certificate loaded

5- system defining done

with all that, only the create_sso2_ticket step you mentioned was not done.

the single sign-on, though, isn't working. so is it because of the create_sso2_ticket?

cheers,

mike

athavanraja
Active Contributor
0 Kudos

yes setting create_sso2_ticket to 1 is required for SSO to work.

Regards

Raja

former_member1173626
Participant
0 Kudos

hello raja,

sorry for the late reply...we were caught up with some major bw problems and lost track.

just wanted to say thanks a lot, everything works now with the sso to ITS.

best rgds,

mike

Answers (0)