cancel
Showing results for 
Search instead for 
Did you mean: 

Installing SAPHOSTAGENT

Former Member
0 Kudos

Hello,

I want to install SAPHOSTAGENT on SOLARIS. The following error message occurs when I install SAPHOSTAGENT:

saphostexec -install

Install service

And that was it. The installtion is not performed. Can someone help ?

Kind Regards

Hartwig Latz

Hydac GmbH

Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos

Hello Huseyin,

we have upgraded a complete GTS Lanscape, GTS 7.2 to GTS 10.0. Start-Release was Basis 700 so SAPHOSTAGENT wasn't installed, target Release was 702. By Downloading the Software for the Upgrade SAPHOSTAGENT was coming up. We use Solution Manager 7.01, only Maintenance Optimizer and Automatically Distribution of Maintenance Certificates.

Is it mandatory for a certain Release to implement SAPHOSTAGENT ?

The installation of SAPHOSTAGENT consists of 28 Files, were this Files directly installed into the Kernel Directory ?

Kind Regards

Hartwig Latz

HuseyinBilgen
Active Contributor
0 Kudos

Hi,

Then there is no dependency. The minimum version you can install is SAP HOST AGENT 7.10

and others are;

SAP HOST AGENT 7.11

SAP HOST AGENT 7.20

I guess you can install the latest version. Download the latest patch (which is also an installer) for SAP HOST AGENT 7.20 via service.sap.com/swdc > Support Packages and Patches > Browse our download catalog > SAP Technology Components" SAP HOST AGENT" SAP HOST AGENT 7.20 > <your os>

and follow the guide @ [https://www.sugarsync.com/pf/D448156_7543774_943524|https://www.sugarsync.com/pf/D448156_7543774_943524]

Answers (4)

Answers (4)

Former Member
0 Kudos

Hello,

thank you very much for your help.

Kind Regards

Hartwig Latz

Former Member
0 Kudos

Hello,

which Syntax of program useradd for User sapadm should I use ? I have a few questions concerning SAPHOSTAGENT:

1.) SAPHOSTAGENT is used in certain Scenarios.

Does we have to implement this Agent if we don't use these Scenarios in our Company ?

What is if a new Kernel-Patch is installed on the system, is it necassary to implement the newest Version of SAPHOSTAGENT ?

Is it possible that there are problems if we install SAPHOSTAGENT in an Cluster Environment ?

Kind Regards

Hartwig Latz

Hydac GmbH

HuseyinBilgen
Active Contributor
0 Kudos

Hi,

Then, please let me know on which SAP Solutions server you're installing this agent?

In newest SAP versions, HostAgent is automatically installed with SAP installation.

HostAgent is used in 2 scenarios I know:

- Solution Manager SMD Implementation

- Adaptive Computing Controller

It behaves a little bit seperate from the SAP solutions running on the server. But, depending on the scenario you're using, you've to check the compatibility of HostAgent to the ACC or Solman.

Otherwise, although it is good to use the latest version, it is not mandatory to patch the HostAgent in parallel to SAP Kernels.

Former Member
0 Kudos

Hello,

wit User root.

Kind Regards

Hartwig Latz

HuseyinBilgen
Active Contributor
0 Kudos

Hi,

Did you performed the steps mentioned in SAPHostagent Install?

Installation Under UNIX

1. Switch to the root user, because you need to perform the installation under root.

2. If the sapsys group does not yet exist on the host, create it using, for example, the

command groupadd.

3. If the user sapadm does not yet exist on the host, create it using, for example, the

command useradd.

The user must be a member of the sapsys group.

4. If the SAPOSCOL working directory does not yet exist on the host, create the

directory usr/sap/tmp.

5. Decompress the SAPHOSTAGENT.SAR archive with the SAPCAR tool, following SAP

Note 212876. Normally, you use the following command for decompression and

executing it in the directory of the archive:

sapcar -xvf SAPHOSTAGENT.sar

6. Among other things, the archive contains the saphostexec program. Install

SAPHOSTCONTROL by entering the following command:

saphostexec -install

regards

HuseyinBilgen
Active Contributor
0 Kudos

Hi,

With which user you're installing? root or <sid>adm