cancel
Showing results for 
Search instead for 
Did you mean: 

Installation problem NW04 SP Stack 11 - Load Database

RenaldWittwer
Contributor
0 Kudos
187

Hi,

since a few days we can download the new NW04 Version SP Stack 11. Great!

I downloaded the Java Edition, not the Slim Edition and installed it on a Windows 2000 Server SP4, english Version.

During the Database Load I became the following Error, that I found in the file jload.log:


17.06.05 21:06 com.sap.inst.jload.Jload dbImport
SEVERE: DB Error during import of BC_EDM_EVENT

17.06.05 21:06 com.sap.inst.jload.Jload printSQLException
SEVERE: Message: Invalid object 11/23/04 3:00 PM of type
java.sql.Date assigned to host variable 5.

17.06.05 21:06 com.sap.inst.jload.Jload printSQLException
SEVERE: SQLState: SAP06

17.06.05 21:06 com.sap.inst.jload.Jload printSQLException
SEVERE: ErrorCode: 1001109

17.06.05 21:06 com.sap.inst.jload.Jload dbImport
INFO: trying to delete from table BC_EDM_PROJECT

17.06.05 21:06 com.sap.inst.jload.Jload dbImport
INFO: BC_EDM_PROJECT deleted

17.06.05 21:06 com.sap.inst.jload.Jload dbImport
SEVERE: DB Error during import of BC_EDM_PROJECT

17.06.05 21:06 com.sap.inst.jload.Jload printSQLException
SEVERE: Message: Invalid object 5/16/05 3:00 PM of type 
java.sql.Date assigned to host variable 5.

I found a workaround and I was thinking about to write it here, because it could damage your Installation!

I edited the file IMPORT.XML in the directory C:\Program Files\sapinst_instdir\NW04SR1\WEBAS_COPY\ONE_HOST after the problem occured. I deleted the four lines with the tables BC_EDM_EVENT and BC_EDM_PROJECT in it. After that the installation ended without errors.

As far as I can see the Enterprise portal runs without error. I can logon an was playing a little bit around, but probably the system will crash in the moment when it needs the tables. I don't know when.

Does anybody else has this problem?

Is it an error in the installation file?

Best regards

Renald

Accepted Solutions (0)

Answers (7)

Answers (7)

Former Member
0 Kudos

I had same problem. Thanks a lot for the workaround.

Former Member
0 Kudos

Renald,

With the work around you mentioned I could overcome the same error. My installation is on Windows 2000 Server SP4.

Thanks

Shaji

Former Member
0 Kudos

Hi everyone.

I encounter the same problems on Win2000 Japanese edition with SP4.

I found some symptoms before finishing installtion.

1.DBconnection is failed on JLoad phase22.

You should restart DB connection form SAP MMC.

after that you can retry installtion process from 'New installtion'.

'continue old installtion' will be 'connection failed'symtom again.

2.No respose from Installer

find DB Status from SAP MMC. data or log volume must be full.add volume to J2E 1500mb is not enough volume in case some retry.

regards.

Former Member
0 Kudos

Addition info on my previous message

if you finished to create table on jload.log like below.

but your installation process is stopped for connection.

you can skip Jload phase22 intentionally.

-


06.07.05 13:15 com.sap.inst.jload.Jload dbImport

INFO: XAP_CUR_CURRENCY01 loaded (0 rows)

06.07.05 13:15 com.sap.inst.jload.Jload dbImport

INFO: trying to create table XAP_CUR_EXCHANGERB

06.07.05 13:15 com.sap.inst.jload.Jload dbImport

INFO: table XAP_CUR_EXCHANGERB created

06.07.05 13:15 com.sap.inst.jload.Jload dbImport

INFO: XAP_CUR_EXCHANGERB loaded (0 rows)

06.07.05 13:15 com.sap.inst.jload.db.DBConnection disconnect

INFO: disconnected

-


so you can modify IMPORT.XML files to remove all objects

from

-


<object name="ADS_LICENSED_FORMS" type="T" action="create"/>

-


to

-


<object name="XAP_CUR_EXCHANGERB" action="insert"/>

-


and retry installation process.

so it will be skipped re-createing tables.

and all installation process continues successfull.

regards.

Former Member
0 Kudos

Hi,

the current best workaround is:

- change your windows timezone to GMT +1 (Berlin, Amsterdam, Rome,...) with daylight saving.

- Install

- Switch back to your timezone

Regards,

Armin

Former Member
0 Kudos

Perfect.

Thanks a lot.

Change the Timezone and continue installation

Thanks once again for the workaround.

~Kishor

Former Member
0 Kudos

Thanks, I'm on to the next step

Former Member
0 Kudos

Bottome line. Install things on a VMWare Instance. You will be glad you did.

Former Member
0 Kudos

Hi Renald,

Guess I am facing the same problem. I wud follow ur trick to see wat happens.Iam on Windows 2003.

Thanx

MauricioMiao
Contributor
0 Kudos

Hello Renald,

Many thanks for your work around, I have the same problem trying to install it in a Win XP SP2 Portuguese.

Thanks,

Mauricio

Former Member
0 Kudos

Hi,

this is a locale issue. The two tables are not vital for WebAS to run, they are part of a data dictionary sample project, the Education Data Model. Unless this sample is used, no problems should occur.

We're working on a fix for this problem. Meanwhile, you may want to go with the workaround provided by Renald. Thanks, Renald!

Regards,

Armin

Former Member
0 Kudos

Hi,

I had exactly the same error. I followed your workaround and the installation is moving forward now.

I'm installing on Windows XP pro SP2.

Thanks.

Former Member
0 Kudos

Faced the same Error, Did the workaround suggested.

But is there a standard solution?

Server Info : Windows 2000 Serv Pack 4 English

RenaldWittwer
Contributor
0 Kudos

Hi,

I tried the installation on an other system with windows 2000 professional german version, and it worked perfect. No errors!

Could it be that this is a problem with windows 2000 server english version?

Best regards

Renald

Oliver_S
Product and Topic Expert
Product and Topic Expert
0 Kudos

no, i runs also here on my english machines.

Strange - I have to investigate this.