cancel
Showing results forΒ 
Search instead forΒ 
Did you mean:Β 

Installation of SAP HANA Cockpit failed on HANA express sps04

petterhuseby
Participant
0 Kudos
1,274

After a long time the HANA express sps04 installation failed during installation of SAP HANA Cockpit. I will attached the log and the result of the command: xs display-installation-logs 4181 -scv. And hopefully someone can take a look at it to find the root cause.

Thanks in advanced πŸ™‚

lsubatin
Active Contributor
0 Kudos

HI Petter,

Can you please elaborate on where you're installing this? Is this a binary install? On which platform/OS? Is this an upgrade? Which other components are you installing/upgrading? WHat is the exact error (log2.txt is not saying anything relevant and hdblcm doesn't seem to have the intended content)

Thanks,

Lucia Subatin

Accepted Solutions (0)

Answers (10)

Answers (10)

panderle
Discoverer
0 Kudos

You need version of python 2.7. Opensuse Leap 15.x have default version 3x in path /usr/bin. Install python2 with Yast and check symlink and version in dir /usr/bin is created

python --version

/usr/bin # py

pydoc pydoc3 pydoc3.6 python python2 python2.7 python3 python3.6 python3.6m pyvenv pyvenv-3.6

/usr/bin # python --version

Python 2.7.17

holyspirit03
Explorer
0 Kudos

In my installation of opensuse, python was not installed at all.

So, I installed it, checked with "which python" as root and it worked.

petterhuseby
Participant
0 Kudos

Did some more "digging" and I found out that since install_hsa.sh must be executed by root the python fails to runs since root don't have the python in the PATH variable. So I suppose I have two chooses: Make new variables to root, or make hxeadm a root user.

petterhuseby
Participant
0 Kudos

Sinse the installation script seems to be buggy or needed python, I manage to use Lifecycle manager to install Streaming Analytics and AFL but APL failed. I have attached the log from SAP_AFL_SDK_APL.log

sap-afl-sdk-apl.txt

petterhuseby
Participant
0 Kudos

Here is the out from running install_hsa.sh

hana2:/tmp/HANA_EXPRESS_20 # ./install_hsa.sh Enter SAP HANA system ID [HXE]:

Enter HANA instance number [90]:

Enter local host name [hana2.skye.no]:

Enter System administrator (hxeadm) password :

./install_hsa.sh: line 322: python: command not found Invalid password. Enter System administrator (hxeadm) password :

petterhuseby
Participant
0 Kudos

Just to inform : This installation configuration works ok: ############################################################################## # Summary before execution # ############################################################################## HANA, express edition installer : /tmp/HANA_EXPRESS_20 Component(s) to install : HANA server, Application Function Library, SAP HANA EPM-MDS, and Extended Services + apps (XSA) Host name : hana2.skye.no HANA system ID : HXE HANA instance number : 90 Master password : ******** Log file : /var/tmp/setup_hxe_2019-09-04_09.32.35.log Proxy host : N/A Proxy port : N/A Hosts with no proxy : N/A Install SAP EA Designer : No Install Streaming Analytics : No Install SDI : No Install External Machine Learning Library : No Install Automated Predictive Library : No

petterhuseby
Participant
0 Kudos

Hi Lucia

This is a binary install on Open Suse Leap 15.1. Running on a Intel nuc server with 32 GB memory.

I did some testing yesterday and I can see the installing runs ok with HANA db and the XSA application server. When I try to install SAP HANA smart data integration manually I get error when I enter the password for HXEADMIN. It says that it's wrong. Could be some problem or compability issue with the installation script for Streaming Analytics(install_hsa.sh) It seems that this is the code that fails on Suse linux, I have make the line that I think is causing the problem as bold. It says Python, is it to that I need to install python on SUSE to get this to work?

# Check local OS user password

# $1 - user/login name

# $2 - password

checkLocalOSUserPwd() {

local user=$1

local passwd=$2

local shadow_hash=$(grep "^$user" /etc/shadow | cut -d':' -f2)

if [ -n "$shadow_hash" ]; then

if [[ ! "$shadow_hash" =~ \* && ! "$shadow_hash" =~ \! ]]; then

local algo=$(echo $shadow_hash | cut -d'

local salt=$(echo $shadow_hash | cut -d'

local allsalt="\${algo}\${salt}\$"local genpass=`python <<EOF import crypt,sys print crypt.crypt("$passwd", "$allsalt") EOF` if [ "$genpass" == "$shadow_hash" ]; thenreturn 0 else echo echo "Invalid password." echo fi else return 0 fi else echo echo "User \"$user\" does not exist." echo fi return 1 } -f2)
petterhuseby
Participant
0 Kudos

I tried a new installation, and choose to only install all the comonent and not the addons, and the installation went ok.

Maybe the error came from SAP HANA streaming Analytics, or SAP HANA smart data integration or SAP HANA external machine Learing Library or automated predictive Library. I will try to do a new installation without SAP HANA streaming Analytics and SAP HANA smart data integration, and see if that works ok.

petterhuseby
Participant
0 Kudos

Hi Kaushik

Thanks for links .-)

I manage to get further by doing the following steps:

  1. Uninstall of HANA
  2. Reboot
  3. Installed e few recommended updates on SUSE
  4. Added a entry to domain search list.
  5. Start the installation again.

The cockipt was installed, but after that the installation ended with the following messages that was repeated endlessly, have you seen this before?

kaus19d
Active Contributor
0 Kudos

Hi Petter Huseby,

Check the XSA User used is locked or not? check the XSA SSL certificate, which also can be resetted by,

XSA reset-certificate

Please also check the below,

https://wiki.scn.sap.com/wiki/display/SAPHANA/Troubleshooting+the+SAP+HANA+cockpit

Please check the port, also is suggested in below,

https://help.sap.com/doc/eb75509ab0fd1014a2c6ba9b6d252832/2.0.00/en-US/SAP_HANA_Administration_Guide...

Thanks,

Kaushik