cancel
Showing results for 
Search instead for 
Did you mean: 

Installation of SAP HANA APL V2.5.10

0 Kudos

I tried to install and setup the APL (SAP HANA APL V2.5.10) on HANA (version: SPS10.102.06). However, an error occurred when installing the APL.

I followed the steps described in page 14 to 15 of 'SAP HANA Automated Predictive Library Reference Guide' (pa25_hana_apl_user_en.pdf) as follows:

1/ I downloaded the installer 'SAPPAAPL2005P_100-80000819.TGZ' (Patch of SAP PA APL 2.5 for HANA SP 10 and higher) from SAP Support Portal.

2/ I stopped HANA.

3/ I tried to install the APL by the procedure 'Installing using the command line in interactive mode':

./hdblcm --action=update_components --component_dirs=/usr/local/src/apl-2.5.0.0-hanasp10-linux_x64/installer

('/usr/local/src/' is the path to be extracted 'apl-2.5.0.0-hanasp10-linux_x64' folder)

4/ I chose '1. All component' and entered 'System Administrator Password' during this procedure.

5/ Error occurred. The error messages are as follows:

Installing components...

Installing Automated Predictive Library...

Update of SAP HANA components failed.

  Installation of Automated Predictive Library failed

    Installation failed

      running in batch mode

        No password tag 'system_user_password' found

        Mandatory parameter 'system_user_password' (SQLSysPasswd) is missing or invalid

-------

Are there anything wrong with our steps or HANA versions?

Accepted Solutions (1)

Accepted Solutions (1)

0 Kudos

Hi Kentaro,

I installed a fresh HANA instance (version 102.06) on my machine:

  • go to the folder where the HANA setup package is located
  • sudo ./hdblcm, I am prompted for several information: (Assuming, my System ID (SID) is SCN)

  • I have to input 2 passwords:
    1. for the scnadm user, who is an OS account
    2. for the SYSTEM user, who is a HANA database account

Once the HANA installation is completed

  • I stopped my HANA instance
  • I go within the folder where the resident hdblcm is located (eg, /hana/shared/SCN/hdblcm/)
  • I extracted the APL 2.5.10 package into the followig folder ~/temp/ (Note, I have full acces to this folder)
  • sudo ./hdblcm --action=update_components --component_dirs=~/temp/apl-2.5.0.0-hanasp10-linux_x64/installer

  • I picked option #1: all
  • Then, I have to provide the password for the scnadm user, and another one for the SYSTEM user

Regards,

0 Kudos

Dear Jean-Raymond-san,

Thank you very much for your test and command results.

I noticed that in my install procedure, the following two 'prompts' which are prompted in your case seem to be skipped:

- Enter Database User Name [SYSTEM]:

- Enter Database User (SYSTEM) password:

And I noticed that the version of the resident hdblcm is '1.00.102.02' (not '1.00.102.06') while the database version is '1.00.102.06.1461042750'.

The version of the resident hdblcm may cause this error?

Best Regards,

0 Kudos

Dear customer,

Honestly, I was not even aware that it is possible to have a resident hdblcm with a version different than HANA database version.

By the way, starting from hdblcm version 102.03, the hdblcm tool will prompt you for the database user info (name and password). These info are required by APL package in order to deploy its internal Delivery Unit (named HCP_PA_APL).

So please, update your resident hdblcm to version 102.03

Regards,

0 Kudos

Dear Jean-Raymond-san,

Thank you very much for your suggestion.

We will update the resident hdblcm and try to install the APL V2.5.10.

Best Regards,

achab
Product and Topic Expert
Product and Topic Expert
0 Kudos

Hi Kentaro-san, could you please mark Jean-Raymond's answer as the correct one? Appreciated & thanks in advance. Please reopen a new thread later on if need be.

Best regards

Antoine

0 Kudos

Dear Jean-Raymond-san and Antoine-san,

I have installed the HANA APL V2.5.10 after updating the resident hdblcm to 102.06 (as the database version).

Thank you so much for your support and helpful command results!

Best Regards,

0 Kudos

Dear Kentaro,

I would like to install that APL too.

We have severals HANA instance and i would like to test APL on our Test Instance.


I installed VMware then i installed ubuntu 64 bit on it , then unixODBC.

Can you tell me step by step what should i do now ? should i extract that PAL file in my VMware player too ?

Best Regards

Hariz

achab
Product and Topic Expert
Product and Topic Expert
0 Kudos

Hi Hariz,

Please post this as a new question as per SCN rules of engagement ("do not resurrect old threads")

Thanks & regards

Antoine

Answers (2)

Answers (2)

achab
Product and Topic Expert
Product and Topic Expert
0 Kudos

Did you give it a try with the other modes? (Graphical interface or batch mode)

0 Kudos

Dear Antoine-san,

I tried with 'batch mode' (since I can access HANA server via console only). However, the install process failed. The steps are as follows:

1/ I run the following command (an option of '-action=update_components'  seems to be required):

./hdblcm -action=update_components --dump_configfile_template=/usr/local/src/apl_install.cfg

2/ I edited and saved the generated config file ('apl_install.cfg' above) to set values and passwords.


3/ I run the following command:

./hdblcm --batch --configfile=/usr/local/src/apl_install.cfg

And then, the (same) error messages are displayed:

Installing components...
Installing Automated Predictive Library...
Update of SAP HANA components failed.
  Installation of Automated Predictive Library failed
    Installation failed
      running in batch mode
        No password tag 'system_user_password' found
        Mandatory parameter 'system_user_password' (SQLSysPasswd) is missing or invalid

-----------

In the config file, there is the entry 'system_user_password' (I set its password):

# Database User Password
system_user_password=xxxxxx

We would be very grateful if there are any workaround on his issue.

achab
Product and Topic Expert
Product and Topic Expert
0 Kudos

Dear Kentaro-san,

Thanks for the additional tests. I'll follow up with our local experts and let you know their recommendations.

Best regards


Antoine

achab
Product and Topic Expert
Product and Topic Expert
0 Kudos

Hello,

Everything seems to be OK, at least looking at the PAM and documentation. I'll connect with our local experts to see what they say about this. Stay tuned!

Thanks & regards

Antoine-san