cancel
Showing results for 
Search instead for 
Did you mean: 

Installation Error: CTC retval is not 0 but 1.

Former Member
0 Kudos
71

Hello Experts,

installing NW 7.0 in Phase 102 "Prepare to install minimal configuration" an error occurred: CTC retval is not 0 but 1.

My JDK is the special version for SAP:

JAVA_HOME = C:\j2sdk1.4.2_18-x64

SAPINST_JRE_HOME = C:\j2sdk1.4.2_18-x64

What is CTC? Could I call offline manually?

Errror Message:

_________________

ERROR 2008-08-06 16:30:38.614

FCO-00011 The step callOfflineCTC with step key |NW_Onehost|ind|ind|ind|ind|0|0|SAP_Software_Features_Configuration|ind|ind|ind|ind|6|0|NW_Call_Offline_CTC|ind|ind|ind|ind|7|0|callOfflineCTC was executed with status ERROR ( Last error reported by the step :Caught ESAPinstException in Modulecall: in

function NW_Call_Offline_CTC_ind_ind_ind_ind_SubComponentContainer_callOfflineCTC() {

var nw = NWInstall.getSystem(context.get("sid"));

var ctcDirFs = nw.getCI().getInstanceDir().concat("j2ee", "ctc");

var ctcExeFile = installer.onWindows() ? "LaunchOfflinectc.bat" : "LaunchOfflinectc.sh";

var ctcCall = ctcDirFs.concat(ctcExeFile);

installer.writeTrace("CTC is in" + ctcCall);

ASSERT(arguments.callee, ctcCall.isExisting(), "CTC executable cannot be found in " + ctcCall.toString());

var pmgt = new ProcessMgt();

var app = pmgt.createChildApplication(ctcCall, []);

var userData = nw.getUsers().getAccountData(NWUsers.roles.SIDAdm);

var user = (new AccountMgt()).getUser(userData.name);

var env = pmgt.getProcessEnvironment();

if (installer.onUnix()) {

env.setUser(user);

}

env.setWorkingDirectory(ctcDirFs.getNode());

env.setEnvironmentVariable(new Property("JAVA_HOME", nw.getJavaHome().toString()));

installer.writeTrace("For the Offline CTC Call, JAVA_HOME is set to " + env.getEnvironmentVariable("JAVA_HOME"));

app.setEnvironment(env);

var retval = app.run([], true);

ASSERT(arguments.callee, retval == 0, "CTC retval is not 0 but " + retval);

installer.writeTrace("CTC has been called in Offline Mode.");

}

CTC retval is not 0 but 1.).

_________________________

Thank you.

Best Regards

Bernd

Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos

Did you check this thread?

Looks like the same problem.

Answers (2)

Answers (2)

Former Member
0 Kudos

Starting manually solved the problem. Generally on Windows Server 2008 many problems are disappearing when you

- stop installation, restart windows, start SAP Servers in Management Console and continue to install or

- check users in Server Management and apply without changes (sic!) or

- login on Windows with nspadm and continue to install

- start SAP servers services manually and retry.

Former Member
0 Kudos

Hello Kevin,

I have replaced sap.comtclmctcoffline_ctc_lib~Library.jar with archive attached in Note 1094628.

It doesn't solved the problem.

In case of Thread 883409 retval = 255. In my Error Message retval = 1.

I launched LaunchOfflinectc.bat manually. But sapinst doesn't stepped over retrying.

I keep investigating.

Best Regards

Bernd

Former Member
0 Kudos

Sorry that didn't help. I'm out of ideas ... good luck and hopefully some other people here can help.