cancel
Showing results for 
Search instead for 
Did you mean: 

Install SOLMAN 7.1 on Windows 2012 R2 failed at ABAP import level

Former Member
0 Kudos
166

Dears,

I am installing SOLMAN 7.1 at my Windows 2012 R2 server, and at the Import ABAP phase, and precisely at this level : Import Monitor jobs: running 1, waiting 1, completed 26, failed 1, total 29.

I got this ERROR:

"

An error occurred while processing option SAP NetWeaver 7.5 > MaxDB > SAP Systems > Application Server ABAP > Standard System > Standard System( Last error reported by the step: Program 'Migration Monitor' exits with error code 103. For details see log file(s) import_monitor.java.log, import_monitor.log.). You can now:

  • Choose Retry
    to repeat the current step.
  • Choose Log Files
    to get more information about the error.
  • Stop the option and continue later.

Log files are written to C:/Program Files/sapinst_instdir/NW750/ADA/INSTALL/STD/ABAP.

"

Yu can find more details in the thread i have opened by error at other community: full link: http://scn.sap.com/message/16533177#16533177

So, need your expertise in sorting out this issue.

Here a summary of what I am using as software:

- Download manager V2.1.142 to download the media from Market Place

- SLTOOLSET Software Provisioning Version 1.0

Unfortunatey, the log files are heavy and cannot attach them here, as 1MB is max.

If you require more details

Do not want to flood this post with entries from the logs...Please let me know your feedback how can I go forward ?

Are the tooling versions Ok ?

What the error says ...shall I start from scratch ? (I tried many time, by downloading again the suspect SW and unpack, but without success)

Thanks in advance.

Ahmed.

Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos

Hi Folks,

I have switched the OS (from 2012 to 2008), and corrected a lot of issues...

I have built my own procedure for SOLMAN 7.1 SR1 Setup on windows 2008 R2 + MAXDB environment, after I have succeeded to install it.

I like that peaple can profit from it and avoid suffer like I did.

Sharing it with you...Sorry, I cannot attch it directly to this thread, as the Word format is not allowed in SCN...So, you can download it via the link below.

Procedure of SOLMAN 7.1 SR1.docx - Google Drive

Hope this will hep the incoming installers

Happy to help, enjoy.

Thanks,

Ahmed.

Answers (1)

Answers (1)

former_member80258
Participant
0 Kudos

Hi Ahmed

This document procedure is greatest:

Former Member
0 Kudos

Hi Community Folks,

Still insisting and trying to sort this issue and succeed SOLMAN 7.1  installation.

Actually, in Market Place, only Media for 7.1 are available, so that decided to continue with it.

I have downloaded the latest version of SLTOOLSET Software Provisionning and , restarted the installation, but unfortunately, with same error at same level...

However, i took a look at the sapinst_dev and sapinst_loginquirer files and found one pertinent error:

System call failed. Error 5 (Access is denied.

) in execution of system call 'CreateFile' with parameter (C:\Documents and Settings), line (26) in file (d:\depot\bas\720_rel\bc_720-2_rel\gen\optu\ntamd64\ins\sapinst\impl\src\syslib\synxclink.cpp), stack trace: d:\depot\bas\720_rel\bc_720-2_rel\gen\optu\ntamd64\ins\sapinst\impl\src\guiengine\iaxxdirbrs.cpp: 74: CDirectoryBrsHandler::doHandleDoc()

d:\depot\bas\720_rel\bc_720-2_rel\gen\optu\ntamd64\ins\sapinst\impl\src\guiengine\iaxxdirbrs.cpp: 148: CDirectoryBrsHandler::findFiles()

d:\depot\bas\720_rel\bc_720-2_rel\gen\optu\ntamd64\ins\sapinst\impl\src\syslib\syxxclink.cpp: 131: CSyLinkImpl::isResolvable()

d:\depot\bas\720_rel\bc_720-2_rel\gen\optu\ntamd64\ins\sapinst\impl\src\syslib\synxclink.cpp: 85: CSyLinkImpl::resolveTarget()

d:\depot\bas\720_rel\bc_720-2_rel\gen\optu\ntamd64\ins\sapinst\impl\src\syslib\synxclink.cpp: 18: CSyLinkImpl::getTargetPathObject()

.

Failed action: CreateFile with parameters C:\Documents and Settings

Error number 5 error type WIN32_ERROR

The problem, is that I do not have drive (D:) in my virtual Windows machine !!!

And during the preparation phase, i have never mentionned a path with 😧 (C: rather, contains all media).

So, this might be the root cause ??

Can anyone help, please ??

Thanks,

Ahmed.

former_member185239
Active Contributor
0 Kudos

Hi Ahmed,

Its a permission issue on your system.

just disable the Integrity check on the system

"Start -> All Programs -> Accessories -> Right click Command Prompt -> Run as administrator", then type in the following, "bcdedit /set loadoptions DDISABLE_INTEGRITY_CHECKS".

With Regards

Ashutosh Chaturvedi

Former Member
0 Kudos

Dear Ashutosh,

Thanks for our input and efforts.

Actually, i tried your advice, and clicked the "Retry" button, however, got the same ERROR.

In Import_monitor log file:

ERROR: 2016-03-08 15:52:50 com.sap.inst.migmon.LoadTask run

Loading of 'SAPSSEXC' import package is interrupted with R3load error.

Process 'C:\usr\sap\ST1\SYS\exe\uc\NTAMD64\R3load.exe -i SAPSSEXC.cmd -dbcodepage 4103 -l SAPSSEXC.log -nolog -c 50000 -force_repeat -para_cnt 18 -decluster' exited with return code 2.

For mode details see 'SAPSSEXC.log' file.

INFO: 2016-03-08 15:57:52 com.sap.inst.migmon.LoadTask run_report

Monitor jobs: running 0, waiting 1, completed 26, failed 2, total 29  error processing of package SAPAPPL1

ERROR: 2016-03-08 15:57:52 com.sap.inst.migmon.LoadTask run

Loading of 'SAPAPPL1' import package is interrupted with R3load error.

Process 'C:\usr\sap\ST1\SYS\exe\uc\NTAMD64\R3load.exe -i SAPAPPL1.cmd -dbcodepage 4103 -l SAPAPPL1.log -nolog -c 50000 -force_repeat -para_cnt 18 -decluster' exited with return code 2.

For mode details see 'SAPAPPL1.log' file.

WARNING: 2016-03-08 15:58:20

Cannot start import of packages with views because not all import packages with tables are loaded successfully.

WARNING: 2016-03-08 15:58:20

2 error(s) during processing of packages.

INFO: 2016-03-08 15:58:20

Import Monitor is stopped.

At sapinst_loginquirer , same error as well: (I do not have drive D in my computer, however, still references in error below):

TRACE      2016-03-08 15:58:20.881 (SAP-MANAGER\Administrator) [synxcchapp.cpp:236] CSyChildApplicationImpl::doStart()

Exception thrown near line 584 in file d:\depot\bas\720_rel\bc_720-2_rel\gen\optu\ntamd64\ins\sapinst\impl\src\syslib\synxcchapp.cpp

At line 584 file d:\depot\bas\720_rel\bc_720-2_rel\gen\optu\ntamd64\ins\sapinst\impl\src\syslib\synxcchapp.cpp

Call stack:

d:\depot\bas\720_rel\bc_720-2_rel\gen\optu\ntamd64\ins\sapinst\impl\src\ejs\ejscontroller.cpp: 309: EJSControllerImpl::callLogInquirer()

d:\depot\bas\720_rel\bc_720-2_rel\gen\optu\ntamd64\ins\sapinst\impl\src\ejs\jsextension.hpp: 1136: CallFunctionBase::call()

d:\depot\bas\720_rel\bc_720-2_rel\gen\optu\ntamd64\ins\sapinst\impl\src\osmod\iaxxcprocess.cpp: 120: iastring CIaOsProcessConnect::callMemberFunction(iastring const& name, args_t const& args)

d:\depot\bas\720_rel\bc_720-2_rel\gen\optu\ntamd64\ins\sapinst\impl\src\osmod\iaxxcprocess.cpp: 1346: iastring CIaOsProcessConnect::start(args_t const& _args)

d:\depot\bas\720_rel\bc_720-2_rel\gen\optu\ntamd64\ins\sapinst\impl\src\osmod\iaxxbprocess.cpp: 421: CIaOsProcess::start_impl()

d:\depot\bas\720_rel\bc_720-2_rel\gen\optu\ntamd64\ins\sapinst\impl\src\syslib\synxcchapp.cpp: 238: CSyChildApplicationImpl::start(false)

d:\depot\bas\720_rel\bc_720-2_rel\gen\optu\ntamd64\ins\sapinst\impl\src\syslib\synxcchapp.cpp: 262: CSyChildApplicationImpl::doStart()

System call failed. Error 2 (The system cannot find the file specified.

) in execution of system call 'CreateProcess' with parameter (NULL, <command line for executable undefined\bin\java.exe, NULL, NULL, TRUE, 0x420, NULL, NULL, &StartupInfo, &ProcessInfo), line (584) in file (d:\depot\bas\720_rel\bc_720-2_rel\gen\optu\ntamd64\ins\sapinst\impl\src\syslib\synxcchapp.cpp), stack trace: d:\depot\bas\720_rel\bc_720-2_rel\gen\optu\ntamd64\ins\sapinst\impl\src\ejs\ejscontroller.cpp: 309: EJSControllerImpl::callLogInquirer()

d:\depot\bas\720_rel\bc_720-2_rel\gen\optu\ntamd64\ins\sapinst\impl\src\ejs\jsextension.hpp: 1136: CallFunctionBase::call()

d:\depot\bas\720_rel\bc_720-2_rel\gen\optu\ntamd64\ins\sapinst\impl\src\osmod\iaxxcprocess.cpp: 120: iastring CIaOsProcessConnect::callMemberFunction(iastring const& name, args_t const& args)

d:\depot\bas\720_rel\bc_720-2_rel\gen\optu\ntamd64\ins\sapinst\impl\src\osmod\iaxxcprocess.cpp: 1346: iastring CIaOsProcessConnect::start(args_t const& _args)

d:\depot\bas\720_rel\bc_720-2_rel\gen\optu\ntamd64\ins\sapinst\impl\src\osmod\iaxxbprocess.cpp: 421: CIaOsProcess::start_impl()

d:\depot\bas\720_rel\bc_720-2_rel\gen\optu\ntamd64\ins\sapinst\impl\src\syslib\synxcchapp.cpp: 238: CSyChildApplicationImpl::start(false)

d:\depot\bas\720_rel\bc_720-2_rel\gen\optu\ntamd64\ins\sapinst\impl\src\syslib\synxcchapp.cpp: 262: CSyChildApplicationImpl::doStart()

.

Failed action: CreateProcess with parameters NULL, <command line for executable undefined\bin\java.exe, NULL, NULL, TRUE, 0x420, NULL, NULL, &StartupInfo, &ProcessInfo

Error number 2 error type WIN32_ERROR

Please, can you check and advice ?!!

Thanks and Kind Regards.

former_member185239
Active Contributor
0 Kudos

Hi Ahmed,

Just reboot the server , then rerun the SWPM with continue with old option

With Regards

Ashutosh Chaturvedi

Former Member
0 Kudos

Hi Ashutosh,

Still no chance, even after reboot and again disabling the integrity checks.

I am trying now to prepare new VM with Windows 2008 R2 server, instead of 2012 R2.

I hope will sort that out, as in logs I saw many system calls failure...

Meanwhile, if you have any other suggestion, please feel free to post.

Will keep you posted with results.

Thanks,

Ahmed.

Former Member
0 Kudos

Hi,

Updating this thread...

Actually, I am still in ERROR mode with SOLMAN 7.1 SR1 setup.

But with a moderated progress.

In fact, the error reported at first step, was resolved, by getting the right SLTOOLSET SWPM version.

This woud have been avoided, if the correct version was included in the SOLMAN Media list at Market Place.

In the guides, they ask to download the latest version !!!

SOLMAN 7.1 SR1 needs SWPM1.0 SP9/10 based on Neweaver 7.0 (70SPPM10SP10)

After installing new version and resuming the installation, I got new error:

       An error occurred while processing option SAP Solution Manager 7.1 Support Release 1 > SAP Systems > MaxDB > Central System > Central System( Last error reported by the step: Instance ST1/DVEBMGS00 reached state SHUTDOWN after having state STARTING. Giving up.). You can now:

  • Choose Retry
    to repeat the current step.
  • Choose Log Files
    to get more information about the error.
  • Stop the option and continue later.

Log files are written to C:\Program Files/sapinst_instdir/SOLMAN71/SYSTEM/ADA/CENTRAL/AS.  

in dev_w0, i can see these pertinent error:

M  ***LOG Q0I=> NiPGetHostByName: 'SAP-MANAGER.focus.com.tn' not found: getaddrinfo [D:/depot/bas/745_REL/src/base/ni/ninti.c 896]

M  *** ERROR => ThSetGwParam : NiHostToAddr SAP-MANAGER.focus.com.tn failed [thParam.c    3422]

M  in_ThErrHandle: 1

M  *** ERROR => ThInit: ThProfileRead (step TH_INIT, thRc ERROR-CORE-INIT_FAILED, action STOP_WP, level 1) [thxxhead.c   2456]

M

C:\>ipconfig /all

Windows IP Configuration

   Host Name . . . . . . . . . . . . : SAP-MANAGER

   Primary Dns Suffix  . . . . . . . :

   Node Type . . . . . . . . . . . . : Hybrid

   IP Routing Enabled. . . . . . . . : No

   WINS Proxy Enabled. . . . . . . . : No

   DNS Suffix Search List. . . . . . : focus.com.tn

Ethernet adapter Ethernet:

   Connection-specific DNS Suffix  . : focus.com.tn

   Description . . . . . . . . . . . : Intel(R) 82574L Gigabit Network Connection

   Physical Address. . . . . . . . . : 00-50-56-92-B2-46

   DHCP Enabled. . . . . . . . . . . : Yes

   Autoconfiguration Enabled . . . . : Yes

   Link-local IPv6 Address . . . . . : fe80::89d6:9afa:4d0b:3cc9%12(Preferred)

   IPv4 Address. . . . . . . . . . . : 192.168.30.205(Preferred)

   Subnet Mask . . . . . . . . . . . : 255.255.255.0

   Lease Obtained. . . . . . . . . . : mardi 15 mars 2016 12:44:36

   Lease Expires . . . . . . . . . . : jeudi 17 mars 2016 00:44:35

   Default Gateway . . . . . . . . . : 192.168.30.254

   DHCP Server . . . . . . . . . . . : 10.5.5.2

   DHCPv6 IAID . . . . . . . . . . . : 302010454

   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-1D-F1-8A-E5-00-50-56-92-B2-46

   DNS Servers . . . . . . . . . . . : 10.5.15.3

   Primary WINS Server . . . . . . . : 10.5.15.3

   Secondary WINS Server . . . . . . : 10.5.15.5

   NetBIOS over Tcpip. . . . . . . . : Enabled

Tunnel adapter isatap.focus.com.tn:

   Media State . . . . . . . . . . . : Media disconnected

   Connection-specific DNS Suffix  . : focus.com.tn

   Description . . . . . . . . . . . : Microsoft ISATAP Adapter #2

   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0

   DHCP Enabled. . . . . . . . . . . : No

   Autoconfiguration Enabled . . . . : Yes

C:\>

Can someone, give help, please ?

Thanks,

Ahmed.