cancel
Showing results for 
Search instead for 
Did you mean: 

Infopackage is not bringing changed records

Former Member
0 Kudos

Hi,

I am running IP for 0PERSON_ATTR in the process chain. It is not bringinging the modified records when we do a bulk load. If i run for a specific person id then it is bringing the modified records of that employee.

Can you please help in resolving the issue

Accepted Solutions (0)

Answers (7)

Answers (7)

abhishek_shanbhogue2
Contributor
0 Kudos

Even we had a similar issue where client records was not refreshed in BW even after we do a full load but it did when we do a selective load. Here is how I resolved it (our data models are 3X flow)

1. Replicated the DS

2. Activated the Transfer Structure

3. Created 8 different variants of info package with client number range (in your case personnel number)

4. Change the IP as direct to Infoobject and not in PSA/Update from PSA

5. Include all the variants in serquence in you daily batch job

6. Attr change run

Thanks

Abhishek Shanbhogue

Former Member
0 Kudos

Check the data in RSA3 whether it has new records or not, delete request from PSA, replicate your datasource. Re-run the IP.

Former Member
0 Kudos

Hi,

Do you have the right authorisation. Is there any data authorisation?

Just an thought, maybe this might not helpful but pls check in source system in which user the job get triggered and give an full authorisation for that user and execute the IP.

former_member210253
Contributor
0 Kudos

Hi,

How  will you have old and modified data at ECC for master data.

If IP is full it will bring all the data whatever present at source table.In the source table will you have two images for changed/modified records ?.

Regards,

Babu.

Former Member
0 Kudos

Hi,

On Info Package --> update tab, make sure to have correct start and end date.


After then, Activate the master data change via “Execute Hierarchy/Attribute Change for reporting” function. (Via AWB -> Tool menu option)



Thanks

KulDeepJain
Active Participant
0 Kudos

Hi Ramesh,

Can you please give detail for issue and what error message you are getting. It will help us more to give precise answer.

One quick reply can be try setting data package size properly and rerun the IP.

Regards,

KD J

Former Member
0 Kudos

Hi Jain,

I am not getting any error, but it is bringing the old value instead new.Below is the data package setting

Maxsize=20,000

no.of data packets per info-idoc=10

no.of data packages per delta request=0

Former Member
0 Kudos

Replicate the datasource and check the values. You will get new values. Replication required in case of datasource changes.

Former Member
0 Kudos

Hello Ramesh,

Provided you have replucated and activated the DataSoure, where is that you are cehcking the record? In PSA only is it bringing old value?

Can it be the case that while running Full Ip then checking in PSA you are still looking at old record.. did you try to see the record by passsing a filter in PSA and see all the records or that employee!

Could u please try creating a new IP and run & check.

Regards,

Gaurav

Former Member
0 Kudos

or if is it at MAster data lelel, did you try running Attribute change run and check.

/Gaurav

Former Member
0 Kudos

Yes I am checking in PSA only. I already tried with a new IP, but the same is happening with the new IP. PSA itself not having the latest record, but when I pass the filter means for a specific employee im getting proper data.

Assumption is on high volume of data it is not bringing the modified records. Where as if I go with specific filter then data volume is very low and it is bringing the proper data. Why is this happening?

Activation of master data is later part.

RamanKorrapati
Active Contributor
0 Kudos

Hi,

What kind of info pack you ran.

is it delta or full load?

Can you try to run your data source at Source side RSA3 for particular employee(person, which is modiifed).

Thanks

Former Member
0 Kudos

It is full load. it is showing the proper records at ECC level

RamanKorrapati
Active Contributor
0 Kudos

Hi,

Are you sure about modified records are saving properly at a time source side.

As it is full load then just replicate your data source and activate it by using program - RSDS_DATASOURCE_ACTIVATE_ALL(For 7.x version)

Once records are modified at soruce, you can trigger your info pack and cross check the latest modifed record received or not.

Thanks

Former Member
0 Kudos

I have replicated and activated the data source. but still it is bringing old value. If I run the IP for single employee, it is bringing the latest modified value.

RamanKorrapati
Active Contributor
0 Kudos

copy your prod data to ecc and implement your isse at dev.

You can debug your info pack and see. form where its picking old data rather than new one.