cancel
Showing results for 
Search instead for 
Did you mean: 

Importing a Job issue in BODS

Former Member
0 Kudos
141

Hi

I have been trying to import a job from other machine and i m getting below error. Version using BODS 12.2

Did anybody encountered this issue before. I have also tried to edit the .atl file and do some syntax related changes but still not able to rectify it.

Please help on this regard.

Abdulrasheed.

Accepted Solutions (0)

Answers (1)

Answers (1)

rupeshsf0320
Explorer
0 Kudos

Hi Abdul,

    Let me know does both the systems have same BODS version.

    Are you IMPORTING only job ? what about other dependencies.

    Check whether the ATL has any security.

Thanks,

Rupesh

Former Member
0 Kudos

Hi Rupesh,

Version is same in both the systems.

Yes i m importing only job and i has exported everything which comes with the job.

There is no security been defined. actually, we had taken latest version from central repository and then exported as file to import it into other machine.

One strange thing is, when you search for this string <r_recoverable>, which is actually a <bulk_ldr_recoverable> in some other lines. In most of the coding lines of the .atl file there is one symbols like in a rectangular shape which may be BODS doesn't read it.

This is just a finding. Please do let me know your thoughts as well.

Regards,

Abdulrasheed.

rupeshsf0320
Explorer
0 Kudos

HI Abdul,

There was a SAP note for the same issue.

But its for the old DI version.

1185493 - Error: "Please check and fix the syntax and retry the operation" when attempting to use a script variable copied from Data Integrator 5.x to a 6.x installation.

  Probably this issue was fixed in the latest version.

  Will update you, if I get any information on this issue in the latest BODS versions.

Thanks,

Rupesh

Former Member
0 Kudos

Hi Abdul,

Any time did you upgrade the version or repository?

Arun

Former Member
0 Kudos

Hi Rupesh,

Now, i have export the job again as .xml and and imported that in new machine. Now this issue got resolved. Can able to view the job will the required stuff.

Thanks,

Abdulrasheed.

rupeshsf0320
Explorer
0 Kudos

Hi Abdul,

    Good to know that the problem was solved.

    Let me know, If you've done any changes to solve the issue.

Thanks,

Rupesh

Former Member
0 Kudos

I didn't change anything Rupesh. while exporting that same job, just saved it as .xml and imported it in new  machine. But strange, what the difference it found in .atl and .xml not sure.