cancel
Showing results for 
Search instead for 
Did you mean: 

import statement vanishes while saving metadata

Former Member
0 Kudos
59

Hi

I am facing a strange problem.When I am saving metadata the import statements are erased from the //begin import and // end section in the implementation section of a view.But all packages are present.

Pease help

Accepted Solutions (0)

Answers (1)

Answers (1)

detlev_beutner
Active Contributor
0 Kudos

Hi,

sounds strange in fact; I have some "déja vu" with this, but that would be 1.5 years ago - so I ask myself, on what version you are?!

Best regards

Detlev

Former Member
0 Kudos

Hi

I am using SAP NetWeaver Developer Studio

Version: 2.0.12

Build id: 200505090134

Please help.

Regards

Ananda

Yashpal
Active Contributor
0 Kudos

Hi,

this problem is with ur all views or a specific view have u changed anything check it .with other views .

it should be like below.

//@@begin imports

import yash2.wdp.IPrivateDsfs;

import java.util.Locale;

//@@end

Regards,

Yashpal

Former Member
0 Kudos

Hi

Sometimes it is hapening ; not for all views.I know what or where it should be placed BUT when am manually writing it and press 'Save MetaData' the import vanishes ; also the 'Code Completion ' feature doesn't list the import.

Please help

Ananda

Former Member
0 Kudos

Hi

Does anyone knows the workaround of this problem

Thanks

Ananda

Former Member
0 Kudos

Does anyone has a solution for this, I have the same problem and running on 2.0.16...

Former Member
0 Kudos

Check if there are errors with the metadata of your project, see "Problems" view in Eclipse.

Another possibility may be an exception in the NWDS, open the "PDE runtime" -> "Error log" view.

Do you find anything that might cause the problem?

Armin

Former Member
0 Kudos

Hi Armin

I have installed NWDS

Version: 2.0.14

Build id: 200509100215

which solved this problem.Seems that it was the problem with the NWDS.

Thanks

Ananda

Former Member
0 Kudos

Any news about this?

I have the same problem. I tried to re-install NWDS(Version 2.0.9), then I tried Version 7.0.6 but the problem still resists. I would appreciate any advice

Regards

Ivo