cancel
Showing results for 
Search instead for 
Did you mean: 

Import record-automatic

Former Member
0 Kudos

Hi all,

I am facing an interesting issue.

I have imported one record using IMPORT SERVER as automatic by placing the xml file in the ready folder.

That record have the partner number as "50001" with the name " rahul".

It was imported successfully.

After that i have imported another record having the partner number as "50001" with the name " vijay" (in this record i changed the name only noy partner number).

And i placed it in ready folder , its imported. i can see the record in the archive folder with my changes.

But in the data manager i am seeing the old record only.

What is the problem in this?

Why the modified record having the same partner number is not uploading?

Thanks in advance.

Vijay

Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos

Hi Vijay,

This is due to two main factors

1) The import action as saved in your map when using the automatic importing

2) The matching field you have selected for importing the records

- As the matching field is selected as Partner number it is matching the incoming records based on the partner number

- So if the partner number is same for two records only one out of the two gets selected under the create import action and

- The other one come under the Update all mapped fields

So ultimately in the MDM rep you will have just 1 rec with the distinct primary key.

If you want them to be imported as two separate records then you will have to amke aminor change in your import map.Change the matching field to Name then both the records will get imported.As the deciding field to create unique records in MDM si Name and the Name in both the rec are diff

Hope It Helped,

Thanks & Regards

Simona Pinto

Former Member
0 Kudos

Hi Nitin/Simona,

Thanks.

When i created a new map (which one i mentioned in the port) ,i have given the import action as "create".

For this only its doing like this?

how can i modify the map?

in my case i want to import the updated data only , not going to create new record.

what to do?

Regards,

vijay

Former Member
0 Kudos

Hi Vijay,

If the import action is create.it will create a new record only if the matching primary key is new .Or else it will automatically come under the skip import action and the craete import action will have 0 records to import so ultimately you have not imported any new rec in MDM.

If atall you had selecte Update all mapped feilds to as the next import action for the asme map the it would have updated the record with the same number but the new name.

Hope It Helped,

Thanks & Regards

Simona Pinto

Former Member
0 Kudos

Hi Vijay,

Once you have successfully imported records. try importing several records amongst the records you have already imported also incule one new record. In this case you will get both the import actions i.e. Create as well as Update. Now save the map. When ever you import using the same map it automatically identifies the new records and the records to be updated.

Regards,

Jitesh Talreja

Former Member
0 Kudos

Hi Vijay,

1) Unload the repository.

2) Open IMport Manager with a source file and open the import map that you have saved.

3)Then go to the Match Tab and make the changes mentioned below.

For the records which are tries to be imported again, you need to set the second Import Action

1st row - import Action - Create

2nd Row- import Action - Update All mapped Fields

This will update the data when you try to import the same data for the 2nd time.

3) Save the map and Load the repository again with Update indices.

4) Place the file back in the Inbound ready folder.

5) You will find the file imported with updated results in the Data Manager

Hope ite helps

Thanks and Regards

Nitin Jain

Answers (2)

Answers (2)

Former Member
0 Kudos

Hi Vijay,

Check the Key based on which it is decided which records are to be imported. In your case it should be Partner number and since 50001 is already present in the repository it is not doing any thing. So select the proper Matching Key you can also combine the fields to perform matching.

Regards,

Jitesh Talreja

Former Member
0 Kudos

Hi Vijay,

It depends upon the settings you have done in the Import Map.

Open the Import Map through the Import Manager.

GO to Match Fields Tab and choose only Partner Number if you only want only 1 record in this case.

And then go to the Default Import Action ( which is on the right side in the same tab) and choose "Update Mapped Fields" in the second Row. ( And for the first row, choose create)

Save the Map and then place the fiel again the Inbound Ready Folder.

You will find the Value - Vijay getting updated in the Data Manager.

Hope it helps.

Thanks and Regards

Nitin Jain