Showing results for 
Search instead for 
Did you mean: 

Import Manager - Import Parent Child Relationships

Former Member
0 Kudos

I have a parent child relationship set up in console.

Kits / Parts.

Has Required = No

Has Quantity = No

I am trying to import the data for the relationship links using Import Manager.

The source is a Excel file.

Item Number <Kits> Item Number<Parts>

ACC-123 ACC-1234

ACC-123 ACC-555

I mapped the Item Number Kits and Item Number Parts.

When I import, I am getting the following error

<b>Import failed. Failed to find the aggregation record from its field values.

Source record no: 1</b>

I am able to import the same record using Data Manager if the file format is Text.

Any help is appreciated.

Helpful answers will be duly rewarded

Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos


What happens if you try using an Access Database instead? Excel sheets have this thing with write permissions that sometimes get in the way of MDM Imports



Former Member
0 Kudos

I tried with Access Database instead.

I get the sam error.

Import failed. Failed to find the aggregation record from its field values.

Source record no: 1

I did check the Configuration Settings in Import Manager.

Aggregate by : Parent

Links Update: Replace

New Links: Create

Existing Links (Update Only) : Update (All mapped Fields)

Any other suggestions?

Former Member
0 Kudos

Any other suggestions please??

Former Member
0 Kudos

Hi Thiagaraj,

I am also facing the similar issue with <optional sevice> relationship have any updates on this...



Answers (2)

Answers (2)

0 Kudos

The key field that you use to load the relationship must be defined as:




My problem was that I had defined Model Number as multiligual. When I changed this setting and loaded with Update Indices the load worked.

I have not found anywhere in the literature that talks about this restriction. You can create the relationship in the Console. You can load this type of relationship in Data Manager. You can not however load them in Import Manager.

Former Member
0 Kudos

Looks like one or both records (parent and child) do not exist in your repository