cancel
Showing results forΒ 
Search instead forΒ 
Did you mean:Β 

iFlow: Buggy or am I doing wrong?

Former Member
0 Kudos

We just "in migration" from SAP PI 7.11 to PO 7.50,

therefore we are completely new to iFlow.

I have also read all I can find about iFlows, specially

As you can see, we do like SDN. πŸ™‚

iFlows in Eclipse (we are using NWDS 7.5, SP02, Patch 1) works fine as long as we do it like "". But in this documentation allways a new Business System was created (see step 9 and step 14 on page 7f).

So, we do want to reuse business systems.

Therefore we create the Business-System in eclipse by right-click on Systems --> new Business-Component:

Sorry, screenshots are from german eclipse (and I do not have any idea how to switch back to english, but thats another point).

So, than we add Interfaces to that Business-Component:

Works all fine.

But, as soon as I want to use that Business-Component in the iFlow (I created one using Right Click --> New Integration Flow) I am not able to choose any interface!!!

As you can see, the dialog box is empty.

Same if I say "finish" and edit the iFlow:

So, my question is: is this a Bug or am I doing wrong?

Thx,

Rene

Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos

We found a solution for that:

The problem is: GERMAN.

So, if my machine is configured as german machine, the PI Plugins within Eclipse (only the PI-Plugins, the rest of eclipse stays in english) are switched to german.

And than: It does not work.

So: Solution 1: Switch Windows to something else than german (big issue)

Solution 2: adjust eclipse.ini

We have that eclipse.ini currently:

-startup

plugins/org.eclipse.equinox.launcher_1.3.100.v20150511-1540.jar

--launcher.library

plugins/org.eclipse.equinox.launcher.win32.win32.x86_64_1.1.300.v20150602-1417

-product

org.eclipse.epp.package.jee.product

--launcher.defaultAction

openFile

--launcher.XXMaxPermSize

256M

-showsplash

org.eclipse.platform

--launcher.XXMaxPermSize

256m

--launcher.defaultAction

openFile

--launcher.appendVmargs

-nl

en

-vm

c:/PROGRA~1/Java/jdk1.8.0_74/bin/javaw.exe

-vmargs

-Dosgi.requiredJavaVersion=1.7

-Xms256m

-Xmx1024m

The trick is that "-nl en" in the end of this file (it has to be before -vm!!).

Former Member
0 Kudos

we also opened a oss-message just to inform SAP that there is a issue with the German-Version of the NWDS.

Answers (4)

Answers (4)

0 Kudos

The issue is a bug which occurs in non-english NWDS. Luckily the issue is already solved - see SAP Note 0002307240 (corrected up to 7.50 SP2).

Eclipse offers language packs for several languages, which can be downloaded separately. Please check http://www.eclipse.org/babel/downloads.php if you are interested in more details. You can install an eclipse language pack to get also the rest of NWDS (standard eclipse views, dialogs and menus) translated. You can install a language pack that way:

-Open the install wizard with 'Help' > 'Install new software...'

-Add the Babel p2 repository: http://download.eclipse.org/technology/babel/update-site/R0.13.1/mars -Select/install your language pack of choice

-Add to eclipse.ini an additional line -nl before -vm parameter

-Restart Eclipse and you should get a translated Eclipse

Keep in mind, that language pack probably doesn't contain the full translation (completion rate depends on the language).

vadimklimov
Active Contributor
0 Kudos

Hi Rene,

It is not a bug - it is a feature. By default, F4 search help suggests you only a list of interfaces that were explicitly assigned to a communication component (e.g. business system, business component). In Integration Directory, you could overcome this by manually entering interface name and namespace during creation of Integrated Configuration objects, but in NWDS, I haven't seen such an option any more. Thus, go to business component maintenance view and add corresponding interface (sender and/or receiver interfaces - in your case, it is a sender interface), and save it (you may even not activate it at this point of time). Then you shall be able to see them in F4 search help window when assigning an interface to a business component in iFlow maintenance view.

Regards,

Vadim

Former Member
0 Kudos

These are already added. For me it looks like the communication-component is correct and does have interfaces configured!

Former Member
0 Kudos

Here is a screenshot of the eclipse: the interfaces are added (correclty, as long I know) to that communication component:

former_member182412
Active Contributor
0 Kudos

Hi Rene,

Is your PO system also PO 7.5 SP2 PATCH 1?? because you are using NWDS 7.5 SP2 PATCH1, make sure you use the right version  of NWDS.

Regards,

Praveen.

bhavesh_kantilal
Active Contributor
0 Kudos

To add to what Praveen has pointed out on the NWDS version, also make sure you use Java 8 as your corresponding JDK.

Regards

Bhavesh

Former Member
0 Kudos

Hi Praveen, Bhavesh,

yes we do have the same version and also use Java 8-JDK

former_member186851
Active Contributor
0 Kudos

If the versions are fine,Objects are activated then it should appear.

Try re-configuring or try adding other interfaces and see if it works.

former_member186851
Active Contributor
0 Kudos

Hello Rene,

Did you activate the Business component which will be under the change list?

Former Member
0 Kudos

I did not found anything to activate therefore I startet the swing tool and found out that the Business-Component is activated and looks good for me:

Former Member
0 Kudos

Take a look at the screenshot for the Sender, also correct (as it looks in the Swing tools ) ????

former_member186851
Active Contributor
0 Kudos

You will find under change lists.

Former Member
0 Kudos

All objects are activated. We do not have any open change list.

apu_das2
Active Contributor
0 Kudos

It looks like your SI is not assigned under BS properly. Just check on that portion. I cant under stand the language of your screen shot so not able to dig much.

Thanks,
Apu