Showing results for 
Search instead for 
Did you mean: 


0 Kudos

Hello All

we are facing persistend connection-error in OAC0 when test-Connectiong a new-installed ContentServer.

It says:


               Message no. CMS166"

The ContentServer is installed with User „CS-Admin“, which is in group „Administrators“ on an English Windows 2008 R2, 64bit.

The installation went fine and finished with no errors.

After installation the driver is registered successfully with odbcreg as follows:

     "odbcreg.exe CSMaxDB -i -p "E:\sapdb\SDB\db\pgm" -d sdbodbcw.dll"

An idea is, that there still might be failours in right-administrations

For example CS-Admin had no rights for some partitions. Also some directories where excluded from permission inheritance (Berechtigungsvererbung) after first installation. Furthermore the user CS-Admin had no rights to execute the odbcreg-command.

Also the contentserver.ini was not editable for CS-Admin after installation,

But finally there was no error in installation-process (?!).

And all this is solved now by the Person, who has installed Windows on that machine.

I have reinstalled the ContentServer after this with CS-Admin, I have also deinstalled and again installed the contentserver, but the connection-error remains.

The Network-Connection seems to be fine. SAP-Ping (OS01) is ok. Also Telnet works fine.

Please do not doubt the IIS-Installation, this is ok.

Can somebody give advice, how we can find out, what breakes up the connection between SAP-Server and CS-Server?



Additional Informations:

Systemdata: Linux / SYBASE / NW731 SPS11

Kernel: 721 PL201

No entries in Syslog (SM21)

No entries in RFC-Trace (SM59) after activation of Trace for RFC-Destination „SAPHTTPA", also with rdisp/TRACE=2

No entries in „cs_trace.txt", only request by URL in Webbrowser generates entries in cs_trace.txt.

  1. ContentServer.ini: [ContentServer]












Report RSHTTP05 is OK

Report RSHTTP20 gives "Response Data 0"

Checked notes:

794919 - Fehleranalyse: ICM_HTTP_TIMEOUT und interner Fehler

164203 - Probleme mit SAPHTTP

761387 - Support-Informationen fuer den SAP Content Server

Accepted Solutions (1)

Accepted Solutions (1)

Hello everybody,

thanks for help, we found the error located in Firewall:

Even when telnet to port 1090 is stable, the connection can be cut by the firewall afterwards.

The firewall first checks, which kind of application wants to connect to the port. When this is clear, the firewall is cutting connection anyway, if the Port is not opened by definations. Maybe this is a new feature in Firewall-technologies...

Thanks so far.


Answers (6)

Answers (6)

Product and Topic Expert
Product and Topic Expert
0 Kudos


First check whether the repositories mentioned in this SAP note are present in the system.

308977 - Repositories BIE_QMM, BIE_NET, HME_CONTENT,ED,A2 and B2

If yes follow the SAP note.

Also try to maintain the Content Server hostname and the IP address in the hosts file of the server where ABAP is running.



Active Participant
0 Kudos

Hi Tobias

Can you please check this one is set ?, as per OSS note 977091 - CS 640 Driver



0 Kudos

Thanks for reply, guys.

Sorry, I did not mention.The CS-Installation is done with:

  • MaxDB 7.90 (CD: 51046952)
  • Content Server 6.50 (CD: 51048248)

Regarding UAC: it is disabled allready.

With Disabling my User "CS-Admin" was able to execute the mentioned odbcreg.exe command:

"odbcreg.exe CSMaxDB -i -p "E:\sapdb\SDB\db\pgm" -d sdbodbcw.dll"

Regarding EventViewer:

I have activated IIS-Log, but the only Message, I get there time to time is:

"A worker process with process id of '3840' serving application pool 'DefaultAppPool' was shutdown due to inactivity.  Application Pool timeout configuration was set to 20 minutes.  A new worker process will be started when needed."

Regarding #977091 - CS 640 Driver:

I was facing this error last time:

"The new Installtion of Content server 6.40 on windows misses default DB ODBC Driver registration 'liveCache'"

But we are working now with 6.50. also 'liveCache' is missing now!

Which drivers are in place, you can see with odbcreg.exe -g

As mentioned I have registered a new Driver CSMaxDB with odbcreg (please find above).

Therefore this runs fine with all other installations I have done so far.

Regarding #1971353

"Documents which are saved on SAP Content Server are not found"

Our Problem is a fresh-installed ContentServer with connectionerror. Without a solution there will never be a document stored on the ContentServer...

The server seems to be reachable, but the connection brakes immediatelly after been reached.

Maybe the SAP-Support needs to debug with the RFC-Tracefiles...I also tried this, even with upper Tracelevel, but I found nothing in there. Somebody want me to paist it here?

br tg

Active Participant
0 Kudos

Hi Tobias,

Not sure, odbc driver version used here is the latest ?, Could you please check ODBC Driver is latest as per this note  698915 - Importing an SAP MaxDB ODBC driver

Have you referred this note ? for trace and troubleshoot ? 1405031 - Generate ODBC trace on Windows



0 Kudos
Please find: SAP Message Number  0120050409 0000036823 2014
Active Contributor
0 Kudos

Hi Tobias

Is this any error in the windows event viewer ?

Have you disable the UAC on Windows 2008 server ?

Could check this SAP Note 1971353



0 Kudos

Regarding  1829887 - Error in HTTP Access: IF_HTTP_CLIENT->RECEIVE 1 HTTPIO_PLG_CANCELED Message no. CMS166

I tried. I have added the entry in SDOKPROF, but the Connectiontest say's then:

HTTP error:

Message no. CMS025


Error in accessing via HTTP

This might lead to

1293399 - 500 (Internal Server Error) in CSADMIN

but ODBC driver has been registered successfully

To me, this seems not to bring any solution, right?

Active Contributor
0 Kudos

Hi Tobias,

Was there anything in ICM logs ?



0 Kudos

Hi Divyanshu,

thanks for quick replay!
ICM logs show errors, but...

[Thr 140736815482624] Wed Aug 13 21:36:36 2014

[Thr 140736815482624] *** WARNING => Connection request from (5/6/0) to host:, service: 1090 failed (NIECONN_REFUSED)

[Thr 140736815482624]  {000902d5} [icxxconn_mt.c 2096]

[Thr 140736814425856] *** WARNING => Connection request from (5/6/0) to host: pwdf2625, service: 1090 failed (NIEHOST_UNKNOWN)

[Thr 140736814425856]  {000902d6} [icxxconn_mt.c 2096]

The given IP and hostname might come from other repositories:

I just found: SAP invalid content repository - Application Server Infrastructure - SCN Wiki

These messages comes all the time and might be produced by RZ20 (CCMS) by old default repositories. Furthermore the connection to the contentserver goes over RFC with connection SAPHTTPA, so far I know. Is the ICM involved in my problem anyway?

br tobias

Active Contributor
0 Kudos

Hi Tobias,

Not really, I was looking the reply which says ICM HTTP connection broken


That was the reason I asked you to even check ICM logs.



0 Kudos

Maybe check RFC connections or might have to do with the port assignment.

0 Kudos


works fine:

serverType="SAP HTTP Content Server";serverVendorId="Copyright SAP AG, All rights reserved 1998, 2001";serverPatch="0";serverStatus="running";serverStatusDescription="";serverDate="2014-08-13";serverTime="17:31:23";startUpDate="2014-08-13";startUpTime="17:31:22";lastAccessDate="2014-08-13";lastAccessTime="17:31:22";

And as Report RSHTTP05 gives no errors, there is everything OK with RFC's I think...

     SAPHTTP check

     Check RFC destination SAPHTTP...

     ... OK.

     Ping RFC destination SAPHTTP...

     ... OK.

     Check RFC destination SAPHTTPA...

     ... OK.

     Ping RFC destination SAPHTTPA...

     ... OK.