cancel
Showing results for 
Search instead for 
Did you mean: 

i18n Swedish characters display

bjorn-henrik_zink
Active Participant
0 Kudos

Hi,

when using special Swedish characters in my i18n.properties file they are displayed with crap characters, see screenshots below. Anybody who has a solution to this problem?

i18n

view:

Thanks!

Accepted Solutions (1)

Accepted Solutions (1)

bjorn-henrik_zink
Active Participant
0 Kudos

I found the answer here: i18n strange encoding | SCN. Seems to be related to how the properties file is saved and apparently the proper way is not default in Eclipse.

Answers (1)

Answers (1)

jamie_cawley
Advisor
Advisor
0 Kudos

What browser are you using and what control are you trying to show it in?  I did a successful test showing Ökat as a list title without any issues on chrome.

Regards.

Jamie

SAP - Technology RIG

bjorn-henrik_zink
Active Participant
0 Kudos

Hi Jamie,

thanks for your reply, I am using Chrome and the StandardListItem control, adding the text and title:

<StandardListItem

  title="{i18n>Increased}"

  type="Navigation"

jamie_cawley
Advisor
Advisor
0 Kudos

Does this work for you?

http://plnkr.co/edit/6MfLODb6FLZ8N5aSL4L1?p=preview

Regards.

Jamie

SAP - Technology RIG

bjorn-henrik_zink
Active Participant
0 Kudos

Hi Jamie,

I am using the manifest.json approach. I believe that is the recommended way to work with the resource bundles? Does that work for you?

bjorn-henrik_zink
Active Participant
0 Kudos

I have now even tried your version without the manifest.json and loading the the resource bundle in the controller and setting to the view - but it still does not work ... !

jamie_cawley
Advisor
Advisor
0 Kudos

So my example running on plunker does not work on your browser?  Did you try any other browsers?

Regards.

Jamie

SAP - Technology RIG

bjorn-henrik_zink
Active Participant
0 Kudos

Hi Jamie,

your example did work, as mentioned below, the problem was merely encoding of the .properties file.