Showing results for 
Search instead for 
Did you mean: 


Former Member
0 Kudos

Hi ,

Has anyone set up https on XI using there own company's CA to sign the certificates. We are having difficulty with the process.

We have followed all the steps in the help pages but when we check https it's showing the certificate to be signed by the server itself rather than our company's CA.

I have REQUESTED a cert from the XI box.

Sent it to CA.

The ca has sent me back a text cert which I tried to paste in to strustsso2. It errors saying:

Store the CA certificate in the database.

The ca sent us this cert which I import and add to acl screen (bottom screen).

I tried to paste text response again into strustsso2 but i get the same error.

If i try to export the cert to DB i don't seem to have the options.

Do u need to modify the table:vstrustcert.

Any help appreciated...



Accepted Solutions (1)

Accepted Solutions (1)

Active Contributor
0 Kudos

Sorry I can't help you that much, but my suggestion is to post this issue in EP forum also. EP guys have a lot of expertise on STRUSTSSO2 transaction as they use it a lot with EP to connect other sap systems...

Let me know.


Former Member
0 Kudos

Just in case any as same problem as me...i finally figured it out....

We deleted the distinguished name

Generated Cert request

Request request from CA.

Had to get back chain cert from CA.

Import cert we sent to CA and Response back into it looked like:

begin cert

end cert

begin cert

end cert

Restarted smicm and it worked.



Answers (0)