cancel
Showing results for 
Search instead for 
Did you mean: 

HTTP Status 404 - /AnalyticalReporting/WebiView.do

ralphkornack
Participant
0 Kudos
126

Hello Together.
I hope this is the right place.

We have the following configuration:

A VM from VMWare with Windows 2003 R2 64 bit Server
4GByte HS

Installed is a BO Edge 3.1 with SP2 and FP5 without any integration kit (neither SAP nor AD or LDAP integration). The repository reside local on a MySQL Server. The webserver is Tomcat 5.5 (A standard Edge installation on a singel  windows server)

Everything(!) works fine

Now I have installed SP3. The BO – Edge Version is „BuildVersion=12.3.0.202.BOE_EDGE31_SP3_REL“ and I’ve got the following error after starting WebI:

HTTP Status 404 - /AnalyticalReporting/WebiView.do

Then I tried to Install the SP 5 but the error still exists.

Now I have found the SAP hints (1379092, 1308046 and 1271575) to solve the problem.
Nothing helped to solve the problem. Neither a complete deployment from all war files with wdeploy nor the step by step deployment with the administrator console from tomcat.

The BO – Edge Version is „BuildVersion=12.3.0.202.BOE_EDGE31_SP3_REL“

I found another BO – Edge Server with the Version „BuildVersion=12.3.0.601.BOE_EDGE31_SP3_REL“. On this Server this mentioned error doesn’t exist.  I copied the webapps directory (only this) from the Version 12.3.0.601 to the server with the Version 12.3.0.202 and it seems that the HTTP error not occur. This workaround doesn’d work with the SP5. But this is not a solution.

Any suggestions

Greetings
Ralph

Accepted Solutions (0)

Answers (1)

Answers (1)

denis_konovalov
Active Contributor
0 Kudos

It looks like during upgrade from Sp2 Fp2.5 to SP3 the war files were not deployed/updated correctly.

The SP3 install log should offer some insight into what happen.

As to best way to get to a working SP5 install - download Full Install build of Xi3.1 SP5 edge from SMP and install that instead. (you'll need to remove existing install or do it on a new VM Instance)

p.s.

what wdeploy command did you use ?
which war files do you see in your java/applications directory ?

ralphkornack
Participant
0 Kudos

Hallo Denis

Thanks for your quick answer.

What I am looking for within the log-file. I think it is a bit easier to find the interesting lines within the logfile (275.365 KB with overall 780.000 lines) if I knew what I am looking for.

Example for used wdeploy – commands:

wdeploy tomcat55 deployall
wdeploy tomcat55 –DAPP= AnalyticalReporting deploy

The Files within the Direktory java\applications

D:\Programme (x86)\Business Objects\BusinessObjects Enterprise 12.0\java\applications

07.03.2012  09:15         7.066.371 AdminTools.war
07.03.2012  09:56       305.792.331 AnalyticalReporting.war
07.03.2012  09:15        38.871.448 BusinessProcessBI.war
07.03.2012  09:42        29.394.614 CmcApp.war
07.03.2012  09:43        31.665.736 CmcAppActions.war
07.03.2012  09:45        45.425.289 CrystalReports.war
07.03.2012  09:45        48.763.134 dswsbobje.war
07.03.2012  09:44        21.497.507 InfoViewApp.war
07.03.2012  09:44        19.548.337 InfoViewAppActions.war
07.03.2012  09:16        14.774.176 jsfplatform.war
07.03.2012  09:44        13.991.191 OpenDocument.war
07.03.2012  09:48        95.733.597 PerformanceManagement.war
07.03.2012  09:43        35.555.566 PlatformServices.war
07.03.2012  09:51        19.920.575 PMC_Help.war
14.06.2010  16:42        17.485.050 polestar.war
14.06.2010  16:30         8.625.811 PolestarAppActions.war
14.06.2010  16:41           385.901 polestar_help.war
14.06.2010  16:30        33.999.518 polestar_tutorial.war
07.03.2012  09:52        38.630.958 VoyagerClient.war
07.03.2012  09:16        13.806.828 Xcelsius.war
07.03.2012  09:49        11.576.141 XCTemplateUploader.war

The idea to reinstall a fresh R 3.1 Edge with SP5 isn’t a realy good idea, because the VM is used by sales and pre-sales organisation for „Demonstrations to the customer“ with a lot of content and special customisations. It will take a lot of time to repeat that customisations.

Greatings
Ralph 

denis_konovalov
Active Contributor
0 Kudos

In the log you look for the AnalyticalReporting or Webi* and see if they were updated or not and if there were any problems with it...

List of war's apear correct. Since you mentioned customizations - that could be why something got messed up.

What sort of customizations ?
Where and how exactly ?

ralphkornack
Participant
0 Kudos

OK, sorry for that delay.

I tried to find some hints within the installation log file BOE_SP_3_Install_0.log. I found nothing, that gives a hint for some problems during the installation.

The customisations are not concerning the configuration files from the web applications. I wrote in my opening post, that everythink worked fine with SP2 and FP5. Customisations are concerning reports with special layout and such thinks. We are including icons and we have a lot of open doc - connections and report cascades.
Another think is, that the content have evolved over time and migrate such a content is not realy easy.