cancel
Showing results for 
Search instead for 
Did you mean: 

HTML Collection renderer isse & uicommand search_from_here

Former Member
0 Kudos

Hi everyone,

I have followed the tutorial 'How to... configure the HTML collection renderer for the KM Flexible User Interface' for our EP60 SP16, KMC SP16 Patch 3 portal.

Help documentation :

<a href="http://help.sap.com/saphelp_nw04/helpdata/en/cc/00c93e9b2c3d67e10000000a114084/frameset.htm">HTML Collection Renderer Settings</a>

In my HTML page, I have the following coding :

						
<a href="http://com.sap.cm/.?uicommand=new_folder">create a folder</a>

<a href="http://com.sap.cm/.?uicommand=new_file">upload a document</a>

<a href="http://com.sap.cm/.?uicommand=details">browse the details</a> of this folder

<a href="http://com.sap.cm/.?uicommand=feedback">give feedback</a>

<a href="http://com.sap.cm/.?uicommand=subscribe">subscribe</a>

An HTMLCollectionRenderer is created with the HTML page included and added to a layout set. I have an iView using the layout set, everything is shown as supposed to.

Example :



Folder name : <b>Demo Documentation</b>

Description : <b>Upload here all you demo documentation</b>

Action : create folder
         upload a document
         browse the details of this folder
         give feedback
         subscribe to be informed about changes

This is fine, but when I navigate into subfolder 'Portal Related', following is shown :



Folder name : 

Description : 

...

<b>Folder name</b> and <b>description</b> are <u>blank</u>. We expected it would look like :



Folder name : <b>Portal Related</b>

Description : <b>All Portal Demo Related documents go here</b>

...

1) As you can see, when navigating into a subfolder, the UICommand's don't show the folder name, nor the description.

2) When looking into KM configuration (user interface -> commands), the list of UICommand's also show a command 'search_from_here'. Unfortunately, adding this to the above html page as below doesn't work.


<a href="http://com.sap.cm/.?uicommand=search_from_here">search from here</a>

Any suggestions?

Many thanks,

Kevin

Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos

Kevin,

In order to isolate this issue, this command appear if you have created an index to point this repository (index administration). Have you done it ?

Patricio.

Former Member
0 Kudos

Hi Patricio,

yes, an index was already created. Funny enough, I've re- inserted the line


<a href="http://com.sap.cm/.?uicommand=search_from_here">search from here</a>

... and now it works. Probably a typo ;o)

Do you have a clue about the first issue?

Thanks!

Kev

Former Member
0 Kudos

Have you tried with this ?

Use the line below to display the name of the current folder:

<a href="http://com.sap.cm/.?property=displayname"></a>

Use the line below to display the name of the superordinate folder:

<a href="http://com.sap.cm/..?property=displayname"></a>

Patricio.

Former Member
0 Kudos

Yes, same result.

However, I have found out that editing the folder, and resaving it's properties does the trick. Perhaps in a previous SP there was some bug?

Thanks for the help, that's another 10 points for you!

Answers (0)