cancel
Showing results for 
Search instead for 
Did you mean: 

how to trace page server

Former Member
0 Kudos
57

I am using Crystal Reports Server XI R2.

How do I trace/log the execution of the page and cache servers and any other components that are involved when I preview a report from CMC?

Thanks

Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos

Hi Lawrence

Add -trace to the end of the command line. This will produce logs in Logs directory inside you installation directory.

Regards

Alan

Former Member
0 Kudos

Alan:

I ran the following command from the command line

pageserver.exe -name AVLSQLDB.pageserver -ns AVLSQLDB -restart -trace -service

But the page server did not start. The log file is below. However I can start/stop it from CCM

Timestamp ProcessID ThreadID Message

[Fri Jan 30 15:01:32 2009] 3720 7572 (.\main_pageserver.cpp:66): trace message: Process is Crystal Reports Page Server parent

[Fri Jan 30 15:01:32 2009] 3720 7572 Log: level=3 cat=1 msg=35100 p=Crystal Reports Page Server started

[Fri Jan 30 15:01:32 2009] 3720 7572 trace message: Creating controller thread

[Fri Jan 30 15:01:32 2009] 3720 7572 trace message: Waiting on monitor to initialize

[Fri Jan 30 15:01:32 2009] 3720 7060 trace message: In service controller thread's run!

[Fri Jan 30 15:01:32 2009] 3720 7572 trace message: SIServerController::waitingToInitialize

[Fri Jan 30 15:01:32 2009] 3720 7060 trace message: SINTService::run enter

[Fri Jan 30 15:01:32 2009] 3720 7060 trace message: SIServerController::initialize

[Fri Jan 30 15:01:32 2009] 3720 7060 assert failure: (.\siservice.cpp:839). (false : StartServiceCtrlDispatcher: The operation completed successfully.

).

[Fri Jan 30 15:01:32 2009] 3720 7060 Log: level=0 cat=14 msg=35500 p=NT Service Initialization Problem

[Fri Jan 30 15:01:32 2009] 3720 7060 trace message: SINTService::run: Cannot start service control dispatcher

Former Member
0 Kudos

Hi Lawrence,

You need to go to the CMC, select Servers, and select your CrystalReportsPageServer. Stop the Server. Then choose properties. On this page you should be able to alter the CommandLine. Here you enter the -trace at the end of the command line. Save the changes and restart and it should log from then on.

Sorry for the confusion

Alan

Former Member
0 Kudos

Alan:

I am now able to trace the page server.

The problem I am trying to resolve is that certain reports show up blank in InfoView even though there is data to be displayed while the rest show up fine. It is as if no data is being fetched by the report from the database.

Could you please help me?

Regards

Lawrence

Former Member
0 Kudos

Hi Lawrence,

The most likely cause is permissions to the data. This is when the Crsyal Servers are logging on to the data as a user that does not have any access. What is you backend db?

You would be better off closing this issue and putting it in the CR Design forum as more people will look at it.

Regards

Alan

Answers (0)