cancel
Showing results for 
Search instead for 
Did you mean: 

How to remove a Scheduler Task completely

Former Member
0 Kudos

Hi guys,

maybe one of you can advise me how to remove a Scheduler Task completely from the EP 6.0.

<b>Background:</b>

According to this weblog () I created a Scheduler Task. So far everything worked just fine. But after a while I wanted to remove this Scheduler Task. I deleted all instances of my Scheduler Task under --> System Administration --> System Configuration --> Knowledge Management --> Content Management --> Global Services --> Scheduler Tasks --> My Scheduler Task, removed the PAR-file from the portal and restarted the portal. Afterwards I navigated again to --> System Administration --> System Configuration --> Knowledge Manangement --> Content Management --> Global Services --> Scheduler Task and my Scheduler Task was still displayed there, although without instance. I would like to remove that Scheduler Task completely, so it won't be displayed (in --> System Administration --> System Configuration --> Knowledge Management --> Content Management --> Global Services --> Scheduler Tasks) at all.

View Entire Topic
Former Member
0 Kudos

Hi Martin,

That is one thing i haven't been able to figure out. Even if you delete the par, for some reason the task still shows up in KM. We are going to open an OSS note with SAP to see if they have a fix for it.

Regards,

prakash

Former Member
0 Kudos

Hi Prakash,

thank you for your answer. Why does it not surprise me at all? Anyway, please let me know if you found out how to remove the task completely.

Cheers

Martin

Former Member
0 Kudos

Hi Prakash and Martin,

I would also be interested if you find a solution to this, I have a few old tasks I would like to delete completely.

BRgds,

Simon

detlev_beutner
Active Contributor
0 Kudos

Hi everybody,

1.) Delete every instance of the SchedulderTask via the configuration settings.

2.) Delete the metaconfig info:

a) On SP2: Delete the corresponding .configmeta file under \usr\sap\[id]\global\config\cm\config\local\meta\lib

b) On NW04 (and now... the soution...): Just remove the meta config xml file under src.config from the archive and redeploy (in fact, you'll deploy an "empty" config) ))

3.) Undeploy the corresponding PAR.

(Always in this sequence.)

Hope it helps

Detlev

Former Member
0 Kudos

Hello Detlev,

thank you very much for your instructions. It worked for me. Have fun with your reward points.

To clarify point 2b)

You have to remove the <YOUR_SCHEDULERTASK>.cc.xml file from the \src.config\install\meta\expanded\cm\services\schedulertasks of your par file.

Martin

detlev_beutner
Active Contributor
0 Kudos

Hi Martin,

> thank you very much for your instructions

You're welcome!

> Have fun with your reward points

Thanks, I'll buy a PSP2 from that, next year, maybe

> You have to remove the <YOUR_SCHEDULERTASK>.cc.xml

Quite right. If you have deployed an instance of your SchedulerTask in parallel (a .co.xml file under ...\data\...), of course this must be removed, too. Eventually, with this you could skip step1 on NW04, but this I haven't tested.

Hope it helps

Detlev

Former Member
0 Kudos

Hi Detlev,

I've been trying to make my own Scheduler Task, according to the Weblog of Prakash, but till now It does not work.

My problem is that, after deploy, I can't see the new Task in "Sys. Admin > Sys. Config > KM > Global Services > Scheduler Task "

Maybe I'm missing something, like modifying portalapp.xml or maybe there is a problem with the generation of the project (I start creating an empty Portal App Project)

Please, can you give me any idea?

Thanks in advance

Patricio

detlev_beutner
Active Contributor
0 Kudos

Hi Patricio,

only by accident I saw your posting, for subscriptions are killed after three months (or so). So I haven't been informed about the update by mail.

In the future, for new questions please open a new thread.

Check the default.trc for any stack traces or error messages.

Hope it helps

Detlev

Former Member
0 Kudos

Hi Martin,

I have the same problem I have deleted the xml files from my project and deployed the code, still I can see the scheduler task in the topic list.

Can you please let me know how you have fixed this issue

thanks,

Paul

Former Member
0 Kudos

The issue is now fixed after restart of J2EE Engine..

Paul