cancel
Showing results for 
Search instead for 
Did you mean: 

how to Pass parameters between two design studio applications

Former Member
0 Kudos

Hi

Can some one suggest how to pass parameters between two Design studio applications was trying to achieve the Hyperlinking Functionality in Design Studio like the way we do it for web i Reports.

Have Created a  Parent Dashboard from which i would like to pass the parameters to the child Dashboard based on the chosen parameters in the parent Dashboard


also  i want  to avoid Prompt Message when opening the Child Dashboard  rather want the prompt values to be passed based on the selections in the Parent Dashboard for which i  have set the force prompt on start up in the application Properties to False

have tried the below links with no success:

http://scn.sap.com/thread/3434414
  http://scn.sap.com/docs/DOC-41397

Accepted Solutions (1)

Accepted Solutions (1)

TammyPowlas
Active Contributor
0 Kudos

Hi Vamsee - did you see this and watch the video at the end?  

Would that help?

Former Member
0 Kudos

Thankyou Tammy For the Link

Answers (1)

Answers (1)

Former Member
0 Kudos

Hi Vamsee,

I tried the following code and it worked-----

On source dashboard:

var url ="http://oinlcmw142.int.in.nmc.ericsson.se:8080/BOE/OpenDocument/opendoc/openDocument.jsp?sIDType=CUID..."

+"&Xv_Country="+Xv_Country;

APPLICATION.openNewWindow(url);

where Xv_Country is global variable.

On target dashboard:

On variable Intilization: DS_1.setVariableValue("psEnter Country", Xv_Country);

where "Enter Country" is the prompt on DS_1

           and Xv_Country is again the global variable on target dashboard.

Regards,

Himanshu

Former Member
0 Kudos

Guys - I am obviously doing something wrong! I have built a very basic Analytic 1 which displays sales using a geo-map. When a user clicks on a country in the geo-map, it is "supposed" to open Analytic 2 which displays in a cross tab customer sales for that particular country. I am facing several issues:

1. When the second analytic opens, it prompts me for a user id and password which I feel is extremely redundant.

2. The Cross tab in Analytic 2 shows up as if no Data Source is attached to it, when in fact in design mode, I can see my BW Data Source assigned to it.

3. The Analytic 2 shows the following error messages:

    Could not instantiate the data source

    Could not instantiate the data source. See default trace for log ID "0d66a6ab-15c0-4f63-86ce-3604738e0691". Details: Cannot load query "cuid:FvegaVRvMgYA.j0AAAB3BDwCAFBWuTnl/Z_ZFICO_M01_Q002" (data provider "DS_1": No service implementation available)

    Cannot load query "cuid:FvegaVRvMgYA.j0AAAB3BDwCAFBWuTnl/Z_ZFICO_M01_Q002" (data provider "DS_1": No service implementation available)

    Cannot load query "cuid:FvegaVRvMgYA.j0AAAB3BDwCAFBWuTnl/Z_ZFICO_M01_Q002" (data provider "DS_1": No service implementation available)

I have followed all the steps listed in various videos. Appreciate any help!

TIA

Jagannathan Santhanam

0 Kudos

were you able to resolve the "  Could not instantiate the data source for Query DS_1" & " Service Unavailable" ?

0 Kudos

Hello Monika,

were you able, at the end, to solve the issue "Could not instantiate the data source for Query DS_1" ?

Thanks

Silvia