cancel
Showing results for 
Search instead for 
Did you mean: 

how to make fiori control version specific?

rohit_darwade
Explorer
0 Kudos

Hi,

My requirement is,

i used "numeric content" control in my application. which version is "1.34.7".

and my server version is "1.28.0".

so i'm not able to used this control on server.

i have to make it as version specific or dynamic version.

How can i achieve this?

thanks,

Rohit.

Accepted Solutions (0)

Answers (1)

Answers (1)

junwu
Active Contributor
0 Kudos

use what u have......

rohit_darwade
Explorer
0 Kudos

Purpose is that i have to show some measurements.

Former Member
0 Kudos

Hi Rohit,

In Manifest.json under dependencies you can specify if you have both the versions in  server.

example:

"dependencies": { //external dependencies
  
"minUI5Version": "1.34.0" , //minimum version of ui5 dist layer
  
"libs": { //used ui5 libraries
  
"sap.m": {
  
"minVersion": "1.34.0" //minimum version
  
},
  
"sap.ui.commons": {
  
"minVersion": "1.34.0" , //minimum version
  
"lazy": "true //values true/false (default: false)
  }
  }
  }

Have a look at below link for more info.

Descriptor for Applications, Components, and Libraries

Regards,

Viswa

junwu
Active Contributor
0 Kudos

that is information only...i don't think it will help.