cancel
Showing results for 
Search instead for 
Did you mean: 

How to include & in URL as /* WF task description

Former Member
0 Kudos

Hi experts,

Our SAP environment is ECC 5.0. I have a requirement to add an external URL into my workflow task description. I have added the below URL in the task description as a comment with /*

with proper < >

a href="mailto:test@lsi.com?subject=test&body=action:approve"

This works fine.

However, when I create a container element named url_link and assign initial value in the container as below:

mailto:test@lsi.com?subject=test&body=action:approve

And then within the task description as a comment with /*

a href="&url_link"> Approve </a>

This is what I get in the HTML source:

a href=" mailto:test@lsi.com?Subject=Test<(>&<)>Body=action:approve"> Approve </a>

I also tried to include escape character <)> in the container initial value

mailto:test@lsi.com?subject=test<(>&<)>body=action:approve

That didn't work either.

Any help would be greatly appreciated.

Thank you.

Jennifer Tran

Edited by: Jennifer Tran on Jan 5, 2008 12:04 AM

Edited by: Jennifer Tran on Jan 5, 2008 12:05 AM

Accepted Solutions (0)

Answers (2)

Answers (2)

Former Member
0 Kudos

This is how I managed to get this working:

url1=mailto:test@lsi.com?subject=test

url2=body=action:approve

/* &url1&

= &&url2&

Former Member
0 Kudos

Hi Jennifer, please clarify. Are you saying you were able to create a hyperlink in the workitem description? Does it work in Universal Worklist? SBWP?

Matt

bpawanchand
Active Contributor
0 Kudos
Are you saying you were able to create a hyperlink in the workitem description? Does it work in Universal Worklist? SBWP?

Try to use Anchor Tag of HTML in the description

Could you please let us know what exactly you mean by saying UWL

Former Member
0 Kudos

I created 2 containers (ZWCTESTURL1, ZWCTESTURL2) in my task and gave them initial values:

ZWCTESTURL1 = mailto:test$lsi.com?subject=test

(replace "$" with "@", this posting will not let me enter email address)

ZWCTESTURL2 = body=action:approve

I put the following line in my Task Description:

<a href="&ZWCTESTURL1&&&ZWCTESTURL2&">test</a>

When I go into Business Workplace (SBWP) and open my workitem, I see a hyperlink named "test". When clicked, it properly opened a new email in my lotus notes which put To, Subject, and Body text correctly. However, when I open same workitem in Universal worklist (UWL), there is no hyperlink, just straight text. It displays as:

<H href="mailto:test$lsi.com?subject=test&body=action:approve">test</a>

(replace "H" with "a")

As I suspected, I could not create hyperlinks in workitems that are in Universal Worklist. I looked at the editor options in task description and have not any luck with what I tried to make that text a hyperlink in UWL.

Matt

Former Member
0 Kudos

I also tried this

url_link = mailto:test@lsi.com?subject=test

url_link2 = body=action:approve

/* < a href="&url_link

= &

= &url_link2"

That didn't work either. It added an extra space in front and behind the &