Showing results for 
Search instead for 
Did you mean: 

How to fill a grid at initial start using Web Dynpro

Former Member
0 Kudos

Hello readers(s)

I am having some difficulty using WEB Dynpro.

Last week I installed the Sneak Preview CD and i am trying to learn all about WebDynpro and the J2EE environment.

Until now i succeeded to get a grid filled with data from another SAP System. To get the data i use a RFC function call after pushing a refresh button.

Until now the grid at first start is empty. What i want now is to fill the grid at start without having to use the refresh button.

Where should i put this logic. ?

Bertil Rebergen

Accepted Solutions (0)

Answers (2)

Answers (2)

Former Member
0 Kudos

I solved the problem.

The error was caused by me because i used a methode of a messenger object which was not already created.

Former Member
0 Kudos

Hi Bertil,

Could you please describe how you obtained data from R/3 system using RFC call. I tried to use a RFC with model class it didn't work.



Former Member
0 Kudos

Hello Suresh,

I followed the same steps as in the example presented by the tutorial. The RFC module i use delivers a table filled with data. At first it also did not work. I did not receive data at all. By changing the RFC module i found out that the module was not called at all!. Change the source (e.g post a message in your RFC module) to be sure that it is called.

After this i looked more deeper into the example and i added inside the DoInit of the controle a binding of the context elements i used for the RFC. After this it worked.

At this moment am at the TechEd in Basel and therefor not able to look into my sources so i can not give you more details now.

Hope this hint will help you solve the problem



Former Member
0 Kudos

Hello Bertil,

In the view that contains your grid there should be a method called wdDoInit().

This is called the first time of the load of the view (Initialize the controller).

You could put the load of your grid there.

This mehod however will not be called again.

Hope it helps