cancel
Showing results for 
Search instead for 
Did you mean: 

How to change the ROLE: Integration server in business system in SLD

rehancontractor
Explorer
0 Kudos
82

Hi,

I am facing error in communication, becuase the integration server has been attached to in correct business system with incorrect client (001 instead of 700).

In SLD, business system, 'integration' tab there is button "Associate with XI'.

I have selected the role as integration server for the corrrect business system and aslo gave the correct pipeline url for integration server.

When I press the button "Associate with XI" and Save nothing happened.

How do i change my integration server.

Please help.

Regards,

Rehan

View Entire Topic
Former Member
0 Kudos

Hi Rehan

I think you need to change the Technical system and select as integration server not business system. Change the TS of this BS so that it will represent Integration engine

Thanks

Gaurav

rehancontractor
Explorer
0 Kudos

Hi Gaurav,

I have checked the teachnical system and its of type WEB AS ABAP. and when i click on the business systems tab, there are two business systems. When i double click on the business systems

I realised that both the business systems has been defined with role: integration server.

IN one business system i can see that there is "associate with XI" button.

But when i want to chnage the business system with correct client 700 , i tried pressing the button after entering the correct pileline url.... nothing happens.....

Can you please let me know the procedure to chnage the technical system with respect to integration engine???

PLease help as our project is held up due to this.

regards,

Rehan

VijayKonam
Active Contributor
0 Kudos

Delete your business systems and created them again on by selecting the technical system - 700 as integration server and 001 as application system.

VJ

rehancontractor
Explorer
0 Kudos

Hi Vijaya,

In business system which i want to change it as main integration engine, i can see 2 buttons "associate with Xi' and 'save' (in integration tab of business system).

when i press on "associate with xi" button should take it as integration server, but its not happening. Is there any process step i am missing in gui??

Regards,

Rehan

VijayKonam
Active Contributor
0 Kudos

I dont see this associate with XI button in my sys. I am on PI 70 does not have access to 71 system as of now.. Not able to figureout your situatuon..!!

VJ

rehancontractor
Explorer
0 Kudos

HI VJ,

If you define two busines system both in on same technical system and also both with role integration servre the only you cna see this button in Business system in tab: Integration.

Regards,

Rehan

VijayKonam
Active Contributor
0 Kudos

You must use only one business sytem as integration server. Useally the 001 client is not used for that. make that one as application system. You shuld be good to go.

VJ

rehancontractor
Explorer
0 Kudos

Hi VJ,

Problem is our bais team defined two business system on same ABAP wes as teachnical system and gave the role of integration to client 001 instaed of correct 700.

I can see the both the business system one with integration server withsave button and

the other business system with associate with Xi and asve button (cleint 700)

I want to make BS (with client 700) as real integration engine

Regards,

rehan

VijayKonam
Active Contributor
0 Kudos

Just make your 001 sys as application system. THings wll get solved automatically.

VJ

Former Member
0 Kudos

Hi

In that case you need to delete both the system and recreate using one client. If you want to choose 700 then create it again with 700

Thanks

Gaurav

rehancontractor
Explorer
0 Kudos

Thanks Gaurav and VJ,

followed your steps and problem was resolved.

Regards,

Rehan