cancel
Showing results for 
Search instead for 
Did you mean: 

how to change node id in WebAS 6.4

Former Member
0 Kudos

does anybody know how to change j2ee node id (for dispatcher and server, on central instance and app instance) in webas 6.4 sp10?

Thanks

Jane Zhou

Accepted Solutions (0)

Answers (1)

Answers (1)

viliana
Advisor
Advisor
0 Kudos

Hi Jane,

Changing the node ID is not recommended because this will lead to communication problems within the cluster. Are you really sure that you want to change the node ID?

Otherwise, you can modify the name of the cluster nodes by using the Cluster Manager.

Start the Visual Administrator tool and connect it to the J2EE Engine, choose Server/Dispatcher -> Kernel -> Cluster Manager -> Properties tab. Choose the corresponding element.name property and modify its value.

You will see in this tab that you can also modify the node ID values but as I said this is not recommended at all.

Best regards,

Viliana

Former Member
0 Kudos

Hi Viliana,

Thanks for the reply, it's very helpful. I need to do this because I'm trying to do system copy with database backup and restore. the copy works fine, the only problem is that I can't apply patches on the copied system because SAP's patch application generates node id based on host name, which is different from what's in the copied database (it has the node id generated based on source system host name). so if I can change the node id on the target system to match the target host, the patch will probably finish

Do you have more information on what kind of communication problem I may have if I change node id? if I change all node id in the whole j2ee cluster, do you think I will still have the problem?

Thank you very much for your help

Jane

viliana
Advisor
Advisor
0 Kudos

Hi Jane,

Check if SAP Note 812910 can help you solve your problem.

You need to know the old host and SID. Also check for errors in the bootstrap. Did you use SAPInst to do the system copy?

Best regards,

Viliana

Former Member
0 Kudos

Hi Viliana,

Thanks for the reply. I will look at the note you mentioned.

I did not use sapinst to do the system copy. we will look at it once we go live. Do you have any experience with it that you can share? is it easy to use? does it take long time to do? do you think it's practical to use the tool?

Thanks

Jane