cancel
Showing results for 
Search instead for 
Did you mean: 

How do I upload a network hierarhcy into SAP BW?

Former Member
0 Kudos
85

I am trying to import a large network hierarchy with "link nodes" into SAP BW.

I'm new to SAP, and BW 7.0 is all I know. However, apparently, you can't use the new 7.0 concepts and methods to import hierarchies. You must use older 3.5 methods, including a 3.5 InfoSource.

I found some instructions at http://help.sap.com/saphelp_nw70/helpdata/en/fa/e92637c2cbf357e10000009b38f936/frameset.htm

Which documents how do import hierarchies using 3.5 mechanisms in version 7.0.

Unfortunately, I am unable to follow these steps. I create the 3.5 InfoSource, and the docs say:

"Choose InfoSource Tree ® Your Application Component ® Your InfoSource ® Assign Source System."

However, I see no option to "Assign Source System" anywhere. Also, when I create the 3.5 InfoSource, I see the target InfoObject show up in the InfoSources tree, but I don't see a InfoSource object show up in the InfoSources tree. I'm not sure what to do.

Message was edited by: Giesen

Completely revised post.

Accepted Solutions (1)

Accepted Solutions (1)

krzysztof_konitz4
Contributor
0 Kudos

Hi,

Instead of "Assign Source System" choose "Additional Functions" -> "Create Transder Rules"...

regards

Krzys

Former Member
0 Kudos

Actually, I tried that. (Thanks very much for reply)

I tried right-clicking the root InfoObject (in InfoSource tree view) and selecting "Additional Functions" -> "Generate Export DataSource"

I get a dialog that says "The generation of DataSource was successful" (If I switch to the DataSources view, I don't see this new DataSource. Do I need to locate this?)

Then I right-click the hierarchy object in the InfoSources tree view and select "Additional Functions" -> "Create Transfer Rules".

I get a dialog to choose my source system. I do so, and I get the error, "No available DataSources for source system XYZ exist".

I'm not sure what I'm missing here. I haven't had the opportunity to create my DataSource.

Please help!

krzysztof_konitz4
Contributor
0 Kudos

The steps to create InfoSource and DataSource in order to load hierarchies are as follows:

1. Go to InfoSources tree, choose apropriate application component and the from context menu: Additional functions->Create Infosource 3.x

2. On the dialog screen choose Direct Update of Master Data and choose your InfoObject (which is created with hierarchies).

3. Newly created InfoSource will be visible under chosen application component. In the InfoSource tree under InfoSource you should see icon with hierarchy. Set cursor on this icon and press context menu. From context menu choose Additional functions->Create Transfer Rules.

4. On the dialog screen choose apropriate source system.

5. Confirm dialog with question regarding assigning DataSource to InfoSource for hierarchy.

6. Activate transfer structure.

7. Finally you can create InfoPackage for DataSource in order to load data...

Krzys

Former Member
0 Kudos

I make it up to step #4 as you have listed. When I choose my source system, I get the error message, "No available DataSources for source system <my source system> exist".

I have DataSources defined. I'm not sure what the problem is or what I'm supposed to do.

Thank you very much by the way. I am so close to having this project working...

krzysztof_konitz4
Contributor
0 Kudos

Are you sure that in step 1 you chose <b>InfoSource 3.x</b> ?

And I assume that your source system is flat file system...

Krzys

Former Member
0 Kudos

Krzys,

Thank you so much. I was trying to use a DB Connect Source System. I created a new flat file Source System and with that, I make it past step 4.

On step 5, I get asked about three different data sources. I choose "no" to the attributes and text data sources (those are import through BW 7.0 mechanisms) and "yes" to the hierarchy data source.

On Step 6, I am on the InfoSource change screen and I try to activate. I don't know what all the settings on the InfoSource mean. When I click activate, I get this error:

"InfoObj. 0GN_IOBJNM from fld IOBJNM of dataSource CSTOB_CBO_HIER is not active but BCT ex. -> Dtl Message no. RSAOLTP236"

I attempt to follow this help text and do: "RSA1" -> "Goto" -> "BI Content"

From there I see a panel, "InfoProviders by InfoAreas". There is a large tree underneath. I do a "find" for 0GN_OBJNM but nothing comes back. I don't know how to proceed.

I also do a Google for 0GN_OBJNM. I found the Best Practices Article BS1 which mentions activating the 0GN_OBJNM object. I try to follow step 3.3.2, however at step 2.c, I get a running stopwatch cursor that lasts for several hours. I assume it's hung. CPU+Disc on SAP server are idle.

Swapna,

I tried to follow the PDF file that you linked. However, I can't do transaction SE38 since I can't get a developer code. The following steps seem similar to Krzys's suggestion where I'm getting the issues above.

krzysztof_konitz4
Contributor
0 Kudos

Hi,

It looks that characteristic 0GN_IOBJNM is required in order to activate transfer structure.

Because this is standard InfoObject you should go to Business Content and activate it. For activation choose option "only required objects" and then after collecting objects make sure that only required objects are selected on the list.

But be careful if you are not familiar with business content because you can overwrite unintentionally changes for other standard InfoObjects made by other consultants...

Krzys

Former Member
0 Kudos

Thank you again for the reply Krys.

How do I "go to Business Content and activate it"? Sorry, I am still new to SAP overall.

I'm also trying to follow BS1, which seems to explain how to do this. Here are the steps that I take:

RSORBCT

Menu "Edit" -> "Source System Assignment"

Select only BI System

Right hand frame

Grouping: "In Data Flow Before"

Collection Mode: "Collect Automatically"

Left Hand Frame

Select Object Types

Middle frame

Expand InfoObject Catalog

Double click "Select Objects"

Select the following (using ctrl-click)

OFIAA_CHA01,OFIAP_CHA01,OFIAR_CHA01,OFIGL_CHA01,OFIAA_KYA01,OFIAP_KYA01,OFIAR_KYA01,OFIGL_KYA01

Click "Transfer Selection"

System runs for a while before failing with "Maximum runtime exceeded". I'm not sure what to do.

krzysztof_konitz4
Contributor
0 Kudos

Hi,

In order to activate characteristic:

1. In RSA1 go to Business Content.

2. On the right pane toolbar choose "Grouping" - "only necessary objects". Choose "Collection mode" "Collect Automatically"

3. Under business content button choose "InfoObjects by application group".

4. Find InfoObject 0GN_IOBJNM in the three in the left pane (using search icon).

5. Drag InfoObject 0GN_IOBJNM from left to right pane. After a while all required objects for activation of InfoObject 0GN_IOBJNM will be visible. Make sure that only really needed objects are chosen.

6. On the right pane toolbar choose "Install" "Install in background". <b>Before you do that please ask someone experienced in business content activation to check your selections because you can overwrite some changes made in standard objects !</b>

regards

Krzys

Former Member
0 Kudos

delete

Former Member
0 Kudos

Krzys,

Thank you. With your help the 0GN_IOBJNM error is resolved. I've completed the seven steps from your earlier post.

I've created the InfoPackage, assigned my flat file with hierarchy data, I had to create a new "hierarchy header", and I've run the InfoPackage.

However, I didn't see any place to specify field mappings from my hierarchy flat file. Also, where is the imported hierarchy data? I can't see it anywhere. When I swtich to the InfoObject view, I still only see the one dummy hierarchy that I created manually.

Where can I see the hierarchy data? How do I know it got imported correctly? Ultimately, I need to see the correct hierarchy on SAP BEx reports.

Sorry to ask so many questions, but I'm really stuck on this issue, I don't know how to troubleshoot, and I'm still new to SAP. Thanks!

Answers (1)

Answers (1)

Former Member
0 Kudos

Hi ,

in case if you are loading the hieracrchy from a flatfile

have you created the datasource ?

follow this doc

https://www.sdn.sap.com/irj/sdn/go/portal/prtroot/docs/library/uuid/0403a990-0201-0010-38b3-e1fc4428...

Cheers,

Swapna.G