cancel
Showing results for 
Search instead for 
Did you mean: 

History - Actions Reschedule Problem

Former Member
0 Kudos

Hello Everybody ,

My problem is that , I want to make changes on report , schedule settings format and destinations For example I want to remove or add person mail.

Firstly , I choose the report I want to make changes , Right click , History , Reschedule , Changing settings.There is no problem this far. But  endly I select schedule , The report is starting .I don't want to starting report automatically . After making changes to report automatically sends mail to people.How can I solve this problem ? Please help me.

Accepted Solutions (1)

Accepted Solutions (1)

graham_sturmy
Active Participant
0 Kudos

Adding it again so this response is not squashed into a tiny column!

Hi,

  You are on FixPack 3.7 so that particular fix should be in place.  I've just tested the same workflow on my FixPack 3.6 system and I still get the same behaviour, even when selecting replacing the original schedule.

  Here is the explanation of what is happening.  You must ensure that FIRST occurrance time/date of the schedule is the next time you actually want it to run.  If this is in the past it could trigger a schedule straight away.

  There are two different types of reoccurring schedule:

    First are ones which are relative to the first time they run (e.g. Hourly, Daily, and Monthly) - you specify a time of day that they should run and then all later schedule times are calculated relatively from that time.

    The second type or relative to a time of month/certain days of the week.  i.e. (Weekly - where you choose WHICH days of the week, Nth Day of Month, 1st Monday of Month, Last Day of Month X Day of Nth Week of the Month and Calendar).  For each of these types, the first occurrance will depend on the next time the '1st Monday' is etc.  If I reschedule this type, and its not the 1st Monday of the Month, then it wont run immediately - it will wait till the criteria are met.

  For this problem I believe you are only having it with the first type (Hourly, Daily or Monthly).  For these types of reoccurring schedules the Start Date/Time is very important as this specifies the first time it will run.  If this date/time is now or in the past it will run immediately and then the next reoccurrance will be at the specified interval after the current time (since it only just ran).

  So - what do you do to avoid this - its simple.  Set the Start Date/Time to be the NEXT time you wish it to occur.  As you are editing an existing schedule, this will be a date in the past so it thinks it needs to run immediately as it doesn't take into account what the next run time was going to be for your previous schedule.  In practise you probably just need to change the Date appropriately because the time is probably the correct time already.

  Hope thats clear.

Regards,

Graham

graham_sturmy
Active Participant
0 Kudos

As an aside, it might be nice, when you click on 'reschedule' for the 'start time' to be changed to the next run time rather than retain the original time - I think it's arguable which is correct.  You could create this request in the Ideas Place for this.

Regards,

Graham

Answers (1)

Answers (1)

former_member188911
Active Contributor
0 Kudos

I think you should check first the Recurrence panel, probably it is set to run now... 

Former Member
0 Kudos

Where is Recurrence Panel ?  Infoview or Central Management Console ? 

Former Member
0 Kudos

Hi ,

Ok I found Recurrence Panel but ,it does not set to run now .Even I replace existing schedule.My repports are generally Daily , Weekly .. etc

former_member188911
Active Contributor
0 Kudos

Hi 

this is strange, there must be another scheduled job go to CMC / Instance Manager and see what are the recurring jobs, maybe there is one that is running that you don't know...

Former Member
0 Kudos

Hi,

  • Login into CMC
  • go to instace manager
  • find your scheduked job
  • right click and click on reschedule
  • first click on replace and select replace existing schedule
  • click on recurrence and select the run object as per your requirement like daily/weekly/monthly
  • then do the changes as per your requirement
  • click on schedule

THanks,

Raj

Former Member
0 Kudos

Hi

I tried to your Suggestions but I am having the same problem over and over again.When I do the changes , The report is working automatically.I want to work when the time comes

Former Member
0 Kudos

Try recreating the schedule from scratch, as you want it to run. Then see if that does the same thing, or if it runs as it should. Simone is right. This doesn't make sense if it is truly scheduled for daily/weekly.

Thanks

graham_sturmy
Active Participant
0 Kudos

Hi,

  Unfortunately you don't state what your Business Objects version and patch level is.

  It sounds like this might be addressed by the following KBA:

1519894 - Rescheduling workflow changes / rescheduling looses original schedule

  If this is the same issue, it occurs in XI 3.1 SP3-> XI 3.1 FP3.5 and SP4.  It is fixed in FP3.6 and FixPack 4.1 (or above)

Regards,

Graham

Former Member
0 Kudos

Thanks 

graham_sturmy
Active Participant
0 Kudos

You need to be clear about exactly which FP you are on.  If you are already on FP3.6 or FP3.7 then you should already have the related fix and this is unlikely to be the cause.  If you or on FP3.5 or below (down to plan SP3 with no FP on) then this could be your issue.

If this is windows you can check either the Software Inventory Tool or the standard Add/Remove programs to be sure which FixPack (FP) you are on.  In Unix/Linux you can use ./AddorRemoveProducts.sh in the BusinessObjects install location.  These will show you a list of all FixPacks, etc that you have installed so you just take note of the largest one.

NOTE: FP3.7 will include ALL the fixes in FixPacks FP3.1, 3.2, 3.3, 3.4, 3.5 and 3.6 so if you have FP3.7 installed then it will include all the fixes in the lesser FP3.X fix packs.

Regards,

Graham

Former Member
0 Kudos

Hi

I attached a fixpack photo .Can you check it please which fix package we use ? I installed fixpack 3.7 last.