cancel
Showing results for 
Search instead for 
Did you mean: 

Help with new install... cannot load database file...

Former Member
0 Kudos

I have installed the latest trial (dev license) of Sybase ASE 15 on a windows 2008r2 VM to test.  The install completed successfully and I brought the DB up... and created a database and new devices.  I am attempting to load a dump file from version 12.5

When I run this command:

load database NEWDBCREATED from "compress::S:\12_5_DRUMP.dmp"

I get this:

The sp_db shows:

Msg 7205, Level 17, State 2:

Server 'SYBASEDB', Line 1:

Can't open a connection to site 'SYB_BACKUP'. See the error log file in the ASE boot directory.

Msg 7205, Level 18, State 3:

Server 'SYBASEDB', Line 1:

Can't open a connection to site 'SYB_BACKUP'. See the error log file in the ASE boot directory.

Msg 3220, Level 16, State 8:

Server 'SYBASEDB', Line 1:

Could not establish communication with Backup Server 'SYB_BACKUP'.  Please make sure that there is an entry in Sysservers for

this server, and that the correct server is running.

1>

1> sp_helpserver SYB_BACKUP

2> GO

name       network_name    security_mechanism   server_principal   class

         status                                                                    id cost

---------- --------------- -------------------- ------------------ ------------

         ------------------------------------------------------------------------- -- ----

SYB_BACKUP SYBASEDB_BS NULL                 NULL               ASEnterprise

         timeouts, no net password encryption, writable , enable login redirection  1 NULL

(return status = 0)

1>

I DO NOT see the service in windows for the backup server, did I miss something on install?

ANY idea where to go from here?

Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos

Hi Ken,

I hope you have installed only ASE not the backup server.

Check if you have a local backup server running using showserver command from command line. If the output shows a entry for backup server then you have to add an entry into sysservers system table with sp_addserver system stored procedure.

If you have not installed a backup server then install it and proceed further.

I hope this helps clear your doubt.

Let me know if you still get any other issue.

ADNAN

Former Member
0 Kudos

I must be missing something..

I am in windows 2008r2 I do not see a showserver command anywhere...

But if I look at the services I do not see the backup server listed.. I see the main server and an _xp server (which will not start)

When I run the install again.. i do NOT see the option to install a backup server when I choose custome install.

I found a server config utility..

And tried to create a backup server..

I net No Network Connection..

When I try to add network addresses and choose TCP/IP it seems like it wants "connection info" filled out?   I can not click OK ... it does not close dialog?  and the HELP button does not work..

How do you suggest I install the backup service properly?

Thank you..

ryan_hansen
Contributor
0 Kudos

Hi Ken,

Try this:

Add an entry in your sql.ini:
Example:

[RH2008VM_BS]

master=NLWNSCK,rh2008-vm,5002

query=NLWNSCK,rh2008-vm,5002

Now go back to the server config:
select "network address..."

select "add"
default name- RH2008VM_BS

pick options-

Protocol - SPX NT NWLINK SPX/IPX Net-Library Driver

Connection info - RH2008VM_BS

Now select
"select Related Adaptive Server"

Adaptive Server name - ASE name you have started

sa login - sa

sa password - your sa password

Now continue and run.


Hopefully this works.
(not sure if my syconfig is an old version or not)

Former Member
0 Kudos

Baby steps.

Thank you for letting me know what has to go into the connection info.. that was the missing piece. (no help file is tough)

The service now exists.. but still does not start...

Apr 04 11:56:51 2014: Backup Server: 1.78.1.1: The interfaces file used by the backup server is 'C:\Sybase\ini\sql.ini'.

Apr 04 11:56:51 2014: Backup Server: 1.79.1.1: The backup server name is 'SYBASEDB_BS'.

Apr 04 11:56:51 2014: Backup Server: 1.70.1.1: Configuring the maximum shared memory usage to 48 MB.

Apr 04 11:56:51 2014: Backup Server: 1.69.1.2: Configuring the number of service threads to 48.

Apr 04 11:56:51 2014: Backup Server: 1.70.1.3: Configuring the maximum shared memory per stripe to 1048576 bytes.

Apr 04 11:56:51 2014: Open Server Error: 16240.10.0: Net-Library routine sybnet_listen() failed in srv__start_net

Network error: status = 23 - Net-Lib protocol driver call to register a listener failed

.

Apr 04 11:56:51 2014: Open Server Server Fatal Error: 16029.20.0: Failed to start any network listeners

.

Apr 04 11:56:51 2014: Backup Server: 1.29.2.1: Unable to start the Backup Server.  See Backup Server error log for additional information.

the sql.ini looks like this..

[SYBASEDB_XP]

master=NLWNSCK,SYBASE-DB,5004

query=NLWNSCK,SYBASE-DB,5004

[SYBASEDB]

master=NLWNSCK,SYBASE-DB,5000

query=NLWNSCK,SYBASE-DB,5000

[SYBASEDB_BS]

master=NLWNSCK,SYBASE-DB,5001

query=NLWNSCK,SYBASE-DB,5001

ryan_hansen
Contributor
0 Kudos

Ken,


What does the backup server log say?

%SYBASE%\ASE-15_0\install (Default)

Sounds as if the port is already in use.
Does it start if you change the port number in sql.ini?

Also see this:
After change BS entry in SQL.INI from hostname and NLWNSCK protocol to IP address and TCP protocol the issue was solved.

[RH2008VM_BS]

master=TCP,10.168.26.49,5001

query=TCP,10.168.26.49,5001

Regards,
Ryan

Former Member
0 Kudos

I was able to get the backup service installed and started!  PROGRESS!

I am now able to login to isql and get a sp_who to run from the backup server..

When I run the load database....command

I get..

1> load database SYBASEDB from "compress::S:\THEDUMFILE.dmp"

2> go

Backup Server session id is: 12. Use this value when executing the 'sp_volchanged' system stored procedure after fulfilling any

volume change request from the Backup Server.

Backup Server: 4.132.1.1: Attempting to open byte stream device: 'compress::S:\THEDUMPFILE.dmp::000'

Backup Server: 4.124.2.1: Archive API error for device='compress::S:\THEDUMPFILE.dmp::000': Vendor application name=Compress API,

Library version=1, API routine=syb_open(), Message=syb_open: open() error=2, msg=No such file or directory

Msg 8009, Level 16, State 1:

Server 'XXXXXX', Line 1:

Error encountered by Backup Server.  Please refer to Backup Server messages for details.

1>

QUESTIONS:

1     .Does the file HAVE to be on a local drive?  S:\ is a NAS device

2.     The dump is from a 12.5 version.. will I be able to load it here in the latest ASE 15?

Thanks for all your help.. so close..

-Ken

Former Member
0 Kudos

moved the dump file local..

got this,,

Backup Server session id is: 15. Use this value when executing the 'sp_volchanged' system stored procedure after fulfilling any

volume change request from the Backup Server.

Backup Server: 4.132.1.1: Attempting to open byte stream device: 'compress::E:\THEDUMPFILE.dmp::000'

Backup Server: 6.28.1.1: Dumpfile name 'DCHPRG4140790D1F4' section number 1 mounted on byte stream

'compress::E:\THEDUMPFILE.dmp::000'

Backup Server: 6.35.2.2: Volume validation error: bad magic number EOF1, expected USTH.

Msg 8009, Level 16, State 1:

Server 'SYBASESERVER', Line 1:

Error encountered by Backup Server.  Please refer to Backup Server messages for details.

1>

BAD magic...

-Ken

Former Member
0 Kudos

Looks like your original dump may come from a different platform than Windows.

ryan_hansen
Contributor
0 Kudos

Ken,

Getting further away from my area, but here is from our internal search:

The 'bad magic number' is usually raised when you attemp to load a backup with and older version of the backupserver than then backserver that made the backup

Loading database from higher version to lower version is possible but we can't use higher version features in this way.

ryan_hansen
Contributor
0 Kudos

Oops. Here was the rest:


Also found this-

omitting the "compresion::" part of the syntax resolved the issuehttp://infocenter.sybase.com/help/index.jsp?topic=/com.sybase.infocenter.dc36272.1550/html/commands/...

and

use the "with compression =" method instead of "compress::"

Does the backup server log give any further information?

As I said not too sure about this error, just items I've found in our internal search.

Regards,

Ryan

Former Member
0 Kudos

I tried to remove the compress::: and got this

1> load database SYBASE-DB from "E:\DUMPFILE.dmp"

2> go

Backup Server session id is: 18. Use this value when executing the 'sp_volchanged' system stored procedure after fulfilling any

volume change request from the Backup Server.

Backup Server: 6.28.1.1: Dumpfile name 'DCHPRG4140790D1F4' section number 1 mounted on disk file 'E:\DUMPFILE.dmp'

Msg 3120, Level 16, State 1:

Server 'SYABSEDB', Line 1:

The database you are attempting to LOAD was DUMPed under a different sort order ID (44) or character set ID (2) than the ones

running on this server (SortOrd = 50, CharSet = 2). If the sort orders differ, at least one of them is non-binary.

The dump came from an older windows version Sybase (12.5)

The new database exists JUST to load this dump.. so I can kill/rebuild etc..

Looks like the SortOrd of the new database is different.. so I ran,,,

1>  sp_configure "default sortorder id", 44

2> go

Msg 5824, Level 16, State 4:

Server 'AIGORACLE11G', Procedure 'sp_configure', Line 1310:

Cannot reconfigure server to use sort order ID 44, because the row for its underlying character set (ID 2) does not exist in

syscharsets.

(return status = 1)

1> select name, id from master..syscharsets where csid=0

2> go

name                           id

------------------------------ ---

ascii_8                          0

iso_1                            1

cp850                            2

1> select name, id, csid, description

2> from master..syscharsets

3> where csid = 2

4> go

name                           id  csid

         description

It will not let me change the sort order?

------------------------------ --- ----

         ---------------------------------------------------------------------

------------------------------------------------------------------------------

--------

bin_cp850                       50    2

         Binary ordering, for use with Code Page 850 (cp850).

Former Member
0 Kudos

Hi Ken,

it is more and sp_configure to change sortorder you also need to load the sortorder in to the ASE,

syconfig will do this for you check use the configuration option and then you ASE server name.

Niclas

Former Member
0 Kudos

Hi Ken,

I would recommend to execute:

  load database SYBASE-DB from "E:\DUMPFILE.dmp" with headeronly

as this will report pagesize, charset and sort_order of the database/dataserver that was dumped.

Your target server needs to match all three for the load to succeed.

Good luck,

- jon

ryan_hansen
Contributor
0 Kudos

Hi Ken,

Here is the command to load the sort order just in case:
cd $SYBASE/charsets/cp850

grep ID *

noaccents.srt:id = 0x2C                 ; Unique ID # (44) for the sort order


$SYBASE/$SYBASE_ASE/bin/charset -P<sa_password> -S<server_name> noaccents.srt cp850

Not sure about the pagesize.

Regards,
Ryan

Former Member
0 Kudos

I am in windows ...

and still stuck on this..

I can not seem to get the proper sort order.. I need to get to sort order 44

There is a GUI in windows to change sort order but there are only text descriptions.. and not ID#s so I don't know if 44 is even in the list.. I tried to change it (guessed) and got 49... so close..

Any ideas on how to change the sort order in ASE 15 to 44?

Thank you again for all your help.

-Ken

ryan_hansen
Contributor
0 Kudos

Hi Ken,


The command I used should work for you.

C:\Windows\system32>cd C:\Sybase\charsets\cp850

C:\Sybase\charsets\cp850>charset -Psybase -Srh2008vm noaccents.srt cp850
Loading file 'noaccents.srt'.

Found a [sortorder] section.

This is Class-1 sort order.

Character set for the sort order is already in the Syscharsets table.

I have a space issue on my box to test any further.

noaccents.srt should be 44.

You can try this command:

sp_configure "default sortorder id", 44,'cp850'

Regards,

Ryan

Former Member
0 Kudos

If I try to set using sp_configure I get this..

1> sp_configure "default sortorder id",44

2> go

Msg 5824, Level 16, State 4:

Server 'AIGORACLE11G', Procedure 'sp_configure', Line 1310:

Cannot reconfigure server to use sort order ID 44, because the row for its underlying character set (ID 2) does not exist

syscharsets.

(return status = 1)

But the char set seems to be there???

1> sp_helpsort

2> go

Collation Name                 Collation ID

------------------------------ ------------

altdict                                  45

altnoacc                                 39

altnocsp                                 46

binary                                   25

cyrnocs                                  64

defaultml                                20

dict                                     51

elldict                                  65

espdict                                  55

espnoac                                  57

espnocs                                  56

gbpinyin                                163

hundict                                  69

hunnoac                                  70

hunnocs                                  71

iso14651                                 22

noaccent                                 54

nocase                                   52

nocasep                                  53

rusnocs                                  59

scandict                                 47

scannocp                                 48

thaidict                                 21

turknoac                                 73

turknocs                                 74

utf8bin                                  24

nocase_eucgb                             52

nocase_cp936                             52

nocase_gb18030                           52

nocase_eucjis                            52

nocase_sjis                              52

nocase_deckanji                          52

gbpinyinnocs                             26

gbpinyin_eucgb                          163

gbpinyin_gb18030                        163

gbpinyin_cp936                          163

gbpinyinnocs_eucgb                       26

gbpinyinnocs_gb18030                     26

gbpinyinnocs_cp936                       26

Loadable Sort Table Name       Collation ID

------------------------------ ------------

cp932bin                                129

cyrdict                                 140

dynix                                   130

eucjisbn                                192

euckscbn                                161

gb2312bn                                137

rusdict                                 165

sjisbin                                 179

turdict                                 155

big5bin                                 194

Sort Order Description

------------------------------------------------------------------

Character Set = 2, cp850

     Code Page 850 (Multilingual) character set.

Sort Order = 49, caseless_34

     Case-insensitive sort order for 3.4.1 caseless database.

Characters, in Order

....

any idea why I can't set 44?

-Ken

Former Member
0 Kudos

I as able to change the sort order based on your post and the GUI available... Now I can load the backup... I just have to create all the users that own the objects.. so it actually failed..

It is now in some odd state where the recovery did not work...

I will look at it next week...

Thanks again for all your help..

-Ken

Answers (2)

Answers (2)

Former Member
0 Kudos

Hi Ken,

So you are on Windows platform ?

If you do not have the service in Windows, I would assume you do not have a bcksrvr.exe

listed as a processes in the task managers ?

If you check %SYBASE%\ASE-15_0\install  do you have RUN_YOURSERVER_BS file there

to start the backup server at command prompt ?

If not I would assume as you say it was not installed.

You can install it after a finished installtion with syconfig.exe

but I will check the install logs why it was not installed.

Rgds, Niclas 

ryan_hansen
Contributor
0 Kudos

Hi Ken,

I work in connectivity, but it sounds like the backup server isn't started
or not in the sysservers as ADNAN noted above.

Check the sql.ini file for SYB_BACKUP.

If an entry exists try to isql to it.

redhead_back

        master tcp ether redhead 4749

        query tcp ether redhead 4749

isql -Usa -Psybase -Sredhead_back

1>

Mine was down initially so this is the command on unix:
startserver -f RUN_redhead_back

Believe on windows its:
startsrv -f <filename>

example:
open cmd prompt
cd %SYBASE%\ASE-15_0\install

startsrv -f RUN_SYB_BACKUP

if this doesn't exist then there is a possiblity it wasn't built.

Regards,
Ryan