cancel
Showing results for 
Search instead for 
Did you mean: 

help!Cache status of object for Central Adapter Engine is incorrect

Former Member
0 Kudos

this problem cconfused me several days!

version:PI 7.1

after i activate the communication channel, the cache not update for central adapter engine

problem: in cache status overview, the update for central adapter engine not yet started, but notification is ok.

the update for integration server and mapping run time are all correct.

then when i display wsdl for sender agreement(SOAP sender), show message:Cache status of object abcd123 for Central Adapter Engine is incorrect

if i ignore this message, error message popup:dapter Engine af.xid.sapittest for communication channel abcd123 not registered in SLD

who can help me solve this problem.

thank you in advance.

Accepted Solutions (0)

Answers (6)

Answers (6)

Former Member
0 Kudos

after re-intall, the adapter engine is ok

Former Member
0 Kudos

and in tcode SM59 if the INTEGRATION_DIRECTORY_HMI Connectivity test ok

Former Member
0 Kudos

hi Caio Cagnani

i have follow Note 764176 - Error in XI due to inconsistent SLD contents to fix this problem two times, no effect

0 Kudos

Hi cheng,

Kindly check if you have set theparameter 'com.sap.aii.connect.integrationserver.sld.name' in your

Exchange Profile, since it's not set by default. Open note #1278563 and follow the procedures.

And you may check the following notes:

#1031321 - Self-Registration of Adapter Engine and RWB fails

#1334053 - No automatic PI 7.10 SLD Registration (Here you'll see the note 764176 which you have already applied and also the note #1117249).

In RWB, is the adapter Engine "red light"? If yes, what is the specific error?

Regards,

Caio Cagnani

0 Kudos

Hi,

Check in tcode SM59 if the Connectivity test gives the 500 "Internal Server Error". It means that it's ok.

Check the correct components and associations in SLD by following note #764176.

And last, ensure you use the FQHN in order to maintain the correct host name for your serve to

communicate through the SLD.

Regards,

Caio Cagnani

Former Member
0 Kudos

hi Chirag Gohil .

thanks for your reply!

the traffic light in sxi_cache is green.

i think the system could not find central adapter engine "af.xid.sapittest"

because in http://sapittest:50000/dir/start/index.jsp, click administration, then click "runtime", click "Data Cache Overview"

the list like this:

af.xid.sapittest Refresh Refresh

Integration Server (ABAP) Refresh Refresh

Mapping Runtime (Java) Refresh Refresh

click refresh for Integration Server (ABAP) and Mapping Runtime (Java), logon screen popup, but click refresh for af.xid.sapittest, logon screen not popup and error occur.

Former Member
0 Kudos

Check troubleshooting guide:-

http://www.sdn.sap.com/irj/scn/go/portal/prtroot/docs/library/uuid/1a69ea11-0d01-0010-fa80-b47a79301...

Check RFC destingation - INTEGRATION_DIRECTORY_HMI

Do SXI_CACHE refresh and CPAcache refreshe.

chirag