cancel
Showing results for 
Search instead for 
Did you mean: 

HANA XS Administration

Former Member
0 Kudos
2,212

Hallo together,

i started a project in my company with SAP HANA two weeks ago.

There's one point i'm not able to handle and the documentation and/or google could not help me.

So i hope that somebody here can give me a solution.

Currently i'm trying to establish a connection to an external webservice also running in my intranet.

To check my settings i wanted to look into XS Administration Page that can be accessed by /sap/hana/xs/admin/

but got the error: Request execution failed due to missing privileges.

So i asked our administrator to grant me access and i got all sap.hana.xs.admin.roles:xxx that are available.

But i still get the same error with the missing privileges.


Now my question: What i need to do to get access to the XS Administration Page?


I tried to disconnect / connect to the HANA instance, restarted HANA studio, refreshed the whole repository...but nothing helps.


Thanks a lot for you help.


Kind regards


Adam Glodek

Accepted Solutions (0)

Answers (2)

Answers (2)

aungthitlu
Explorer
0 Kudos

Hi Adam,

             As the Taner Yuksel said, you will need the administrative application privilege for your XS account. Also you will need some of the administrative privilege in general roles according to your user level. Please check the attachment.

Best Wishes,

Aung Thit Lu.

Former Member
0 Kudos

Is there any progress on this issue?

I am getting the same error. I was able to access the XS Administration Page before but now it does not even ask me the user credentials. Here is the error:

     Request execution failed due to missing privileges


I am sure that my username has the access rights to access the XS Admin Panel. In fact it is not related with access rights because as i mentioned, the browser does not ask me user name and password. . I tried it on several browsers and machines but I am getting the same error and  form based authentication window does not display. 


Is there any setting where "form based authentication" is somehow accidentally turned off?

Former Member
0 Kudos

Problem solved.

Digging into Google, SAP support pages and developer guides for several days does not give any useful result.

I've started to try updating _SYS_XS schema manually by using my "sensations" and solved the problem.

Execute the following SQL script from SQL console:

UPDATE "_SYS_XS"."RUNTIME_CONFIGURATION" SET Configuration= '{"authentication": {"method": "Form"}}' where PACKAGE_ID=''

Then restart xsEngine by rightclick on hana system->Administration->Configuration->daemon.ini->xsengine ->set instance number of host to 0 (if it is 1)-> set instance number to 1 again


This worked for me. I finally got the authentication form back again.


I suppose the problem is about choosing "Public" (No authentication required) from xs/admin page either intentionally or accidentally. After you choose this option and restart xsengine then it is not possible to see your xs admin page again. Because you select public, it is not asking authentication. But that does not mean you will be allowed to access publicly to web admin interface because of privilages. When you select public, web admin interface is not asking authentication and gives "Request execution failed due to missing privileges" error forever. You have to fix it manually by updating the _SYS_XS schema. That means you can change No public->public from xs admin page but cannot do the reverse public->No public from xs admin page because it will not be working anymore.


Hope it helps someone out there.



Former Member
0 Kudos

I think the explanation above should be corrected. Nermin's method solve the problem temporarily.

The standard solution is as follows:

Assign the following application privileges to the user who will use XS Administration Page that can be accessed by /sap/hana/xs/admin/

Taner Yuksel

CEO

http://www.infonomi.com

http://www.kurbibeacon.com