cancel
Showing results for 
Search instead for 
Did you mean: 

HANA update blocked by version mismatch of plugin

christoph_volkert
Participant
0 Kudos

Hello, i try to update HANADB and the related plugins to an new version.

I have downloaded and extracted all archives into a folder, started hdblcm and tried to do the update, but if fails constantly.

[root@hana3 HANADB_59]# ls -lah
insgesamt 4,4M
drwxrwxrwx   7 s3hadm   sapsys    149 23. Jun 16:05 .
drwxr-xr-x. 11 XXXX     XXXX     4,0K 22. Jun 15:58 ..
-rwxrwxrwx   1 s3hadm   sapsys   4,3M 23. Jun 10:47 SAPCAR_1115-70006178.EXE
drwxr-xr-x   4 s3hadm   sapsys     77 23. Jun 12:22 SAP_HANA_AFL
drwxr-xr-x   5 s3hadm   sapsys    207 23. Jun 12:21 SAP_HANA_CLIENT
drwxr-xr-x   8 s3hadm   sapsys   4,0K 23. Jun 16:05 SAP_HANA_DATABASE
drwxr-xr-x   4 s3hadm   sapsys     77 23. Jun 12:22 SAP_HANA_LCAPPS
drwxr-xr-x   4 s3hadm   sapsys     77 23. Jun 12:20 VCH_AFL_202
[root@hana3 SAP_HANA_DATABASE]# ./hdblcm

SAP HANA Lifecycle Management - SAP HANA Database 2.00.059.03.1651819148
************************************************************************

Scanning software locations...
Detected components:
SAP HANA AFL (incl.PAL,BFL,OFL) (2.00.059.0300.1651855268) in /home/XXXX/HANADB_59/SAP_HANA_AFL/packages
SAP HANA Database (2.00.059.03.1651819148) in /home/XXXX/HANADB_59/SAP_HANA_DATABASE/server
SAP HANA Database Client (2.13.13.1650313242) in /home/XXXX/HANADB_59/SAP_HANA_CLIENT/client
SAP HANA LCAPPS (2.00.059.0300.1651855268) in /home/XXXX/HANADB_59/SAP_HANA_LCAPPS/packages
SAP VCH AFL 2021 (2021.059.0300.1651844921) in /home/XXXX/HANADB_59/VCH_AFL_2021/packages

Do you want to specify additional components location? (y/n) [n]: n

Choose an action

Index | Action             | Description
------------------------------------------------------------------------------------
1     | S3H (update)       | Update SAP HANA Database version 2.00.048.03.1605873454
|                    | hana2dev3 (Database Worker (worker))
|                    | plugins: lcapps, afl, vch1909
2     | install            | Install new system
3     | extract_components | Extract components
4     | Exit (do nothing)  |

Enter selected action index [4]: 1

Choose components to be installed or updated:

Index | Components | Description
-------------------------------------------------------------------------------------------------------------------------------------
1     | all        | All components
2     | server     | Update SAP HANA Database from version 2.00.048.03.1605873454 to version 2.00.059.03.1651819148
3     | client     | Update SAP HANA Database Client from version 2.7.21.1611351107 to version 2.13.13.1650313242
4     | afl        | Update SAP HANA AFL (incl.PAL,BFL,OFL) from version 2.00.048.0300.1605893454 to version 2.00.059.0300.1651855268
5     | vch2021    | Install SAP VCH AFL 2021 version 2021.059.0300.1651844921
6     | lcapps     | Update SAP HANA LCAPPS from version 2.00.048.0300.502760 to version 2.00.059.0300.1651855268

Enter comma-separated list of the selected indices [2,3,4,6]: 1
An already installed component SAP VCH AFL 1909 is not compatible with SAP HANA Database version '2.00.059.03.1651819148'. The SAP VCH AFL 1909 '1909.048.0300.1605893771' requires SAP HANA Database version 2.00.048.03.1605873454 The update of SAP HANA Database to version '2.00.059.03.1651819148' requires also the matching SAP VCH AFL 1909 to be updated. Updates for plugins are available on the SAP Support Portal. For withdrawn plugins, follow SAP Note 2293092.

whatever i search for a solution, it always says that i have to extract the packages into the folder, like i had done and start the hdblcm, as i have done.

I#m stuck, can someone help me pls?

christoph_volkert
Participant
0 Kudos

To be clear, that's the error message:

An already installed component SAP VCH AFL 1909 is not compatible with SAP HANA Database version '2.00.059.03.1651819148'. The SAP VCH AFL 1909 '1909.048.0300.1605893771' requires SAP HANA Database version 2.00.048.03.1605873454 The update of SAP HANA Database to version '2.00.059.03.1651819148' requires also the matching SAP VCH AFL 1909 to be updated. Updates for plugins are available on the SAP Support Portal. For withdrawn plugins, follow SAP Note 2293092.

Accepted Solutions (1)

Accepted Solutions (1)

christoph_volkert
Participant
0 Kudos

OK, happily today everything is inside a VM so you can just try out and revert to the last snapshot if you are blocked.

So, just do a

./hdblcm  --ignore=check_component_dependencies

that's it. Seems like the hdblcm has a bug somehow.

Answers (1)

Answers (1)

jgleichmann
Active Contributor
0 Kudos

Hi Christoph,

this is just a workaround to install VCH2021 with the skipping option, but you also should check which component is now installed and used.

Please verify that the install/update procedure worked correctly. The normal component check identified correctly that the old plugin is only valid for revision 48.03+ but it should recognize that there is an update component. Means normally your procedure approach should work. You can uninstall the old VCH first and then repeat your procedure. Currently the old components may still in place and pop up again with the next upgrade.

Check the HANA views:

select * from AFL_FUNCTIONS;
select * from AFL_PACKAGES;
select * from AFL_AREAS;

Check the backend:

Report: VCH_HL_AFL_CHECK

Check also if the correct permissions are granted.

I recommend to open a OSS ticket to report this issue to SAP for fixing it also for other customers.

Regards,

Jens