cancel
Showing results for 
Search instead for 
Did you mean: 

HANA Express installation fails on a 16GB Intel NUC ->deactivate memory check for hdblcm?

stephan_hofmann3
Discoverer

Hi guys,

yesterday I tried to install the current version of HANA Express on a 16GB Intel Nuc Centos based. Inside the installation guide is written, that 16GB is minimum -> adding swap-file will solve some memory issues.

But the result is the following:

Installation failed -> Checking minimum memory requirement failed --> Physical memory on this host is 15.387 GB. Minimum required: 24GB.

Is there any option to deactivate the memory check -> I think the performance will be ok for my small use case.

Thanks Stephan

Accepted Solutions (0)

Answers (3)

Answers (3)

nbys
Explorer
0 Kudos

Hello Stephan,

I get exactly the same error message installing SAP HANA Express on my NUC:

Checking minimum memory requirement failed

Physical memory on this host is 15.557 GB. Minimum required: 24 GB.

Did you manage to skip this check?

0 Kudos

@Stephan,

Are you using the setup_hxe.sh script (as documented) or hdblcm directly (not supported)? Are you installing the server only or server + XSA?

Chris

stephan_hofmann3
Discoverer
0 Kudos

Hi Chris,

I use the setup_hxe.sh script as documented.

First I tried to install HANA Server, AFL and Extended Services and XSA.

Next try HANA Server, AFL and Extended Services.

Both ran unsucessfully.

Former Member
0 Kudos

Hi Stephan,

Did you do the changes in 'setup_hxe.sh' script? Can you provide the line number or command that you modified for ignoring the memory check.

Thanks,

Vish

BJarkowski
Active Contributor
0 Kudos

You can try with:

./hdbinst --ignore=check_min_mem

stephan_hofmann3
Discoverer
0 Kudos

Hi Bartosz,

I found that this parameter exists and tried it by editing the

setup_hxe.sh script. but I think I didn´t found the correct line for it.