cancel
Showing results for 
Search instead for 
Did you mean: 

HANA DB- "Some Services not started". whats the issue??

Former Member
0 Kudos

Hello,

Recently I have registered with SAP HANA dev edition on Cloudshare. Initially I was facing problems while creating a new system and connect HANA DB to HANA Studio. I could able to resolve this issue and came up with another one. I can see some services are not started when i place my mouse onto the system. After creating a new system and connection it to a HANA DB, in my DB landscape, there is one service called "sapstartsrv" is in yellow mode.

Can anyone pls let me know how to resolve this issue?

pls refer to the image attached..

Regards

Avi

   

Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos

OK, I have looked at your environment, updated your hosts file and license. Clearly, it looks like the environment has been messed up . Couple remarks:

  • Your hosts file doesn't reflect your HANA server internal IP address. Use the internal IP address to connect from your Cloudshare HANA Studio, if you want to connect from your local machine, use the external IP address.
  • The license somehow got expired and now it's updated.
  • The hdbclient seems to be missing too. I have reinstalled it and reconfigure your Studio.

That's it. You should have a working system now.

Rocky

Former Member
0 Kudos

Rocky,

At Last!!!! Its working.. Thanks a lot bro...

I am able to access my HANA cloudshare environment. All status are in "Green" mode... As you said i need to use the extrernam IP address to connect my HANA studio from local machine!. I have done that. Now its asking to configure JDBC trace properties. I have installed the latest version of HANA studio and HANA client. Along with that I have downloaded jdbc driver and configured my trace folder to sap\hdbclient . Can you pls let me know how to configure JDBC driver properly into my local machine.

Here are some screenshots. And these are taken from my local machine.

Regards

Avijit

Former Member
0 Kudos

Hi Avijit,

I think I'm missing something from you here. Why do you need to configure JDBC again? if you are working with HANA Studio alone, you don't need to configure anything else. If you are building your own application, that is another story, and yes you will need to configure the connection string, but as far as HANA Studio concerns, it should work just fine now.

Rocky

Former Member
0 Kudos

Hi Rocky,

Yes, you are right. I just unchecked that option. JDBC error is not coming now. But still it showing some services not started into my local machine. Whereas, its perfectly alright in my cloudshare environment. Is there any changes that I need to make into my local machine?? May be, as you said I need to configure the connection string!!! I have mapped the external ip with my host name...

Note: I am able to work in my cloudshare environment. I am just trying to configure it in my local machine..

thanks

Avijit

Former Member
0 Kudos

Hi Avijit,

Can you elaborate what you mean by "mapped the external ip with my hostname"? There should not be anything else you need to do unless your local machine has firewall or your network is blocking some port. I can connect to your hanaserver from my machine just fine, I'm not sure why you can't.

Anyhow, I still don't understand why you cannot work with it from your local machine. Even with the warning sign, everything still works perfectly. As I have said many times earlier, the only thing that might not work is START/STOP the database, which you shouldn't do anyway.

Former Member
0 Kudos

Hello Rocky,

Now I can connect hanaserver from my local machine. But still I am getting the "yellow" warning sign. Is it a normal thing getting a warning sign while connecting it from my local machine and no warning sign while connecting from cloudshare environment??

Avijit

Former Member
0 Kudos

it is quite normal for development machine. nothing to worry about. as I have stated, it only means your machine doesn't know how to translate "imdbhdb".

Former Member
0 Kudos

Thanks for your help and support mate!!..After 2 weeks of struggle I could able to start working on my system.

Thanks

Avijit

Former Member
0 Kudos

Hi Rocky,

Thanks for your all replies in this post, it made me to try all the things before i post my issue.

I use the Trial SAP HANA in cloudshare. I am unable to add a HANA Server to HANA Studio present inside the cloudshare VM.

I already completed a week for this trial version. I am not able to create a system or connect to Hana server.

The error message which I am getting is that "System Cannot be reached. logon data cannot be used"

Below are system and credential details:

HOST: hanacloud

INSTANCEL 00

USER: SYSTEM -> This is provided in the SAP Developercenter while signing up for an account and also present in the Readme file in VM

PASS: manager

The issue i am facing some thing different i.e., Nameserver is not running pls see below screenshot. Your prompt help will be really appreciated. Thanks in Advance

Former Member
0 Kudos

Hi Kumar,


I guess you cant give the same host name while creating a new system. Coz the same host name must have been used by someone else. Moreover you should keep an unique one to protect it from an unauthorized access of ur system.


Pls refer my response to Mr Adinarayayan. Try go ahead with all the steps. Before that, you need to delete the system which you have created and exit hana studio. If you still getting the same error, than there must be some issue with the server.  To overcome this issue in the new instance try logon to HANA server via SSH (eg. putty) as root. SUSE has a known bug regarding SSH connections. if you are not able to connect via SSH to the server. Let me know if experience as such


thanks

Avijit

Answers (10)

Answers (10)

Former Member
0 Kudos

Hello Rocky,

I'm facing the same issue and not able to add the system in my trial version.

Best regards,

Ariff

Former Member
0 Kudos

HI Ariff,

Did you signed up with AWS or Cloudshare?

Few screenshots of ur errors would give a clear picture.

thanks

Avi

Former Member
0 Kudos

Hello Avijit,

I have signed for cloudshare 30 day trial.

Thanks

Ariff

Former Member
0 Kudos

I have post a reply in your other thread with some information regarding same issue.

pls check

Avi

Former Member
0 Kudos

Hi Rocky.

I use the Trial SAP HANA in cloudshare. I am unable to add a HANA Server to HANA Studio present inside the cloudshare VM. The error message which I am getting is that "System Cannot be reached. logon data cannot be used"

Below are system and credential details:

HOST: hanacloud

INSTANCEL 00

USER: SYSTEM -> This is provided in the SAP Developercenter while signing up for an account and also present in the Readme file in VM

PASS: manager

Please help me asap.

Thanks and Regards,

Adi

Former Member
0 Kudos

Hi Adi,


Can you assign devcenter@sap.com as contributor? I have to take a further look at the machine as I found several instances were corrupted previously.

Rocky

Former Member
0 Kudos

Hello Adi,

If this is a new instance, then it takes some time for some of the services to be started/added to the instance. Did you again try after 15-20 mins? If not than, you can give it a go after the following exercises,

1. Create an entry in your local hosts file:


for Windows: C:\Windows\System32\drivers\etc\hosts.( If you are using Windows 8, you need to open the host file as follows: search>notepad>right click>run as administrator>browse the host file> open.

for Linux: /etc/hosts) -- > mapping your elastic IP / (IP address which you used in HANA studio) to the hosts name of your hana server.

*** Use the internal IP address to connect from your Cloudshare HANA Studio, if you want to connect from your local machine, use the external IP address.

2. While adding a new system, you need to provide correct hostname. ie

host: <hostname>.vm.cld.sr

instance: 00

3. In case if you changed SAP HANA server "Vanity URl", you need to use that as a Host name.

If you are still getting error message(s) with the HANA Studio (on Cloudshare desktop image) to the HANA DB after you enter the correct username or password:

a. "Error when connecting to system":

The issue seems to be caused by a corrupted secure storage file.

As a workaround, please follow the following steps:

1. Delete your HANA connection on the Navigator tab in HANA Studio, and then close the HANA Studio.

2. Open windows explorer, and navigate to C:\Users\Administrator folder on your Cloudshare desktop.

3. Find the folder ".eclipse" and rename it to "OLD.eclipse":

4. Open your HANA Studio and set your HANA DB Connection again. You will be prompted to set the password reminder for secure storage file. You can choose "No".

5. After that, the new ".eclipse" folder and the new secure storage file will be recreated.

6. Close and re-open your HANA Studio, to verify that the workaround fixed the connection issue.

Hope this helps!!..

Regards

Avijit

Former Member
0 Kudos

Hi Rocky,

I have added devcenter@sap.com as a contributor. Please have a look at my enviro and help.

Thanks and Regards,

M.N.Adinarayanan

Former Member
0 Kudos

Hi Avi,

Thanks for the reply. I tried all those. But none works. Hence assigned devcenter@sap.com as a contributor for Rocky to look at.

Thanks and Regards,

M.N.Adinaraynan

Former Member
0 Kudos

Alright!!. Rocky will surely help you out.

Are you trying to connect from your Cloudshare HANA Studio or from your local machine? From the screenshot I can make out that your hostname is showing as "hanacloud". You need to add the remaining part too. ie. hanacloud.vm.cld.sr and change the hostfile in ur windows machine..

thanks

Avi

Message was edited by: Avijit

Former Member
0 Kudos

I tried that too Avi. It did not work.

@Rocky: Can you please check my VM and fix the issue. I am keeping my fingers crossed to start working on it.

Thanks a lot guys.

Adi

Former Member
0 Kudos

Hi Adi,


I've followed up with you separately. Please check your email.


Rocky

0 Kudos

Hi Rocky:

Today started my 30 free trial of SAP HANA in cloudshare and could not connect to DB from HANA studio. Could you please look into and advise. Assigned the case to you as contributor devcenter@sap.com..

Former Member
0 Kudos

Hi Rocky

I signed for SAP HANA in AWS and facing the same issue as Avi. I did tried the secure storage file fix suggested by Avi without luck. Please advice

Former Member
0 Kudos

hi Jignesh,

what error are you getting?

post a screenshot of same.

thanks

avi

Former Member
0 Kudos

Did you signed up in AWS or Cloudshare?

My above screenshots are taken from "Cloudshare" instance.

Former Member
0 Kudos

Hi Avi,

Thanks for replying back

"sapstartsrv" is not green. I am on AWS. Do you still need screen shots?

Thanks

Jignesh

Former Member
0 Kudos

Hi Avi,

I think its a corrupt license.

Jignesh

jimguo
Advisor
Advisor
0 Kudos

Hello,

Please check if work around mentioned in note 1743225 and 1639568 helps.

Thanks.

Jim

Former Member
0 Kudos

I couldnt trace the above notes.

can you pls provide me the link for it?

thanks

avi

Former Member
0 Kudos

Hello,

I dont have username and password details to access the above notes.

is there anyway to get it?

Thanks

Avi

Former Member
0 Kudos

Hi Avi,

This is Rocky from the Dev Center team. OK, first of all, nothing to freak out because your database works just fine. You might not be able to start/stop the DB from the studio, just like said. That's it, but you can always ssh into your HANA server and administer from there.

OK, the yellow sign. While I strongly believe there is a funny stuff going on on your hosts file, I couldn't just make the assumption. Can you maybe share your environment to devcenter@sap.com? and paste entries of your hosts file here?

Rocky

Former Member
0 Kudos

Hello Rocky,

Something wrong is going on with my HANA dev on AWS cloud environment.

I am not able to locate client details. Because of which I am getting some weird error.

Can I just redeploy my machine and start my environment in new??

Let me know how do you want me to share my environment and I can send the hosts file to devcenter.

2 weeks are over and I am yet to start work on my HANA dev environment.

Would appreciate your help on this.

Thanks

Avi

Former Member
0 Kudos

Hello Rocky,

Now something new came up.

Can you pls help me with redeploy new hana cloudshare environment?

I want to strat with fresh.

Former Member
0 Kudos

Have you installed HANA Client on your laptop? That error message just tells you that you have not installed regi.exe (HANA Client for repository access). Please go ahead and reopen HANA Studio. When you see that message again, open the Repository Access preferences page and just point it to wherever you install your client to. I think the default is C:\Program Files\sap\hdbclient

Former Member
0 Kudos

Hi Avijit,

Please share your environment to devcenter@sap.com and I will have a look at it.

Rocky

Former Member
0 Kudos

I am using HANA cloudshare environment. So there is no way to reinstall HANA client. It was there before when I started initially HANA studio. All of a sudden its just vanished.. Only hanastudio folder is available. no hanaclient folder available in sap root folder in my cloudshare environment.

I m gonna share my environment.

Former Member
0 Kudos

I have already sent an invitation to devcenter@sap.com.

Former Member
0 Kudos

Hi Rocky,

I checked the 3 items you listed - entries in host file, License and hdb client. The entries and hdb client are fine in my AWS. I can't access the license or get my hardware key refresh license.

Any suggestions on how to proceed ?

Thanks

Jignesh

Former Member
0 Kudos

Hello guys!!

I am still facing the above issues. 11 days are already over, but I am still not able to work on my system. Is there any permanent solution on this or I will have to go with this for the rest 19 days??

Would appreciate a positive reply.

Thanks

Avijit

Former Member
0 Kudos

Hello Myles,

I have tried this solution too. But no changes!!. Network Connections comes under "General Tab"

Window -> Preferences -> General-> Network Connections -> Active Provider.

I have contacted with SAP Dev team. They its not a major issue. My database will work fine , but I will be unable to stop/start the instance from HANA Studio.

Guess I will have to go with that!!!..No other options left..I wanted to go in depth of this problem.


Former Member
0 Kudos

Hello Guys,

I have tried all possible ways..Still I am facing the same problem. I have mapped elastic IP  with my local hosts file. And also checked the ip address of my cloud environment. And its matching with the IP address  I've used in HANA studio. But same issue cropping up!!!

any further suggestions on this pls?

mylesfenlon
Participant
0 Kudos

Hi Avijit,

You could try this solution:

In the SAP HANA studio, choose "Window -> Preferences -> Network Connections -> Active Provider and change the value from "Native" to "Direct".

I am not saying this will work, but it's another suggested solution to similar problems to yours.

mylesfenlon
Participant
0 Kudos

Hi again Avijit,

If you haven't tried Kumar's suggestion, then you should certainly try that. Despite the apparent nature of the problem, it is related to the Studio not being able to reach the server.

Try that, and let us know if you still have problems.

Former Member
0 Kudos

Hi Avijit,

You may know, the IP address of  cloudshare envirnoment is dynamic allcation, so you have to check IP address every time, when you will use SAP HANA stutdio in local machine, and you have to chang IP address, if the IP address was changed.

It should be normal in your windows machine of cloudshare environment, please check.

Anyway, you want to use HANA stuidio in local machine without yellow color, you need to change IP address, if you found it not match with current setting IP address.

Besides, it has no impact for your using HANA stuido for any active, though the color is yellow.

Hope this can help you.

Regards,

Jerry

former_member184871
Contributor
0 Kudos

Hi Avijit,

Create an entry in your local hosts file:

for Windows: C:\Windows\System32\drivers\etc\hosts,

for Linux: /etc/hosts) -- > mapping your elastic IP / (IP address which you used in HANA studio) to the hosts name of your hana server.

Eg:

ELASTIC IPHANA HOST NAME
XX.XXX.XXX.XXhanacloud

Regards

Kumar.

mylesfenlon
Participant
0 Kudos

Hi Avi,

If this is a new instance, then it takes some time for some of the services to be started/added to the instance. Try again after 10 or 15 minutes, and see if they are running then. If not, then there might be another issue but not one that I am familiar wth.

Myles

Former Member
0 Kudos

Hello Myles,

Thanks for your response.

I have started my server after an hour. But still the same!. Not able to figure out the problem.